Gettich Logitech QuickCam Communicate STX to work


I’ve got a Logitech QuickCam Communicate STX webcam. According to this website, this webcam works under Linux; however, when I open Cheese, I get only a screen full of colored bars (like what you see on a television channel that’s off-air), and in Skype I get green snow.

Can anyone help me get this working?


Sorry for the typo in the title of the previous post; it should, of course, have been “Getting Logitech QuickCam…”. Brain ahead of fingers!

(Is there no means to edit your own posts? The “posting rules” at the bottom say “you may edit your posts”, but I couldn’t find an edit button anywhere…)
EDIT: OK, Now why does THIS post have an “edit” button, but the first one does not? AARGH

Further update to the above: I happened to discover, eventually, that there is a separate “quickcam” package for OpenSUSE – I couldn’t figure out why my webcam, which was supposed to work with the V4L package, wasn’t working with the V4L package installed. With the quickcam package installed as well, the webcam now works in Skype.

However, I still only get colored bars and no picture in Cheese – anyone have any ideas why the webcam would work in one app but not the other?


I have the same webcam and I have the same problem (green screen in skype).
I have not installed V4L package and I tried to install quickcam-kmp-default. Then I tried to test the webcam and the skype terminated…

Before I try to install quickcam-kmp-default I had install the driver from but I never uninstalled it (Because I didn’t know how). Might it be the problem?
If not, is there anything else you did in order to have the camera working?


PS:I’m really new in linux…

I have the same problem with 11.4, yet my Logitech Quikcam Communicte STX works perfectly with 10.3. I got it to work with 11.3 also. What has changed – and why? !!!


#> /etc/SuSE-release
openSUSE 11.4 (x86_64)
VERSION = 11.4
CODENAME = Celadon

#> uname -a
Linux MyLinuxBox #1 SMP PREEMPT 2011-04-25 21:48:33 +0200 x86_64 x86_64 x86_64 GNU/Linux

#> lsmod | grep -i videodev
videodev 81448 1 gspca_main
v4l1_compat 17505 1 videodev
v4l2_compat_ioctl32 10573 1 videodev

Lösung könnte also sein:

  1. Packman Repository einbinden
  2. libv4l installieren
  3. skype starten mit
LD_PRELOAD=/usr/lib/libv4l/ skype

BTW: ich starte Skype immer zwei Mal hintereinander; beim 2. Mal geht dann auch Video…