Generate autoinst.xml?

Leap 15.1

yast clone_system “looks” like it’s working, but there’s no generated autoinst.xml file. What am I missing?

Hi and welcome to the Forum :slight_smile:
AFAIK, once you have it all configured from the GUI as required, File -> save, browse to where you want to save it (eg /root/) and call it autoyast.xml, check it with jing.

While this document is for Leap 15.0, it’s still valid:

Thanks for the response, but my question is a bit different.

While I can enter the configuration tool and make a variety of changes and save the resulting file, I want to use the previously functional tool that will collect data around the currently installed system and auto-generate a file to use as a starting point. From a CLI, the command is:

yast clone_system

When you run this, you get a message on the screen that says:

Cloning the system...
The resulting autoyast profile can be found in /root/autoinst.xml

That file is never generated, though, and doing a filesystem-wide search for autoinst.xml yields zero results. I have done this on previous builds quite a bit, but it has been a while. I’m wondering if some level of functionality around this has actually been removed, or if maybe there’s a package that isn’t installed that isn’t triggering correctly as a dependency.

Ahh ok, my bad.

It does take a little while to produce, I see the screen, wait and then it starts doing it’s thing and exits, I see the file generated;

-rw-r--r-- 1 root root    119135 Jan 10 15:48 autoinst.xml

Also tested in Tumbleweed and works fine.

The file is never generated on my system. It must be a missing package as I did a minimal server install, added DHCP, DNS, and file server items and then added the autoyast package.

That would likely be the cause, a missed requires in the packages for a minimal install. If you open two terminal sessions, in one try tailing the YaST log and re-run your command;

tail -f /var/log/YaST2/y2log

There could be other files in that directory with some pointers to missing files…

Good idea, but gigantically unhelpful. That log is fed info at an alarming rate of speed and it’s super hard to determine if things are errors in areas like package dependencies, or if it’s just trying to indicate that certain packages aren’t installed or configured for inclusion in the file.

You can cat the log afterwards then and then grep for error or missing or other keywords, libsolv, librpm?

For example;

cat /var/log/YaST2/y2log | grep librpm
cat  /var/log/YaST2/y2log | egrep "librpm|libsolv|error"
less /var/log/YaST2/y2log (press the space bar or arrow or page down)

I should have mentioned that I have over 25 years of experience with Linux, over 15 years with SUSE flavors, and have been running various SUSE linux machines at home for years and years. This issue is one I have not run into in the past, and scanning for errors has turned up nothing.

The y2log file is loaded with ‘errors’ that are clearly not related to things like missing packages or faults in the process but are, rather, indicative of things like searching the system to compile the autoinst.xml file and finding installed packages not configured or used or finding that packages are not installed and therefore shouldn’t included in the resultant file.

Sadly, unless someone explicitly knows the required packages for this to work (assuming it still DOES work - I have read a few things here and there that seem to imply the functionality may have been removed at some point), I’ll have to step through a process of adding packages until I get it to work.

Missing package for sure, but by default when I ran the yast configuration tool it installed them, but it could also be the JeOS image still lacking packages to detect and pull in.

I have the two autoyast2 packages installed.

It’s functional for me on Leap 15.1 and Tumbleweed both systems creating an autoinst.xml file. Both run GNOME, not JeOS, I run JeOS systems (Leap 15.1, SLES 15.1 and Tumbleweed) on my RPi3’s, let me test on Leap 15.1 aarch64…

zypper in autoyast2

The following 3 NEW packages are going to be installed:
  autoyast2 libxslt-tools yast2-schema

The following package is going to be upgraded:

yast clone_system

-rw-r--r-- 1 root root 37801 Jan 11 16:53 autoinst.xml

I wonder if it’s the presence of the X system on yours, and the subsequent additional Yast2 packages that are GUI based…

All my RPi3’s are console based in fact boot/setup over serial interface as don’t even have a keyboard or screen attached… no Xorg installed or running.