garbled screen with fglrx driver

Hi there.
I’m very impressed by the new opensuse 11. Amazing work, and it installed very fine. No problems.

But…I now need some help to figure out why my desktop screen fail after updating to fglrx driver.
Nothing works, and the screen is very messed up. Except the mouse cursor is movable, but nothing else works.
Ati radeon HD 4850
Hitachi LCD tv, connected with DVI - HDMI ( could this be the problem? )
Amd 64bits
4GB ram.
OpenSuse 11 on KDE

could it be newest xorg that is the problem? I used the “one click installation” to install the fglrx driver.

Have tried aticonfig --initial
Before i tried fglrx driver, xorg had the radeonhd driver installed.
I also have crawled the web to see if I could find a solution but to no help…

Hi Ultra-magnus. I’m assuming you installed as per this (openSUSE 11.1) guide. Are you sure you installed the correct driver for your hardware? And did you do this step at runlevel 3?

SaX2 -r -m 0=fglrx

You may also need to try the command line method (outlined in the guide), if you have problems with the ‘1-click’ install method.

Note: The 1-click links in that guide are only for openSUSE 11.1

You may better adding the ATI repository from here, to install the drivers.

Hi! Thanx for replying.
unless there is a specific driver for Radeon HD 4850, or 4xxx series, i think i tried the right drivers.
Is there really a 4xxx driver @ ati ?

also tried
SaX2 -r -m 0=fglrx
It doesent help…
It seems opensuse really tries to make it work, but it always fails with strange huge fonts, non working desktop and so on… even CTRL+ALT+F2 and so on doesent work… it freezes if i try.

i have copied the xorg.conf-original to xorg.conf, so i now run with the radeon hd driver wich opensuse initially installed for me.
Kind Regards

edit: i downloaded the opesuse 11.1 dvd yesterday and installed it.

edit: i downloaded the opesuse 11.1 dvd yesterday and installed it.

So your using openSUSE 11.1 now… Maybe you should try the commandline method outlined, using the driver from here.

i have copied the xorg.conf-original to xorg.conf, so i now run with the radeon hd driver wich opensuse initially installed for me.

Thats sensible. At least you can always return to a working state.

Anyone else have any ideas about this?

I realize there IS a specific radeon driver for 48xx cards by going to drivers page…

I will try their driver and see what happens, but I feel this will not work, as I realize now I have tried this with Debian Lenny, and with same results…

I’m beginning to believe this is related to rotten drivers from ati…
Look at this post:
Radeon is the most buggy graphic card - openSUSE Forums

Please tell me, that post isn’t related to my problems… :slight_smile:

I must ask again… could this be because of xorg version 7?
some bug with my graphics card and the Xorg system?

Thanks again deano for your response!

I also should tell you that the driver upgrade to fglrx have “screwed” up my desktop even when using the radeonhd driver:
screensaver does not work as intended,
taskbar is pushed to about half of the lower screen, ( had a segment fault error )

the kde desktop is now generally slow when trying to respond to my mouseclicking on anything. The greeter, xdm? kdm? is also garbled and presents my login credentials with immensely huge fonts and i need to use the tab key to enter my user and pass.

Im trying the command line way, but with older drivers from ati to see if that could work… version 8.10.

no good ofcourse, because older drivers dont support suse 11.1
trying to reinstall, but only this time I wipe out my older /home directory from debian lenny…
Could it be that one? hmm…

ok I give up linux for now I think…
reinstalled suse 11.1 with formatting the partitions…
once installation was done, the installer tries to autodetect settings and so forth…
and desktop shows up but in some insane resolution like lower than 320x200 or something, and with nonresponsive buttons in kde…

try to modify xorg.conf with 1024x768 settings on everything, but after /etc/init.d/xdm restart
the desktop comes up showing the exact same thing…

What have the xorg coders and ati been up to?
I guess this works great on laptops, but for one who likes to have a quiet htpc in his livingroom connected to a LCD TV, this is not the future :frowning:

Back to the non secure winblows xp… or maybe I should install wintendo 7, and watch some good old blue-screens of death…

Sorry people, this sucks… :frowning:

Unless someone can help me…

Have you tried ATI/The Hard Way - openSUSE.
I have got an ATI HD 4650, upon fresh install SUSE 11.1 does not detect my system resolution correctly. The solution is to open Yast → hardware → Monitor and Graphics display(Something like that, I am at office so cant access my SUSE system right now). There configure the monitor display correctly.

After that install the ATI driver using the “Hard Way”.

You should not get disappointed. This is the way of life in Linux. Sometimes things work and sometimes they do not :).

TO reassure you, I got a ATI HD 4650 graphics card which worked fine when I was on Linux kernel 2.6.27(I had installed “The Hard way”). Due to some reasons I had to upgrade to Kernel 2.6.31 and then somebody told me that ATI drivers do not support Kernel 2.6.31 :)… So right now I am having a graphics card but can not use it…

Use this if you have opensuse 64 bit installed. Otherwise go with the 32-bit steps on the same page ATI/The Hard Way - openSUSE.

And after installing the specified libraries proceed installation this way after you have acquired the drivers from ATI Site: ATI/The Hard Way - openSUSE

Thanks for responding everyone!

I think i will do yet another fresh install of opensuse, then follow “the hard way” for 64bit users.

Could it be that I need to use the 32bit version or is this not relevant?

I must point out something I dont quite understand… How does opensuse 11.1 detect my LCD 37" Hitachi tv and adds it to xorg? What software does it use to find out this?

I have tried:
Debian Lenny, ubuntu, linux mint, fedora, and some other distroes, but NONE have even come close to what opensuse 11.1 have tried to fix for me automatically when it comes to screen and resolution.
When this part fails, the noobs, like myself, give up…

But, since you people are kind enough to help, I will not give up just yet, and give it another try.

I’ll be back :slight_smile:


desktop completely garbled and unusable after install…
doing the 64bit hardway from console…

installation failed once again…
when fglrx driver is present in xorg.conf, desktop becomes unusable and non responsive. Not even safe mode works.

when using radeonhd driver it works partially, but if I change from console to desktop everything freezes.

Does someone with radeon HD 4xxx card have another good HOWTO?

Would you try 32 bit system? If you can…

Well, I have been tampering with this problem for some time now, and could it also be problem with the tft TV, and the connection from my PC…??
I dont think the 32bits version will do any more good… It doesent make any sense?

Correct me if im wrong, but this is my connection:

Gigabyte motherboard (GA-MA78GM-S2H) with integrated gpu,(Integrated ATI Radeon HD3200-based graphics) disabled in BIOS.
Asus Radeon HD 4800 gpu with 2 DVI connectors.
Using a connector like this:

To a HDMI cable, connected to the Hitachi TFT LCD 37" TV.
When booting the OpenSuse 11.1 DVD, it has connection to the TV during entire graphical installation.
But, when all is installed and you are about to see KDE desktop for the first time… it manages to mess things up, and the screen gets garbled and you see immensely huge text on white bacground. You can press ESC key and it goes away. You see the KDE desktop, but you cannot click on anything…

So… before installation is done, all works…

Is the installer using the VESA driver?
And when installation is done, it writes all to xorg.conf and adds the radeonhd driver?

Is this correct? And does anyone here think my connection can have something to do with my problems?

Want to confirm that it is not possible to install or use linux when using dvi - hdmi connection, to a TV.
Im now using a VGA cable.

DVI - dvi to vga converter - vga cable - vga input on TV.
did a
aticonfig – initial
and im now running OpenSuse 11.1 :slight_smile:

Thanks for the update. :slight_smile: I wonder if this is a HDCP compliancy issue.