Games won't run...


I’ve tried to install a lot of games on OpenSUSE most which doesn’t work. It bothers me that I can’t make Tremolous and AlienArena work. Tremolous keeps coming up with some install errors. AlienArena claimed to be installed correctly, but won’t start. Nothing happens when I press the game icon. As far as AlienArena goes I think maybe the game engine/3d engine is missing. Does that make sense?

I’ve tried installing Tremolous through the ‘Install Software’ that installation works, but the same happens as with AlienArena. I tried going to openSUSE Game Store And download a .yum file from there. This installation doesn’t work. It claims it can’t connect to the repository.

How do I fix this?


i only play quake 3 arena now…

but back in the days when i tested other first person shootings, like cube or sauerbraten; it worked by installing the .tar.gz source file, not the rpm.

so, have you tried installling them from source?
usually the install and start-up instructions are inside the file.

hope this info helps.

I don’t know how to do that. I downloaded a zip file from here:
Alien Arena - a fast, fun and free FPS!

But I don’t know how to use it. I’ve unzipped it. I need to type ./crx in the terminal to run it, but I get the following error:

./crx: error while loading shared libraries: cannot open shared object file: No such file or directory

I guess I’m missing something?


Yep it is something missing. If you open YaST and go to “Software Management” you should be able to do a search (left hand side top of the window is a search box), It basically means a “dependancy” is not there. In this case it’s the libjpeg package. If your running 64 bit make sure to select both the libjpeg and libjpeg-32bit package’s.

I tried adding libjpeg-devel and libjpeg-devel_32 or something like that I couldn’t find ‘libjpeg’ and ‘libjpeg32’ But these seems to be installed already:

I hope you guys can see the image…

I get the exact same error message…


Yeah look’s like you have them… have you posted on the game’s forums about it?

It sounds like it’s looking in the wrong places… I don’t play them… but I’ll install them later and see what I get.

Well seems Tremulous (from YaST) for me give’s a opStack error, and AlienArena fails on a crx bug aswell…

I’ll have a hunt around see if I can find a solution for it.