Full support for Navi/Navi2 is here: AMD released Radeon™ Software for Linux® 20.50

https://www.amd.com/en/support/kb/re…ed-linux-20-50
https://www.phoronix.com/scan.php?page=news_item&px=Radeon-SW-Linux-RX-6700-XT

                                                     **Radeon™ Software for Linux® 20.50 Highlights**
  • Provide support for the Radeon RX 6700 XT Series of graphics cards
  • Introduce full support for RHEL / CentOS 8.3
  • Introduce preview support for Ubuntu 20.04.2

To use the Vulkan driver in this stack, Vulkan SDK version 1.2.148 needs to be installed. The SDK can be downloaded from: https://vulkan.lunarg.com/sdk/home

  • full support for SLED/SLES 15 SP 2 (= openSUSE Leap 15.2) for Navi/Navi2 (RX 6900/6800/6700 & RX 5700/5600/5500/5300).
    amdgpu-pro-20.45 driver was not available for SLED/SLES 15 SP 2.

Changes to OpenCL perfomance with SLED/SLES can occur due to changing drivers from 20.40 PAL to 20.50 ROCm-based.

Not a request for hep. Will shift to General Chit-Chat.

Has anyone tried this on OpenSUSE Leap 15.2? When I try to install it, it ends with a warning that dkms failed to build the amdgpu module. Looking at the make.log, I guess there is some mismatch or incompatibility between the module (which seem to be from Linux 5.9) and the installed kernel (5.3). This seems like a new issue. Former versions of amdgpu-pro did indeed work on OpenSUSE Leap 15.2. Is anyone else seeing this?

Hi
I’m on Tumbleweed, but don’t install the amdgpu module, no dkms just legacy/rocr.

Thanks for the hint. I have now installed the non-pro variant of the driver package with the --no-dkms switch and OpenCL is working which is basically all I need. With earlier versions of the amdgpu-pro driver, I had attempted to install only the OpenCL part but that never worked for me - either clinfo showed no devices or the graphics stack didn’t work at all (meaning I didn’t even get into a graphical session and had to restore the system from the console). Hence I simply used the amdgpu-pro stack in the past. But with this release the following worked and doesn’t involve building of modules:

sudo ./amdgpu-install --no-dkms --opencl=legacy
or
sudo ./amdgpu-install --no-dkms --opencl=legacy,rocr

I ended up using the former (i.e. omitting the installation of rocr) since the rocr implementation seems to be way slower with my particular hardware and application.