fstab question

I did a fresh install of tumbleweed today using the latest snapshot 11122019 and plasma kde as my desktop. I have windows 10 also on my p/c and share data, between the two systems, using some ntfs partitions. As usual when I do a new install of tumbleweed I add mount-points for the data drives to be mounted at boot.

The difference today was that the data drives were mounted on a read only basis. The end of the relevant fstab entry was:

/windows/g ntfs fmask=133,dmask=022 0 0



part is new, until recently the relevant fstab entry was:

/windows/g ntfs defaults 0 0

I also did a new install of the latest leap 15.2 snapshot, on an old p/c with a similiar set up, and that has also been changed to use the:


format. Changing the fstab’s on both computers to use:


restored the write access to the data drives.

I am just curious as to why the change and what:



For the meaning of the fmask and dmask mount options, see

man 8 mount

Non-Linux file systems do not have permission bits connected to files. That means that on mount these are faked. But which values to fake? This is defined by the masks. Being masks the bit sin the masks are swittched off on the file permissions, thus fmask=133 results n all file permissions being faked as 600 or rw-r–r-- and for directories dmask=022 is feked as permissions 755 or rwxr-xr-x. This means only the owner can write into thje files and can create/remove files.

Thus it is NOT, as you thought, mounted read-only. It is the individual files permissions.

Now it is important to know who is the owner that can write to files and can create/remove files in directories. That is by default the user that mounted the file system (which can also be changed with mount options), which is root in this case. So root can write, etc.

When this is defaults, the mask values are taken from the process mount process. Apparently they are allowing more.

I have no idea why things have changed. But as you say that you “when I do a new install of tumbleweed I add mount-points”, you did that yourself. Either you do this by editing /etc/fstab, in which case you typed it all, or you use YaST > System Partitioner, where you can add the options to your whish.

hcvv - many thanks for posting. your comments make complete sense.