FSTab, cifs and 'guest' login

i’m trying to setup a permanent CIFS share from my nas, but it keeps prompting for a password dispite GUEST access set on the share.

FStab is as follows:

//        /mnt/nas1_media/     cifs            guest,_netdev         0 0

if i do

sudo mount -t cifs // /mnt/nas1_media

then i get a prompt for a password and once password is used, it is successful.

password appears to be my local user SUSE password, and not one that is set on the NAS.

i dont think im doing anything wrong, since im using anonymous login on a previous ubuntu install and windows; neither requested a password. im guessing my unfamiliarity with SUSE is causing me issues :wink: what do i need todo to get connection to the share, without passwords

I have a similar problem. Even though I have a credentials file defined, mount still prompts for a password. The verbose output shows that it thinks I’m trying to mount as a different user:



mount.cifs // /root/netdrive_2 --verbose cifs acl,credentials=/root/.netmount,file_mode=0600,dir_mode=0700,uid=root,gid=root 0 0

mount.cifs kernel mount options: ip=,unc=\\Volume_2,ver=1,user=fred,pass=********
mount error(13): Permission denied
Refer to the mount.cifs(8) manual page (e.g. man mount.cifs)

This appears to be new behavior in 11.3, because I’m using the same fstab that I had for 11.2 (and there it worked fine)

since i was so new to oSUSE, i didnt get chance to try cifs mounting; 11.2 for a day and now im on 11.3 which is where my problems are.
i cant say if the problem was evident in 11.2.

i do know i’ve had the same share mounted fine on ubuntu though (as an anonymous, no login permissions mount); nothing has changed on the NAS so seems to be something in oSUSE…

edit: i do get sucessful mounting via commandline (mount -t cifs …) with the password, but the point is i shouldnt be prompted for any credentials

Just checked the release notes. It appears there have been some temporary fixes to enhance security. I don’t really understand them, but I suspect that it is the cause of the change.

the way i read it, is you cant ‘sudo’ mounting a cifs share in a certain way (without refering back to it, i cant remember exactly), and since i can mount cifs correctly then im not affected by that security flaw/fix/whatever. :confused:

Hmm, weird. I have been seeing the same problem: I have an old credentials file from 11.2 which has always been working, and now with 11.3 it prompts for a password (which it shouldn’t do) and then fails:

mount.cifs kernel mount options: ip=192.168.xx.xx,unc=\server\my_id_on_the_server,credentials=credentials_file,uid=1000,gid=100,ver=1,user=local_user,pass=******
mount error(13): Permission denied

Look at it closely! It shows the local user name as “user”, but if I understand it correctly that should be the server-side name. So it looks as if it isn’t picking up the username from the credentials file. When I run it all manually on the command line with an explicit “user” option it works just fine…

Is this a bug or part of the security enhancements?