[fritzing] Can only use this application once

Greetings !!

I used this application to explain how works serial/parallel electronics to my students.
I did two marvellous svg files with the schematics for my courses.

BUT now, fritzing couldn’t open again :{

I removed reinstalled, wiped out all related to fritzing, installed again, same behaviour.
I git’d the application it was worse, after installation and then first launch I had to kill the startkde process to get back to a normal behaviour of the whole system.

I now have wiped out again all related to fritzing…


That sucks ;{ I really love the way it is easy to draw Arduino schematics with this application.
Can not understand why this application only worked once.

I did symbolic links to ~/.local/share/fritzing and ~/Documents/fritzing replacing the “parts” folder to the /usr/share/fritzing/parts folder where all the ‘not found’ parts where, without success.

You have to delete the /usr/share/fritzing/parts/parts.db file each time, in order to launch the application again :{

This file is created and has a 0 size :{

Bug report in order probably…

However, it looks as if fritzing is perhaps no longer under development, as the last version appears to be 0.9.0b (July 14, 2014).

The page: http://fritzing.org/download/known-issues/ has a link for bug reports: http://fritzing.org/forum/bugs which returns “We’re sorry but that page could not be found.”

I suppose you could create a script to launch the program which first deletes the offending file…

OTOH, their forum at http://forum.fritzing.org/ seems to be alive. Last post from yesterday.

Try this:
Unpack the download, in f.e. ~/bin/ . Do not run the installer script, but do

cd bin/fritzing-0.9.3b.linux.AMD64

The first thing it did was tell me there was an ‘updated parts’, which it downloaded, and installed. Then I had to restart it. I have no clue on how it works, but the application starts fine, and when I shut it down, I can start it again without issues. BTW the last one is from 2016, so the culprit might be that your system is too new. But, it seems to work like this.

A bit more:
Looking at the install script, I suspect you ran it as root. Which, from what I see, you shouldn’t.
FWIW, which version do you have?

New pre-release out 21 days ago…

Sorry for the lateness… I did effectively a script in order to set a workaround, I’ve been contacted by the developpment team they are working on it, I guess the issue is now solved.

Looking at the install script, I suspect you ran it as root. Which, from what I see, you shouldn’t.

As I administrate the test system I log always in root because I hate sudoing ^^
This is not a production computer, I’m a teacher and have nothing to do with “risks” using command line as root.

I did not dug in the install script, indeed if there is some stuff done when you are not “root”… maybe the issue comes from that situation.
No warning nore error in install logs nore logs.

I did a script that runs fritzing and then remove the parts.db file once the application window closed, easy…

FWIW, which version do you have?

The version is BETA 0.9.3 would probably try the newest version if really needed, now it is working perfectly that is a real pleasure ^^