Fresh install of opensuse leap 15.2 dual boot with windows 10: Can't get grub to show up


I bought a new notebook with a NVMe SSD disk and windows 10 installed.

I added a new SSD to it and installed opensuse leap 15.2, after the restart, grub does not show up and windows 10 boot directly.

I read a few posts about disable fastboot and hibernation in windows 10 and also to configure my bios to AHCI. I did all these configurations without success.

To load my opensuse I need to press F7 and select to boot from my SSD.

Here are some pictures of my BIOS and also my grub.cfg

P.S: If you prefer, i can upload these files in another drive other than OneDrive :slight_smile:

One of those BIOS screens shows an option for “opensuse-secureboot”. Have you tried setting that as the default?

To solve this you just have to change the boot priority. I guessed it already before looking at the pictures as it is clear from what you wrote: The system came with one drive pre-installed and you added another one. So, just adding a drive isn’t enough - but you have to tell the UEFI to use that new drive as the boot drive so grub actually gets bootet. What happens when you press F7 is called manual boot override.

First of all, thank you very much for your help.

Changing the boot order solved the problem (yeah, after years of using dual boot i just ignored the boot order).

But something is wrong. After change the boot order, i’m able to see the grub screen and boot in both S.O. but when i shutdown and turn on again, windows don’t boot anymore.
The message says that grub was not able to read the bootmgfw.efi in windows partition.

Anyway, this is a problem that i will try to solve and open a new thread if i can’t resolve by myself.


Sorry for the late reply - wasn’T active for some time here.

It sounds like you using Windows 10 it is set to its default fast boot option. There’re several forums and threads about issues with this feature. From as far as I understand this it seems to be a very specific feature for faster boot time only working correctly when the uefi is set to fast boot and win10 is the only os. As soon as you start change any settings it seem to fail about 9.9/10 times and can cause additional issues, like your ones, in anotehr 1/10 - 5/10 cases.
The only idea I may can give you is to disable fast boot in win10 for it to shut down normal. To do this you have to follow some oddly specific steps:

  1. make sure hibernation is active - yes, for whatever reason - if you have hibernation disabled the option to change fast boot mode does not show up - so, if you don’t see it in the following steps (re-)enable hibernation by: powercfg /h on
  2. open system control
  3. go to power settings
  4. while click on “change what happens when power button is pressed” hold shift pressed (M$ really likes hiding features behind shift being hold)
  5. you now should see additional options - one of them should be fast boot
  6. tick off the mark at fast boot
  7. just to make sure reboot it while holding shift while click on reboot (for some odd reason this can be used as an temporary override to disable fast boot) and reboot the machine
    If this still doesn’t work maybe try to re-setup grub - may it got a hickup or some …
    Hope you can work it out, would be nice to get some feedback.