fresh install of kdenlive fails

I just attempted to install KDEnlive fresh on 12.3 and it is failing. I tried it via yast, and it will not work. I then went to opensuse file download and did the one step install. Same issue.

It is missing dependencies. This the third time with different apps that the program fails because missing dependencies… When attempting to fire up the application via the icon, it pops up with "Can not find your MLT installation, please give it a path: /usr is the default. Selecting this, and it disappears. Attempting to run the program from the bash prompt results in:

kbuildsycoca running…
DCOP Cleaning up dead connections.
KCrash: Application ‘kdenlive’ crashing…
Could not find ‘drkonqi’ executable.
KCrash cannot reach kdeinit, launching directly.

Not sure what else needs to be done. I tried to install MLT, and it also fails with additional dependencies. I thought the whole idea with RPM and the libraries, was so that the installs could be fairly painless, but all of a sudden it is becoming painful. What am I doing wrong? This is a fresh/clean install of 12.3.

And which kdenlive version do you have installed?

For 0.9.6 from Packman, enter as MLT path:


for the version from the standard openSUSE repo (0.9.4), enter:


It should work then.

And report a bug about the wrong default. I may have a look at this myself next week though…

Hm, I just tried it now after deleting my config, and it worked just fine without having to enter anything. So there doesn’t seem to be a wrong default…

So maybe you have a config file left from an earlier version? (the MLT path is stored there)
You could try to remove it before starting kdenlive, it’s ~/.kde4/share/config/kdenliverc .

The problem is that the mlt path includes the mlt version so that you can install different versions simultaneously… (programs need exactly the version they are compiled against)
So if there still was /usr/share/mlt-4/profiles/ f.e. in the config, it couldn’t be found anymore with libmlt5 or libmlt6 and kdenlive asks for the correct directory then.

Oh wait, I overlooked that:

Did you install and try to use the KDE3 version? (kde3-kdenlive)
That’s ancient! That doesn’t even work with the current libmlt6 from Packman but needs the old libmlt4, which is not even available anymore for 12.3 AFAICS (at least no unrestricted version on Packman).
No wonder you got missing dependencies… :wink:

I would suggest to add the Packman repo (kdenlive doesn’t make much sense without all the multimedia codecs anyway I’d say :wink: ) and install kdenlive-0.9.6 from there.
URL: [noparse][/noparse]

Or, if you don’t want to do that, just install “kdenlive” from the standard oss repo (0.9.4) with YaST or zypper.
You won’t be able to open most multimedia files then of course…

There were some other posts concerning this package recently. I run a video editor very very occasionally so wondered what I might use next time I want one.

If Kdenlive isn’t supported any more this one may be of use. Described as professional.

Cinelerra :: a video editor and compositor for Linux

Seems rpm’s are maintained on packman but I wonder what happened to the unofficial opensuse multimedia repo. Codecs always cause problems.


Update: When that drive failed, I tossed it into my suitcase (on the road) and threw a 12.2 disk into that laptop. Got home and can’t find the disk. I either left it in the hotel, or it will show up. Sorry. More later. So will be on an older version for awhile.