Fresh 13.2 Install - Wireless Problem


I’ve reviewed all the sticky notes as well as reviewed many of the threads. I’ll try to provide as much info as possible. I have a Broadcom BCM43228 802.11 a/b/g/n built in Wireless adapter. I did have to connect wired in order to download from packman the Broadcom drivers. At one point last night, it did connect wirelessly, but now it’s not.

Under YaST > Network Devices > Network Settings > Global Options, the only option I have for Network Setup Method is Wicked Service. Last night, I had to edit the card’s settings, under the General tab, select At Boot Time for Activate Device, and enable DHCP. I click next, and for Operating Mode, I have Managed, select my Network Name (from Scan Network), and set the Authentication Mode (also entering the Encryption Key). That process seems odd to me as I’m used to an interface where I can select the scanned network and it would detect the Authentication Mode and allow me to connect after entering the password.

I run sudo ifconfig, and there is an entry for wlp2s0, but no IP (obviously). I run sudo iwlist scan, and my wireless network does appear.

What else is necessary for someone to assist me? Also, is there an interface like I describe above that will show the available wireless networks and allow me to select the one to which I want to connect?

Thanks in advance,

You should manage the network with the network manager at your desktop

Well, if you installed the Broadcom drivers, it should work.
To be sure, can you please post the list of packages installed?

rpm -qa | egrep "kernel|broadcom"

But if you did connect already, that should be ok.

Under YaST > Network Devices > Network Settings > Global Options, the only option I have for Network Setup Method is Wicked Service.

You should be able to choose between “Wicked Service”, “NetworkManager”, and “No Network Service”.
Try to click on “Wicked Service”, a chooser should open and show these 3 options.

I would recommend to switch to NetworkManager for wireless in particular, there are still problems with Wicked (another update that should fix the most outstanding ones is on the way though).

Then use your desktop’s network icon to connect.

Hi everyone,

I need to apologize. I did not see the Network Manager option. I did switch to that, and that worked until updates came down, and I needed to reboot. Now, the wireless card is greyed out, and the network manager icon has a red X.


Here’s some info that will hopefully help me get the wireless card active again:

output from rpm -qa | egrep “kernel|broadcom”

output from uname -a
Linux #1 SMP PREEMPT Tue Apr 14 07:11:37 UTC 2015 (93c1539) x86_64 x86_64 x86_64 GNU/Linux

Please…any assistance will be most appreciated! Do I have a driver conflict?


Not really a conflict, but you just haven’t installed the correct driver for the kernel that you are using.
For kernel-desktop you need broadcom-wl-kmp-desktop, not broadcom-wl-kmp-default.

I’d recommend this:

sudo zypper rm kernel-default broadcom-wl-kmp-default
sudo zypper in broadcom-wl-kmp-desktop

Then it should work after a reboot.

wolfi323, that did it! Thanks very much for seeing that wrong driver. I’m still very new to Linux, but with the help of people on this forum, I learn more and more!

Take care,

The confusion is you have both

Typically you would install just kernel-desktop

Your post information has all the hallmarks of a user unfamiliar with openSUSE and probably Linux in general
The situation of having both installed usually comes about (in my experience) when users use OneClick installers

Your grub menu will reflect your scenario of having both default and desktop
If it were me, I’d uninstall default, but it can be a challenge

Well, if he followed my advice, he shouldn’t have kernel-default installed any more now… :wink:

I did follow exactly what wolfi323 recommended and it worked like a charm.

Thanks again!

Just FYI:

One of my (many) problems with Wi-Fi was that on the new Plasma-nm widget (0.9) I didn’t realize that one must check the box in the upper left corner (with the WiFi symbol to the right) to turn on the WiFi radio. This check box didn’t exist in earlier versions. If not checked, there is no Wi-Fi.

It did.
But it was located at the bottom, and it had a text label (“Enable Wireless”) instead of an icon.

And it should actually be checked by default.