frescobaldi error: possible discrepancy between sip and popplerqt4?

I upgraded to openSuSE 13.2 a few days ago. The lilypond editor “frescobaldi” aborts immediately after displaying its splash image with this error message:

> RuntimeError: the sip module implements API v11.0 to v11.1 but the popplerqt4 module requires API v10.1

Is the current version of popplerqt4 compiled against a recent enough version of sip?

Thanks for any clues!

And which versions from which repos do you have installed? (python-poppler-qt4 does not use/need python-sip at all, but python-qt4 does which is used by python-poppler-qt4)

rpm -qi python-poppler-qt4 python-qt4 python-sip

The versions of python-poppler-qt4, python-qt4, and python-sip shipped with openSUSE 13.2 are definitely compatible with each other.

But according to your other thread ( you have both the 13.2 repo and Factory active, which most probably led to having mismatched packages installed.

Remove the Factory repo immediately, as I already wrote in the other thread, and run “sudo zypper dup” to completely switch back your system to 13.2.
Then frescobaldi should work.