FreeNX Configuration openSUSE 12.1

I use this frequently and ran into a few problems getting this up and running. Once I stopped doing this the way I had always done it and did a little digging, setup was a breeze. First of all, you have to make sure that ssh is installed, enabled and the port is open, which is just a single click during the DVD install~

  1. Open a terminal

  2. Type the following:

zypper in FreeNX-0.7.3-7.1.x86_64.rpm NX-3.4.0-25.1.x86_64.rpm
nxsetup --install --setup-nomachine-key

  1. Connect with your freenx client from another system. This is all it took for me.

Hello. :slight_smile:

Trying to get FreeNX up and running. Following your instructions and I’m getting stuck here:

linux-e7c3:/home/htpc # zypper in FreeNX-0.7.3-7.1.x86_64.rpm NX-3.4.0-26.1.x86_64.rpm 
Loading repository data...
Reading installed packages...
'_tmpRPMcache_:FreeNX=0:0.7.3-7.1' not found in package names. Trying capabilities.
No provider of 'FreeNX = 0:0.7.3-7.1' found.
'_tmpRPMcache_:NX=0:3.4.0-26.1' not found in package names. Trying capabilities.
No provider of 'NX = 0:3.4.0-26.1' found.
Resolving package dependencies...

Nothing to do.

Any suggestions?

Thank you in advance and thank you for posting this guide! :slight_smile:

Try to install FreeNX from my repo:

su -l
zypper ar [noparse][/noparse]  PTA
zypper refresh -r PTA
zypper in FreeNX

Then run nxsetup as previously mentionned.

SUCCESS! That worked great sir!

Thank you for sharing this and setting this up! :smiley:

I tried to install FreeNX server from standard OpenSuse repositories: for OpenSuse 12.1 and for OpenSuse 12.1. I used this setup: nxsetup --install --setup-nomachine-key --clean --purge

In both installations (12.1 as well as 11.4) I got the same results:

Using windows NX client from both remote machines with FreeNX server seem to be fully functional (including arrow keys, PgUP and PgDown).

Using linux NX client from on both remote machines with FreeNX, keyboard issue occurs: arrow keys, PgUP and PgDown are not functional. (Linux clients are fully functional with connections to other servers with Nomachine NX server installed)

Repeated attempts to install FreeNX client from mentioned repositories were unsuccesful. Starting qtnx process continues up to the request for the password, after password entry no reaction.

Final result is bit depressive for Linux clients: Windows-to-12.1or11.4 NX session is fully functional, Linux-to-12.1os11.4 session is dead.

Thanks in advance for any suggestions/advices. Hynek

Why are there so many repos to get freenx from?
Isn’t this the “main” place where one gets FreeNX from? (Think from the perspective of a newb)
Index of /repositories/X11:/RemoteDesktop/openSUSE_12.1
this is what shows up when searching on

please_try_again, can you please work with the packager of X11:/RemoteDesktop to make a single working package of FreeNX?

After install, as root, I was running nxsetup–install --setup-nomachine-key and it crashed when "Setting up special user “nx”.
Rerunning this command, I got missing directory error cannot stat `/usr/lib64/cups/backend/ipp.
Then created this directory with mkdir, and rerunning the nxsetup
after install, I had to add my username to the nx user group in yast.

a simple solution is that to Connect with your freenx client from another system.]( This is all it took for me. as simple as that.](