[forum-meta] New user, went to "English" under "Categories" to make first post, but "+ New Topic" option is grayed-out for me there? But I *can* post in "Everything" under "Community"?

I’m confused whether this is a bug, or the way the forums are supposed to work…?

I’m a new user, and I just went to “English” under “Categories” to make my first post
(since, out of the apparent options, that seemed like the obvious place I should go?),
but the “+ New Topic” option is grayed-out for me there…?

I tried completing the discobot tutorial first,
cuz I thought it was maybe vaguely implying that was necessary to unlock posting privileges,
but no banana…

However, while trying to find some sort of help/info for this,
I clicked on “Everything” under “Community”,
and found that apparently I can start a “+ New Topic” here.

So…
I guess I’m supposed to use “Community>Everything” to make posts?
(and not use “Categories>English”?)

In which case,
I guess that the clickable shortcuts for each language listed under “Categories” are only supposed to be used to filter posts for reading, then?

And like, on one hand, that’s a sensible functionality to have,
but the way everything is laid out and labelled as a whole…
just seems pretty likely to mislead to new users into misunderstanding what the intended functionality is supposed to be
(ie mislead you into thinking you’re supposed to go to the category for your language in order to post),
and ending up all confused like me here.


(
Also, I did note one other unrelated minor point of out-of-date confusion with the discobot tutorial,
where it refers to the “:heart: button”
even though it’s actually a “:+1:” (thumbs up) button…

So it seems plausible that maybe there could be a few other little inconsistencies left over from some updates to the way the forum works or something…?
)


((
Actually, I just noticed another little thing that’s a little confusing as a new user:

There was a first-time poster help message
(“Welcome to openSUSE Forums — thanks for starting a new conversation!” etc)
to the right of the input box I’m writing this into right now,
and that first-time poster help message was hiding / covering up the realtime markdown preview.

However, as a first-time poster,
I didn’t know there was supposed to be a realtime markdown preview there that I couldn’t see,
and the only reason it occurred to me to try closing the help message in order to get the markdown preview
was because I noticed there was one in the discobot tutorial that I was missing here,
and the only reason I noticed that was because I kept looking back at the discobot tutorial
and the only reason I was doing that was because I was already confused about why I couldn’t post.
))

I’m not sure what you did.

However, where I see a “:heart: button” on another discourse forum, I see a “:+1:” here. So it is probably a matter of how the icons were set for us here.

Ahh, I see, “discourse” is a kinda… how-to-say… “template platform” for building forums. I didn’t even know about that.
((Honestly I’ve been so ridiculously socially withdrawn for the past few years I pretty much stopped communicating publicly anywhere at all, or even privately…))

Anyway, thanks for the tip, it let me find discourse.org and their github, which are interesting.


But anyway, when you say

you mean to imply it does work for you?

ie, if you go to the “Category>English” page,
the “+ New Topic” button in the top right of the page does work for you?

Cuz it’s still grayed-out for me.

No, that does not work for me either. It is greyed out.

You have to go down a level. If you had tried
Categories → English → Forum Feedback
then you should have been able to start a new topic there.

I cannot find a “Community → Everything” where you said you posted. So I suspect you found that at the Discourse site where you were checking for help. And they probably moved it here.

Thanks!

This is that post.
ie
the thread(or “topic” if that’s the UI’s official term for it) that we’re posting in right now,
I originally created this thread/topic by:

  • clicking on “Community → Everything” (which goes to URL https://forums.opensuse.org/latest)
  • clicking the “+ New Topic” button in the top right, which popped up an editor panel
  • in that editor panel, selecting “English - Forums Feedback” in dropdown menu for “category…”

Huh? Oh, do you mean the page at the URL https://forums.opensuse.org/c/english/forums-feedback/36?

The “+ New Topic” button does work for me there,
but I didn’t find that page at first,
and having just found it,
it totally makes sense why a new user would be much less likely to find it.


See, for a new user,
clicking on “English” under “Categories” in the always-visible left-hand sidebar is super obvious,
but then all the “down a level” sub-categories are relatively hidden under the dropdown sub-menu “all >” that then appears along the center-top of the page,
so it didn’t even occur to me that selecting one of those would be what I’d need to do to make the “+ New Post” button become useable.


I mean,
there are basically two different and arguably conflicting basic-UI-ideas here…

  1. to post a new topic,
    you click “+ new topic”,
    and then tag the “category” for that topic as part of that process

or

  1. to post a new topic,
    you must first select the “category”,
    and only then can you click “+ new topic” and begin the rest of process

And from the very top level of these forums…

if you click “Community → Everything”, it works by basic-UI-idea-1

but if you click “Categories → English”, it works by basic-UI-idea-2
(
And like, I think basic-UI-idea-2 is arguably just generally inferior anyway,
but in addition to that,
the left sidebar has only a list of languages under the heading “Categories”,
which right-off-the-bat gives the user the idea that when the site says “Category” it means “which language”.

And since the user already clicked on the “English” category
they expect they now are looking at the page for that category,
so why would it occur to you that you need to select a further (sub-)category before you can post?
– especially since those (sub-)categories are under a dropdown menu that looks more like more like a tool for, like, advanced filtering,
and is just labelled “all >” (without even the word “category” to indicate that there are other “categories” than just the languages).
)


And I mean, the end goal of the UI is to make sure the user selects a category when they post a topic, right?

But that’s already handled!
Because it already prevents you from using the “+ Create Topic” button in the editor panel until after you’ve made a selection from the “category…” dropdown menu
(I just tested it, and it does indeed give you the correct feedback: “An error occurred: Category can’t be blank”)

So… in summary, I’d say it really does seem like basically a bug in the UI that the “+ New Topic” post is grayed out if you just go to “Categories → English”, no?

(
… so I guess in that case maybe I should ask what they think about that on the github for discourse?
((… maybe later, I feel my social anxiety is starting to act up again…))
)

My best guess is that this forum is using two levels of categories and “English” is sort of “container” which is not supposed to have posts, just subcategories.

It works from the (default) start page just fine.

That is correct. No threads/topics are to be started at the top language level. You have to choose a sub-category that fits best your problem/question (and “best fitting” here means the category where those people you need for help will possibly lurk to see new threads).

The nasty thing as that we are unable to get that + New Topic removed from where it should not be at all. It can only be blocked from usage. From time to time frustrating for new members here (there are several other threads about this).

I normally don’t see that. Fortunately, you mentioned “left-hand sidebar”. I normally don’t see that, but I turned it on and then I saw the “community/everything”.

Yes, this forum can be confusing to new users.

If you go to Categories/English you cannot start a new topic. But if you go to Categories/English/some-specific-category then you should be able to start a new topic in that specific category.

There’s a “hamburger” menu button at top left. If you click on that, it will hide the left sidebar, and give you more space for other things. That’s what I normally see. But it reverts when I close and restart the browser.

Welcome to our new forum software. You will probably get used to its quirks. Whether those are bugs or features, I don’t really know.

Here’s what I do:

In my profile/settings page, I mark as “Tracking” the categories that I want to follow. For me, that is all English categories and some admin categories visible to moderators. And I make the “Latest” page my default start page.

With that setup, it mostly works quite well.

I mean, honestly the forum software otherwise stands out as really good!
My computer is over 10 years old,
and I’m used to horribly inefficient bloated modern websites lagging ridiculously,
but the interface here is still snappy and pleasant to use!

The only major problem was the “+ New Topic” button being grayed out under the obvious place a new user would go to post
(leading to the obvious misunderstanding that “maybe I don’t have posting privileges yet?”)


Huh, when I toggle the sidebar off,
it just results in more empty space to the right,
without any of the “other things” actually expanding horizontally at all.
I guess maybe my screen is slightly wider than yours or something?


I just found that you can “Edit your sidebar categories” to customize the left sidebar
(a “pencil”-icon edit button pops up when you hover over “Categories” in the left sidebar)
(takes you to https://forums.opensuse.org/u/[username]/preferences/sidebar )

I just set mine up like:

(removing the other languages, then adding all the sub-categories under “English”)
which ends up as basically the kind of structure/interface I think you’d generally expect to see in a forum.

But why block it from usage at all then?

Like I said:

I have my browser using only around 2/3 of the screen width. I find that more comfortable than having it fill the whole screen.

I thought I said that already: because we want only threads in the sub-categories. You have to choose between e.g. Install-Boot/Login or Applications, or Network, etc. We want to to have related things together. When you e.g. now a lot about Networking and want to help people here, you then can restrict yourself to looking into that sub-category if you find an interesting problem where you can help. Efficiency. People spend their spare time to helping here as a volunteer, why should we make things difficult by having one big mass of questions ranging through all aspects and senseless chatting in one big heap?

[Sorry, just deleted and reposted this reply cuz I think I got confused before and posted it as a reply to the wrong thing?]

Huh? I mean, yes, I already agreed you’re obviously correct
– ie, the UI should indeed force the user to pick a category before allowing you to post a new thread
(or “a topic” as the UI apparently calls a thread, although “thread” seems like a clearer term for it in context).

But what I’m saying is that there’s already a separate feature of the UI that already perfectly achieves that goal,
which makes it completely unnecessary to gray out the “+ New Topic” button anywhere,
no?

I thought I’d explained that well enough in the bit I originally quoted up there,
(
ie this bit:

)
but I guess I messed up on explaining it clearly enough…

I’m not sure how to rephrase it more clearly though,
so maybe a screenshot would help?:

That shows how it works when using the (non-grayed-out) “+ New Post” button
under left sidebar “Community → Everything”
(ie URL https://forums.opensuse.org/latest)
[
EDIT: to be extra clear, that’s showing the error message that pops up after clicking the “+ Create Topic” button (bottom left)
]
so
why not just un-gray-out the “+ New Post” button
under left sidebar “Categories → English”
(ie URL https://forums.opensuse.org/c/english/6)
and just let it work exactly the same way on both pages?
(Or rather, “all pages”, including the (super-)category of each language.)

Yes, that was changed by request before we went live. :wink:

I agree that would make sense. I frequently check the Manjaro Forum for reference, and they do that (different aesthetic design), so you can still reach “+ NEW TOPIC”

and you are then presented with an editor forcing you to select a category…

Yeah, it at least seems like a reasonable proposal to make
(ie “Unblock the usage of the “+ New Topic” button under “Categories → English” etc”)
since it seems to have no downside
(on the (reasonable I think) assumption that the UI would indeed keep automatically enforcing category-selection anyway),
and it’s apparently been a problem for at least “several” other people in the past besides my-own-dumb-self
(
according to:

)
so… who to / where / how do I make that proposal?

And your screenshot shows category “Support” which would be equivalent to our “English” (it contains subcategories) and that is exactly what maintainers of this forum wanted to avoid.

Ohhh, are you saying that,
if you un-grayed-out the “+ New Topic” button under the super-category “English”,
that would also automatically cause that super-category “English” to appear as a selectable entry in the dropdown “categories…” menu in the editor panel?

That does call into question how reasonable an assumption it was when I said:

Yep, and I’m agreeing with the OP, that it makes sense to allow a topic to be created with an applicable category chosen :wink:

Right, but while that would make sense in theory
(
ie
for the “+ New Topic” problem to be useable on the page for the super-category “English”
while still enforcing the selection of one of the sub-categories under that top-level for every new thread(/“topic”)
)
I just realized that maybe the problem is that, in practice, with the way the software is set up
(ie, the template from discourse.org )
they might currently be linked together?

(
That’s what I meant by this:

[… I’m guessing I’m supposed to just quote the whole short post like that rather than link back to it…? The quote selection feature seems a bit wonky on the edgecases where the selection goes to the end of a post? at least where a post itself ends in a quote?]
)


[
sorry, just for my own “testing I understand how the forum is supposed to work”, I’m editing to add a link to the post as well, just to see how that works / what it does:

… huh, apparently
(so long as you put the link URL by itself on a single line, rather than in-lined)
it squashes in the text of the linked post itself,
but strips out certain formatting (just line-breaks?)
and strips out quotes from the post?

… no wait, that’s how it shows up in the live-preview in the editor panel,
but once posted it shows up slightly differently,
with the title of the thread appended above?

Huh.
]