Followed the audio troubleshooting, yast was unable to add back the card after deleting it

Upon installation I had a sound card listed and the intel hd module associated with it. But the sound wasn’t working. I followed the trouble shooting up to the point where it says to open yast → hardware → sound, delete the card and add it back… But yast is unable to add it back - it says During the installation of Sunrise Point-LP HD Audio The kernel module snd-soc-skl for sound support could not be loaded. This can be caused by incorrect module parameters, including invalid IO or IRQ parameters.

Here’s my alsa-info after deleting the card.

How do I add a card?
These are the results for the name of this card.

@cantfind is the firmware installed sof-firmware?

Just intall sof-firmware, restarted the computer and tried again with yast - I get the same error.

relevant dmesg:

[  649.323524] Modules linked in: snd_soc_skl snd_soc_hdac_hda snd_hda_ext_core snd_soc_sst_ipc snd_soc_sst_dsp snd_soc_acpi_intel_match snd_soc_acpi snd_intel_dspcfg snd_intel_sdw_acpi snd_hda_codec snd_hda_core snd_hwdep rfcomm ccm nft_fib_inet nft_fib_ipv4 nft_fib_ip
v6 nft_fib nft_reject_inet nf_reject_ipv4 nf_reject_ipv6 nft_reject nft_ct af_packet nft_chain_nat nf_tables ip6table_nat ip6table_mangle ip6table_raw ip6table_security iptable_nat nf_nat nf_conntrack nf_defrag_ipv6 nf_defrag_ipv4 iptable_mangle iptable_raw iptable_secu
rity nfnetlink ip6table_filter ip6_tables iptable_filter bpfilter cmac algif_hash algif_skcipher af_alg bnep btusb btrtl btbcm btintel btmtk uvcvideo bluetooth videobuf2_vmalloc videobuf2_memops videobuf2_v4l2 qrtr videobuf2_common videodev mc ecdh_generic soundwire_int
el soundwire_generic_allocation soundwire_cadence soundwire_bus nls_iso8859_1 iwlmvm nls_cp437 vfat intel_tcc_cooling snd_soc_core fat snd_compress x86_pkg_temp_thermal mac80211
[  649.323561]  snd_pcm_dmaengine iTCO_wdt intel_powerclamp intel_pmc_bxt mei_hdcp mei_pxp iTCO_vendor_support libarc4 intel_rapl_msr coretemp kvm_intel iwlwifi snd_pcm snd_timer asus_nb_wmi kvm asus_wmi snd ledtrig_audio sparse_keymap platform_profile cfg80211 irqbypas
s pcspkr efi_pstore soundcore processor_thermal_device_pci_legacy mei_me rfkill i2c_i801 processor_thermal_device mei processor_thermal_rfim i2c_smbus intel_pch_thermal processor_thermal_mbox processor_thermal_rapl intel_rapl_common intel_xhci_usb_role_switch int3403_th
ermal roles intel_soc_dts_iosf thermal int340x_thermal_zone acpi_als industrialio_triggered_buffer int3400_thermal kfifo_buf tiny_power_button acpi_thermal_rel industrialio acpi_pad ac asus_wireless intel_pmc_core button joydev fuse configfs dmi_sysfs ip_tables x_tables
crct10dif_pclmul crc32_pclmul polyval_clmulni polyval_generic gf128mul ghash_clmulni_intel sha512_ssse3 i915 xhci_pci xhci_pci_renesas xhci_hcd drm_buddy drm_display_helper cec
[  649.323597]  aesni_intel crypto_simd cryptd rc_core usbcore ttm video battery wmi serio_raw btrfs blake2b_generic libcrc32c crc32c_intel xor raid6_pq sg dm_multipath dm_mod scsi_dh_rdac scsi_dh_emc scsi_dh_alua msr efivarfs [last unloaded: snd_hda_core]

Another bit of information:

I can hear sound when I plug in my headphones… so it seems the drivers are working to some extent. the speakers make a little “pluck” when audio tries to play.

What desktop environment is use?

Right now it’s KDE, but it happened in Gnome and xfce too.

@deano_ferrari @oldcpu thoughts on this one?

What does the following command report?

sudo dmesg | egrep -i "sof|snd"
[    4.890326] snd_hda_intel 0000:00:1f.3: bound 0000:00:02.0 (ops i915_audio_component_bind_ops [i915])
[    4.975668] snd_hda_codec_conexant hdaudioC0D0: CX20751/2: BIOS auto-probing.
[    4.977123] snd_hda_codec_conexant hdaudioC0D0: autoconfig for CX20751/2: line_outs=1 (0x17/0x0/0x0/0x0/0x0) type:speaker
[    4.977134] snd_hda_codec_conexant hdaudioC0D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
[    4.977141] snd_hda_codec_conexant hdaudioC0D0:    hp_outs=1 (0x16/0x0/0x0/0x0/0x0)
[    4.977146] snd_hda_codec_conexant hdaudioC0D0:    mono: mono_out=0x0
[    4.977150] snd_hda_codec_conexant hdaudioC0D0:    inputs:
[    4.977154] snd_hda_codec_conexant hdaudioC0D0:      Internal Mic=0x1a
[    4.977158] snd_hda_codec_conexant hdaudioC0D0:      Mic=0x19

I note that output (shared earlier in this thread) reports

snd_hda_intel: dmic_detect=0

Try removing the existing audio config option, and see if that helps in any way.

Its been a long time since I have seen such behaviour, when after removing a sound card in YaST, it could not be seen again. Typically thou, a reboot will cause it to reappear. I know, dumb question on my part, but have you rebooted your PC since? …

Also, the advice about sof_firmware is very relevant.

There is a diagnostic script that comes with alsa-utils (where alsa-utils is installed by default) which when run provides very good information on both configuration and installation issues with one’s sound. To run that diagnostic script, open a konsole or xterm, and as a regular user type (with PC connected to the internet):


Select the UPLOAD/SHARE option when prompted and let the script run to completion. After the script has finished running you should see in the konsole/xterm an entry showing where on the internet the “ALSA information” from your PC setup has been uploaded to. Please provide that link here, and the volunteers on our forum who try to provide support for sound, can look at that and try to diagnose better the issue you are experiencing.

EDIT: I see you ran that script in your 1st post (when you stated your PC could not find the sound card again … Is that still the case? … There are MASSIVE errors in that script output, the likes of which I have never seen before - where that ‘might’ (speculation on my part) be a sof_firmware issue initially. If you have changed your configure/installed sof_firmware since, it would be useful to run the script again.

I moved the system drive to a new chassis and never bothered with sound. On the new system yast2 sound displays two configured cards of the old chassis and three unconfigured ones of the new chassis. However the new system has sound:

3400G:~ # journalctl -b -g snd
Dec 27 10:28:08 erlangen kernel: ata1.00: Features: Trust Dev-Sleep NCQ-sndrcv
Dec 27 10:28:08 erlangen kernel: ata2.00: Features: Trust Dev-Sleep NCQ-sndrcv
Dec 27 10:28:12 3400G kernel: snd_hda_intel 0000:09:00.1: enabling device (0000 -> 0002)
Dec 27 10:28:12 3400G kernel: snd_hda_intel 0000:09:00.1: Handle vga_switcheroo audio client
Dec 27 10:28:12 3400G kernel: snd_hda_intel 0000:09:00.6: enabling device (0000 -> 0002)
Dec 27 10:28:12 3400G kernel: snd_hda_intel 0000:09:00.1: bound 0000:09:00.0 (ops amdgpu_dm_audio_component_bind_ops [amdgpu])
Dec 27 10:28:12 3400G kernel: snd_hda_codec_realtek hdaudioC1D0: autoconfig for ALC887-VD: line_outs=1 (0x14/0x0/0x0/0x0/0x0) type:line
Dec 27 10:28:12 3400G kernel: snd_hda_codec_realtek hdaudioC1D0:    speaker_outs=0 (0x0/0x0/0x0/0x0/0x0)
Dec 27 10:28:12 3400G kernel: snd_hda_codec_realtek hdaudioC1D0:    hp_outs=1 (0x1b/0x0/0x0/0x0/0x0)
Dec 27 10:28:12 3400G kernel: snd_hda_codec_realtek hdaudioC1D0:    mono: mono_out=0x0
Dec 27 10:28:12 3400G kernel: snd_hda_codec_realtek hdaudioC1D0:    dig-out=0x11/0x0
Dec 27 10:28:12 3400G kernel: snd_hda_codec_realtek hdaudioC1D0:    inputs:
Dec 27 10:28:12 3400G kernel: snd_hda_codec_realtek hdaudioC1D0:      Front Mic=0x19
Dec 27 10:28:12 3400G kernel: snd_hda_codec_realtek hdaudioC1D0:      Rear Mic=0x18
Dec 27 10:28:12 3400G kernel: snd_hda_codec_realtek hdaudioC1D0:      Line=0x1a
Dec 27 10:28:12 3400G kernel: usbcore: registered new interface driver snd-usb-audio

Removing the obsolete entries killed sound. In yast2 sound I added an existing card and restarted systemctl --user restart pipewire.service. That’s all.

File created by yast2 sound

3400G:~ # cat /etc/modprobe.d/50-sound.conf
options snd slots=snd-usb-audio
alias snd-card-0 snd-usb-audio
3400G:~ # 

How do I remove the existing audio config? everything had been deleted by Yast from /etc/modprobe.d

(and wasn’t restored after reboot).

Is there another place I should be looking in?

Here’s the latest alsa-info output:

Anything added in the the grub boot parameters?

I haven’t added anything to the grub command. I’m using the default.

Ok, then I’m not sure why the modprobe options listed in the output you shared (at the beginning of the thread) included ‘snd_hda_intel: dmic_detect=0’. I have no further suggestions.

Ok, so this recently shared output does not show the module option unlike the last.