Flickering monitor


Problem: I have been using (up-to-date) Leap 15.0 (Please note that I am virtually a novice Linux user). There is pseudo-random flickering on my screen, which gradually increases its frequency when the computer resources being used more. I am not able to read a single typical-size paragraph without encountering a flickering.

There seems to be similar threads regarding the same/similar issue, for example:
I have amateurishly tried some of the solutions suggested thereat. Nevertheless, the flickering issue persists.

Some information about the workstation is as follows:

inxi -Fz
Resuming in non X mode: glxinfo not found. For package install advice run: inxi --recommends
System:    Host: snoopy Kernel: 4.12.14-lp150.12.64-default x86_64 bits: 64 Desktop: Gnome 3.26.2
           Distro: openSUSE Leap 15.0
Machine:   Device: server System: Supermicro product: X8DA3 v: 1234567890 serial: N/A
           Mobo: Supermicro model: X8DA3 v: 2.01 serial: N/A BIOS: American Megatrends v: 2.0c date: 10/19/2010
Battery    hidpp__0: charge: N/A condition: NA/NA Wh
           hidpp__1: charge: N/A condition: NA/NA Wh
CPU(s):    2 Hexa core Intel Xeon X5650s (-HT-MCP-SMP-) cache: 24576 KB
           clock speeds: max: 2668 MHz 1: 1600 MHz 2: 1600 MHz 3: 1600 MHz 4: 1600 MHz 5: 1600 MHz 6: 1600 MHz
           7: 1600 MHz 8: 1600 MHz 9: 1600 MHz 10: 1600 MHz 11: 1600 MHz 12: 1600 MHz 13: 1600 MHz 14: 1600 MHz
           15: 1600 MHz 16: 1600 MHz 17: 1600 MHz 18: 1600 MHz 19: 1600 MHz 20: 1600 MHz 21: 1600 MHz
           22: 1600 MHz 23: 1600 MHz 24: 1600 MHz
Graphics:  Card: NVIDIA GF104 [GeForce GTX 460]
           Display Server: wayland (X.org 1.19.6 ) driver: nouveau tty size: 190x46
Audio:     Card-1 NVIDIA GF104 High Definition Audio Controller driver: snd_hda_intel
           Card-2 Intel 82801JI (ICH10 Family) HD Audio Controller driver: snd_hda_intel
           Card-3 Logitech H600 [Wireless Headset] driver: USB Audio
           Sound: Advanced Linux Sound Architecture v: k4.12.14-lp150.12.64-default
Network:   Card-1: Intel 82573E Gigabit Ethernet Controller (Copper) driver: e1000e
           IF: eth0 state: up speed: 1000 Mbps duplex: full mac: <filter>
           Card-2: Intel 82573L Gigabit Ethernet Controller driver: e1000e
           IF: eth1 state: down mac: <filter>
Drives:    HDD Total Size: 4150.8GB (87.4% used)
           ID-1: /dev/sda model: WDC_WD1500HLFS size: 150.0GB
           ID-2: /dev/sdb model: WDC_WD2003FZEX size: 2000.4GB
           ID-3: /dev/sdc model: Hitachi_HDS72202 size: 2000.4GB
Partition: ID-1: / size: 40G used: 29G (72%) fs: btrfs dev: /dev/dm-0
           ID-2: /opt size: 40G used: 29G (72%) fs: btrfs dev: /dev/dm-0
           ID-3: /var size: 40G used: 29G (72%) fs: btrfs dev: /dev/dm-0
           ID-4: /tmp size: 40G used: 29G (72%) fs: btrfs dev: /dev/dm-0
           ID-5: /home size: 25G used: 58M (1%) fs: xfs dev: /dev/dm-2
           ID-6: swap-1 size: 25.26GB used: 0.00GB (0%) fs: swap dev: /dev/dm-1
Sensors:   None detected - is lm-sensors installed and configured?
Info:      Processes: 490 Uptime: 0:30 Memory: 3456.1/24085.2MB Init: systemd runlevel: 5
           Client: Shell (bash) inxi: 2.3.40
xrandr --prop
Screen 0: minimum 320 x 200, current 1920 x 1200, maximum 8192 x 8192
XWAYLAND0 connected 1920x1200+0+0 (normal left inverted right x axis y axis) 520mm x 320mm
   1920x1200     59.88*+
sudo hwinfo --gfxcard
[sudo] password for root: 
24: PCI 600.0: 0300 VGA compatible controller (VGA)             
  [Created at pci.386]
  Unique ID: vTuk.0GkgveO_CH6
  Parent ID: 3hqH.IM4iae89QX4
  SysFS ID: /devices/pci0000:00/0000:00:03.0/0000:06:00.0
  SysFS BusID: 0000:06:00.0
  Hardware Class: graphics card
  Model: "nVidia GF104 [GeForce GTX 460]"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x0e22 "GF104 [GeForce GTX 460]"
  SubVendor: pci 0x19da "ZOTAC International (MCO) Ltd."
  SubDevice: pci 0x2166 
  Revision: 0xa1
  Driver: "nouveau"
  Driver Modules: "nouveau"
  Memory Range: 0xf8000000-0xf9ffffff (rw,non-prefetchable)
  Memory Range: 0xd8000000-0xdfffffff (ro,non-prefetchable)
  Memory Range: 0xd4000000-0xd7ffffff (ro,non-prefetchable)
  I/O Ports: 0xec00-0xec7f (rw)
  Memory Range: 0x000c0000-0x000dffff (rw,non-prefetchable,disabled)
  IRQ: 31 (245166 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v000010DEd00000E22sv000019DAsd00002166bc03sc00i00"
  Driver Info #0:
    Driver Status: nouveau is active
    Driver Activation Cmd: "modprobe nouveau"
  Config Status: cfg=new, avail=yes, need=no, active=unknown
  Attached to: #22 (PCI bridge)

Primary display adapter: #24

I would highly appreciate if some of you can give me a hand regarding this topic.

Kind regards,

A good place to start is to try a different session type. IceWM is a nice small low load environment normally installed by default that is good for such testing. It typically will define whether the problem is with the environment (DE: Gnome, Plasma, XFCE, Cinnamon, etc.) or the foundation (Wayland or Xorg).

DEs that can run in either Wayland or Xorg should be tried both ways.

The information provided reports nearly nothing about the X foundation.

inxi -GxxxSa > somePlainTextFile.txt

from any GUI terminal (Xterm, Gnome Terminal, Konsole, etc.) may be used to fill those gaps by pasting the file’s content here without including the colors it uses onscreen.

The inxi (nothing but an information collection and reporting script) provided by 15.0 (and 15.1) is ancient. Slightly more useful results might result from the current version available via its author’s web site.

Dear mrmazda,

Many thanks for your reply.

Please see the outcome of *inxi -GxxxS > somePlainTextFile.txt *below:

Resuming in non X mode: glxinfo not found. For package install advice run: inxi --recommends
System:    Host: snoopy Kernel: 4.12.14-lp150.12.64-default x86_64 bits: 64 gcc: 7.4.1
           Desktop: Gnome 3.26.2 (Gtk 3.22.30) info: gnome-shell dm: gdm Distro: openSUSE Leap 15.0
Graphics:  Card: NVIDIA GF104 [GeForce GTX 460] bus-ID: 06:00.0 chip-ID: 10de:0e22
           Display Server: wayland (X.org 1.19.6 ) driver: nouveau tty size: 190x46

I will try to understand what the remaining of your post means since I am a bit novice regarding all you mentioned.

Many thanks again.

// K

I still couldn’t resolve the issue. :’(

Have you managed to try any X session type in which output of

inxi -Gxx

does not include Wayland, or reports “driver: modesetting” instead of “driver: nouveau”?

I had a similar issue and it was the hdmi lead

Many thanks to both of you for your help.

Eventually, I managed to get rid of this issue by simply installing the correct driver for the graphics card.

Specifically, I have followed this link for the driver installation: https://en.opensuse.org/SDB:NVIDIA_drivers

Thank you