Flickering Gnome or KDE Desktop with Leap 15.4 ISO on Iris Xe Graphics/GeForce MX450

Hi,

just trying to get my feet wet with the new Leap 15.4 by booting from an ISO USB stick on a new 11thGen i7 laptop.
But I dont get far :frowning:

  • No german kezboard (although I changed system keyboard layout)
  • Desktop (tried Gnome and KDE) is flickering badly (is black most of the time)

I guess the graphic card is not supported?


00:02.0 VGA compatible controller: Intel Corporation TigerLake-LP GT2 [Iris Xe Graphics] (rev 01)
[FONT=monospace]01:00.0 3D controller: NVIDIA Corporation TU117M [GeForce MX450] (rev a1)
[/FONT]

I found some hints for other distros (like installing an OEM kernel, diagnosing with inxi), but nothing I could use here.
Is there a known workaround I can use with the ISO image?

No. I dont have fun… yet

While installing change keyboard settings twice: for keyboard and for installation (to get german translation of license agreement).
You may need kernel parameter “nomodeset” to load installer. You need to delete it after successful install.

Post


inxi -aGSz

after install.

Thanks for the hints, but I think they only apply for an installation?

I only run the Live ISO - and for now I have no plans to change that before things stabilize…

EDIT: and for completeness:

  1. I would have answered earlier if login to the forum would work on chromium - found out by chance it works on firefox
  2. Seems there is no official inxi package for 15.4. Only 15.3 and tumbleweed

Live ISO is not intended for everyday use.

Post


zypper se -s inxi

For newer inxi:

zypper addrepo https://download.opensuse.org/repositories/utilities/15.4/utilities.repo
zypper refresh
zypper install inxi 

Just did an online update on the Live ISO and rebooted.

Unfortunately same result: Any mouse move (and it seems any 3d effect like opening dialog, etc.) causes a toggle to a black screen or back to “normal” screen display.

This is inxi output as requested:

System:    Kernel: 5.14.21-150400.22-default x86_64 bits: 64 compiler: gcc v: 7.5.0           parameters: BOOT_IMAGE=(cd0)/boot/x86_64/loader/linux splash=silent quiet systemd.show_status=yes
           root=live:CDLABEL=openSUSE_Leap_15.4_GNOME_Live rd.live.image rd.live.overlay.persistent rd.live.overlay.cowfs=ext4
           Desktop: GNOME 41.4 tk: GTK 3.24.31 wm: gnome-shell dm: GDM 41.3 Distro: openSUSE Leap 15.4
Graphics:  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Lenovo driver: i915 v: kernel bus-ID: 00:02.0
           chip-ID: 8086:9a49 class-ID: 0300
           Device-2: NVIDIA TU117M [GeForce MX450] vendor: Lenovo driver: nouveau v: kernel bus-ID: 01:00.0 chip-ID: 10de:1f97
           class-ID: 0302
           Device-3: Chicony Integrated Camera type: USB driver: uvcvideo bus-ID: 3-6:3 chip-ID: 04f2:b6be class-ID: fe01
           serial: <filter>
           Display: wayland server: X.org 1.20.3 compositor: gnome-shell driver: loaded: nouveau
           note: n/a (using device driver) - try sudo/root display-ID: 0 resolution: <missing: xdpyinfo>
           OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.2.4 direct render: Yes

Hope you see somthing wrong so I can fix it…

I tried something different now: nvidia drivers - but, spoiler, failed again :frowning:

I added community repo for nvidia with yast. Software installation then offered installing nvidia drivers automatically - nice :slight_smile:

Reboot -> flickering :frowning:

inxi still reports using driver nouveau, but lists nvidia_drm,nvidia as alternate now - hm, how to switch to alternate? alternatives tool? Didn’t find info about this, seems switch should be automatic -> discarded

Trying to disable nouveau with “blacklist nouveau” in /etc/modprobe.d/blacklist.conf. Reboot -> no change

Found SDB page about nvidia, secureboot and MOK. Must have missed the boot message about it. Did mokutil --import, reboot, enroll reboot as described → no change

Tried mokutil --disable-validation, reboot → no change

Tried disabling secure boot in bios (can’t boot windows anymore, so not a permanent “solution”, but for now…) reboot → no change :frowning:

lsmod still lists only nouveau. Only mention of nvidia in dmesg after boot is with apparmor, not with failed module loading.

Best hint is probably messages when trying to modprobe -v nvidia:

nvidia: Unknown symbol __x86_return_thunk (err -2)

Out of options. Ideas anyone?

We need to see inxi -Gaz with v3.3.19. Older inxi versions have confusing -G output, since corrected.

You can kill nouveau without killing drivers for i915 by appending to linu line in grub nouveau.modeset=0.

Do you have suse-prime installed?

System:
  Kernel: 5.14.21-150400.22-default arch: x86_64 bits: 64 compiler: gcc
    v: 7.5.0 parameters: BOOT_IMAGE=(cd0)/boot/x86_64/loader/linux
    splash=silent quiet systemd.show_status=yes
    root=live:CDLABEL=openSUSE_Leap_15.4_GNOME_Live rd.live.image
    rd.live.overlay.persistent rd.live.overlay.cowfs=ext4
  Desktop: GNOME v: 41.4 tk: GTK v: 3.24.31 wm: gnome-shell dm: GDM v: 41.3
    Distro: openSUSE Leap 15.4
Graphics:
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Lenovo
    driver: i915 v: kernel arch: Gen12.1 process: Intel 10nm built: 2020-21
    ports: active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:9a49 class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce MX450] vendor: Lenovo driver: nouveau
    v: kernel alternate: nvidia_drm,nvidia non-free: 515.xx+
    status: current (as of 2022-06) arch: Turing process: TSMC 12nm
    built: 2018-22 pcie: gen: 4 speed: 16 GT/s lanes: 4 link-max: lanes: 16
    bus-ID: 01:00.0 chip-ID: 10de:1f97 class-ID: 0302
  Device-3: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 3-6:3 chip-ID: 04f2:b6be class-ID: fe01 serial: <filter>
  Display: wayland server: X.org v: 1.20.3 with: Xwayland v: 21.1.4
    compositor: gnome-shell driver: X: loaded: modesetting unloaded: fbdev,vesa
    alternate: intel gpu: i915 display-ID: 0
  Monitor-1: eDP-1 model: AU Optronics 0xc391 built: 2020 res: 2880x1800
    dpi: 243 gamma: 1.2 size: 301x188mm (11.85x7.4") diag: 355mm (14")
    ratio: 16:10 modes: 2880x1800
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.2.4
    direct render: Yes

suse-prime is installed

nouveau.modeset=0 on grubs kernel command line has no effect (I see it with cat /proc/cmdline, but flickering/black screen stays).

It’s how Optimus users control which GPU is employed. Have you tried using it?

Inxi shows the i915 kernel driver loaded for the Intel IGP, and the nouveau kernel driver loaded for the NVidia GPU. Inxi also shows that Gnome on Wayland is running on the Intel IGP using the modesetting display driver and Intel Mesa renderer. Have you tried running Xorg instead of Wayland? ISTR NVidia users often don’t get along well with Wayland.

I installed lxde and fvwm. Also tried the three offered gnome variants during login. All have the same problem.

I tried prime-select intel, intel2 and nvidia. After relogin same results.

For some settings it seems login takes longer.

What logs should I look for error details?

Try to uninstall Nvidia and nouveau drivers both.
Reboot.
Update inxi.
Post


inxi -GSaz

Post all output, including command.

zypper rm nvidia-gfxG06-kmp-default
zypper rm xf86-video-nouveau

rebooted

only remaining nouveau/nvidia packages

rpm -qa | egrep -i ‘nouveau|nvidia’

kernel-firmware-nvidia-20220509-150400.4.5.1.noarch
libvdpau_nouveau-21.2.4-150400.66.1.x86_64
libdrm_nouveau2-2.4.107-150400.1.8.x86_64

inxi -aGSz

System:
  Kernel: 5.14.21-150400.22-default arch: x86_64 bits: 64 compiler: gcc
    v: 7.5.0 parameters: BOOT_IMAGE=(cd0)/boot/x86_64/loader/linux
    splash=silent quiet systemd.show_status=yes
    root=live:CDLABEL=openSUSE_Leap_15.4_GNOME_Live rd.live.image
    rd.live.overlay.persistent rd.live.overlay.cowfs=ext4
  Desktop: GNOME v: 41.4 tk: GTK v: 3.24.31 wm: gnome-shell dm: GDM v: 41.3
    Distro: openSUSE Leap 15.4
Graphics:
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Lenovo
    driver: i915 v: kernel arch: Gen12.1 process: Intel 10nm built: 2020-21
    ports: active: eDP-1 empty: DP-1,DP-2,HDMI-A-1 bus-ID: 00:02.0
    chip-ID: 8086:9a49 class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce MX450] vendor: Lenovo driver: nouveau
    v: kernel non-free: 515.xx+ status: current (as of 2022-06) arch: Turing
    process: TSMC 12nm built: 2018-22 pcie: gen: 4 speed: 16 GT/s lanes: 4
    link-max: lanes: 16 bus-ID: 01:00.0 chip-ID: 10de:1f97 class-ID: 0302
  Device-3: Chicony Integrated Camera type: USB driver: uvcvideo
    bus-ID: 3-6:3 chip-ID: 04f2:b6be class-ID: fe01 serial: <filter>
  Display: x11 server: X.org v: 1.20.3 with: Xwayland v: 21.1.4
    compositor: gnome-shell driver: X: loaded: modesetting unloaded: fbdev,vesa
    alternate: intel gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 2880x1800 s-size: <missing: xdpyinfo>
  Monitor-1: eDP-1 model: AU Optronics 0xc391 built: 2020 res: 2880x1800
    hz: 90 dpi: 243 gamma: 1.2 size: 301x188mm (11.85x7.4") diag: 355mm (14")
    ratio: 16:10 modes: 2880x1800
  OpenGL: renderer: Mesa Intel Xe Graphics (TGL GT2) v: 4.6 Mesa 21.2.4
    direct render: Yes


no change

You’re still using Live ISO?
Why not conduct standard install?

It is not my notebook. OS on disk should stay as it is - I will rarely use it, if possible with linux.

Added modeset to kernel commandline (and enabled ssh, so I can work on a flicker free console):

linux@caba1:~> inxi -aGSz
System:
  Kernel: 5.14.21-150400.22-default arch: x86_64 bits: 64 compiler: gcc v: 7.5.0
    parameters: BOOT_IMAGE=(cd0)/boot/x86_64/loader/linux splash=silent quiet
    systemd.show_status=yes root=live:CDLABEL=openSUSE_Leap_15.4_GNOME_Live rd.live.image
    rd.live.overlay.persistent rd.live.overlay.cowfs=ext4 nouveau.modeset=0
  Console: pty pts/1 DM: GDM v: 41.3 Distro: openSUSE Leap 15.4
Graphics:
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] vendor: Lenovo driver: i915 v: kernel
    arch: Gen12.1 process: Intel 10nm built: 2020-21 ports: active: eDP-1 empty: DP-1,DP-2,HDMI-A-1
    bus-ID: 00:02.0 chip-ID: 8086:9a49 class-ID: 0300
  Device-2: NVIDIA TU117M [GeForce MX450] vendor: Lenovo driver: N/A alternate: nouveau
    non-free: 515.xx+ status: current (as of 2022-06) arch: Turing process: TSMC 12nm
    built: 2018-22 pcie: gen: 4 speed: 16 GT/s lanes: 4 link-max: lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:1f97 class-ID: 0302
  Device-3: Chicony Integrated Camera type: USB driver: uvcvideo bus-ID: 3-6:3
    chip-ID: 04f2:b6be class-ID: fe01 serial: <filter>
  Display: server: X.org v: 1.20.3 with: Xwayland v: 21.1.4 compositor: gnome-shell driver:
    gpu: i915 note:  X driver n/a - try sudo/root tty: 140x24
  Monitor-1: eDP-1 model: AU Optronics 0xc391 built: 2020 res: 2880x1800 dpi: 243 gamma: 1.2
    size: 301x188mm (11.85x7.4") diag: 355mm (14") ratio: 16:10 modes: 2880x1800
  Message: GL data unavailable in console. Try -G --display

still black screen

tried suse-prime to force intel. Needed to install bumblebee to have bbselect.

linux@caba1:~> sudo prime-select intel
intel catched
Preparing first configuration
bbswitch not loaded


If you want energy saving bbswitch should be loaded in intel mode.
For this package 'bbswitch' needs to be installed on your system.
Or make use of DynamicPowerManagement on Turing GPUs or later by
switching to suse-prime's 'offload' or 'nvidia' mode.
Logout to switch graphics
linux@caba1:~> modprobe: FATAL: Module nvidia_drm not found.
modprobe: FATAL: Module nvidia_drm not found.
modprobe: FATAL: Module nvidia_drm not found.
NVIDIA kernel modules cannot be unloaded (tried 3 times). Your machine may need a reboot.
modprobe: ERROR: could not insert 'bbswitch': Key was rejected by service



Not sure I’m doing this right: why would it want to load nvidia(_drm) modules? Why would it want to unload nvidia modules that are not even installed?
Anyways, I logged out to switch graphics, but no change…

fwiw:

tried intel2

caba1:~ # zypper in xf86-video-intel

rebooted,

linux@caba1:~> sudo prime-select intel2

logout/in → no change

tried nvidia again

zypper in nvidia-gfxG06-kmp-default

reboot, sign MOK

caba1:~ # prime-select nvidia
nvidia catched
Preparing first configuration
bbswitch not loaded


If you want energy saving bbswitch should be loaded in intel mode.
For this package 'bbswitch' needs to be installed on your system.
Or make use of DynamicPowerManagement on Turing GPUs or later by
switching to suse-prime's 'offload' or 'nvidia' mode.
Logout to switch graphics

on logout/in:

linux@caba1:~> modprobe: ERROR: could not insert 'nvidia': Unknown symbol in module, or unknown parameter (see dmesg)
modprobe: ERROR: could not insert 'nvidia_drm': Unknown symbol in module, or unknown parameter (see dmesg)


ERROR: Unable to query GPU information


Configuration failed

manual load of nvidia module fails with same error again

caba1:~ # modprobe -v nvidia
install PATH=$PATH:/bin:/usr/bin; if /sbin/modprobe --ignore-install nvidia; then   if /sbin/modprobe nvidia_uvm; then     if  ! -c /dev/nvidia-uvm ]; then       mknod -m 660 /dev/nvidia-uvm c $(cat /proc/devices | while read major device; do if  "$device" == "nvidia-uvm" ]; then echo $major; break; fi ; done) 0;        chown :video /dev/nvidia-uvm;     fi;     if  ! -c /dev/nvidia-uvm-tools ]; then       mknod -m 660 /dev/nvidia-uvm-tools c $(cat /proc/devices | while read major device; do if  "$device" == "nvidia-uvm" ]; then echo $major; break; fi ; done) 1;       chown :video /dev/nvidia-uvm-tools;     fi;   fi;   if  ! -c /dev/nvidiactl ]; then     mknod -m 660 /dev/nvidiactl c 195 255;     chown :video /dev/nvidiactl;   fi;   devid=-1;   for dev in $(ls -d /sys/bus/pci/devices/*); do      vendorid=$(cat $dev/vendor);     if  "$vendorid" == "0x10de" ]; then       class=$(cat $dev/class);       classid=${class%%00};       if  "$classid" == "0x0300" -o "$classid" == "0x0302" ]; then          devid=$((devid+1));         if  ! -c /dev/nvidia${devid} ]; then            mknod -m 660 /dev/nvidia${devid} c 195 ${devid};            chown :video /dev/nvidia${devid};         fi;       fi;     fi;   done;   /sbin/modprobe nvidia_drm;   if  ! -c /dev/nvidia-modeset ]; then     mknod -m 660 /dev/nvidia-modeset c 195 254;     chown :video /dev/nvidia-modeset;   fi; fi  NVreg_DynamicPowerManagement=0x01 NVreg_DeviceFileUID=0 NVreg_DeviceFileGID=483 NVreg_DeviceFileMode=0660 
insmod /lib/modules/5.14.21-150400.22-default/updates/nvidia.ko NVreg_DynamicPowerManagement=0x01 NVreg_DeviceFileUID=0 NVreg_DeviceFileGID=483 NVreg_DeviceFileMode=0660 
modprobe: ERROR: could not insert 'nvidia': Unknown symbol in module, or unknown parameter (see dmesg)

dmesg shows

  387.147518] nvidia: loading out-of-tree module taints kernel.
  387.147527] nvidia: module license 'NVIDIA' taints kernel.
  387.147528] Disabling lock debugging due to kernel taint
  387.152561] nvidia: Unknown symbol __x86_return_thunk (err -2)
  387.263570] nvidia_modeset: Unknown symbol nvidia_register_module (err -2)
  387.263594] nvidia_modeset: Unknown symbol nvidia_get_rm_ops (err -2)
  387.263624] nvidia_modeset: Unknown symbol __x86_return_thunk (err -2)
  387.263634] nvidia_modeset: Unknown symbol nvidia_unregister_module (err -2)
  395.890232] nvidia: Unknown symbol __x86_return_thunk (err -2)
  437.973707] nvidia: Unknown symbol __x86_return_thunk (err -2)

Did some more tests:

  • Downloaded and tested Tumbleweed ISO
    ** Black screen flickering only with wayland - fine with xorg gnome, but general slowness with anything using graphic effects (menues, move windows, even just moving mouse, …)
    ** Install native nvidia + nouveau.modeset=0 made inxi report using nvidia mesa stuff - but same extreme slowness - you can do stuff if patient, but no fun.

  • Tried Ubuntu LTS 22.04
    Works like a charm right out of the box with nouveau. No slowness anywhere. Just to prove it is not a hardware issue.

Would like to go back because Ubuntu is new to me (I’m pretty sure there are some quirks waiting for me around the next corner) and Suse I know since 6.2 and work with SLES anyways.
But right now I think I stop here and give leap 5.4 some time to ripe before I invest more time in this.

Thanks for your support.

You may install openSUSE on drive attached by USB/eSATA/Thunderbolt/etc.
USB 3.x is much faster than USB 2.0.
Or you may replace ODD with your drive (SSD) via adapter.
LiveISO provides demo mode.

I use an USB3 stick. The performance of that stick with Ubuntu is very decent, more than I would need. When I complain about slownes, this refers to graphics. And with slow I mean it takes about a second until you can be sure the mouse is placed correctly on a menu.

No idea what you mean with ODD.