flickering boot up

Hi every one

recently i decided to do something with my old pc, so i said ill install linux many people
were telling me to install ubuntu but i read around and eventually decided to install openSuse 11.3

during installation everything went fine, but the screen started to flicker alot after installation and then when i tryed to boot it at the boot menu it shows the loading sign then halfway stops and goes black and flickers like mad>:(. I HAVE NEVER USED ANY FORM OF LINUX IN MY LIFE, and i have no idea what to do; it boots fine in fail safe mode just in normal it wont stop flickering, and i have used different monitors to no solution.

I have googled it and read around and nothing works. i am a experienced windows user and my pc is a compaq presario 6000, specs:
amd athlon (1.7ghz), ati r250 graphics ,512mb ram, 80gb ide hdd
any help is much appreciated:)

(also, does anyone know a good place for linux drivers, need one for netgear usb wireless adapter, thanks)

So we do not know how far you got with the installation. It may be that when you are in the Grub Operating System selection menu ready to select the default openSUSE startup, you just need to enter the kernel load option:

And then press the enter key. Some people with nVIDIA or AMD video cards often must load the proprietary video driver to get proper video and the flicker is one of the symptoms you might notice and the nomodeset can put you onto the road for proper operation.

Thank You,

thanks for the reply, very helpfull, i did try nomodeset and turned on; however the background is not loaded (just plain black) and the taskbar is semi-black but i can
see the firefox quicklaunch and green opensuse logo. and for the drivers is this link what i need http://old-en.opensuse.org/ATI_drivers. (by the way my computer(konqueror) does recognise my graphics card as r250)

If a r250 is one of the old depreciated cards the old driver will no longer compile to the newer kernels. This is an ATI issue. They don’t want to support old drivers anymore. Since nomodeset did don’t entirely fix the problem there must be more problems with your hardware configuration. Boot to fail safe. open a console window (command line) become root by typing

then the root password note that the password does not echo to the screen so don’t freak just type the password

Note Linux is case sensitive so be aware

then type

cat /boot/grub/menu.lst

highlight the output and in the console window edit menu select copy. Then past it between code blocks ( use the go advanced button) in a reply here.

There may be some other kernel options that may help this will show what the failsafe is doing.

BTW 512meg is really pretty primitive for a modern OS though it should run don’t expect a speed demon. You might want to try a lighter desktop environment. Also you did not say which desktop you installed.

yh, i know i 512 is very minimal but the pc is after all 10years old, and the truth is opensuse is running faster than xp.

linux-ssfs:/home/ADMIN # cat /boot/grub/menu.lst
# Modified by YaST2. Last modification on Wed Feb 23 13:11:42 GMT 2011
# Configure custom boot parameters for updated kernels in /etc/sysconfig/bootloader

default 0
timeout 8
gfxmenu (hd0,2)/boot/message
##YaST - activate

###Don't change this comment - YaST2 identifier: Original name: linux###
title openSUSE 11.3 - 2.6.34-12
    root (hd0,2)
    kernel /boot/vmlinuz-2.6.34-12-default root=/dev/disk/by-id/ata-WDC_WD800AB-22CBA1_WD-WMAA52080296-part3 resume=/dev/disk/by-id/ata-WDC_WD800AB-22CBA1_WD-WMAA52080296-part7 splash=silent quiet showopts vga=0x317
    initrd /boot/initrd-2.6.34-12-default

###Don't change this comment - YaST2 identifier: Original name: failsafe###
title Failsafe -- openSUSE 11.3 - 2.6.34-12
    root (hd0,2)
    kernel /boot/vmlinuz-2.6.34-12-default root=/dev/disk/by-id/ata-WDC_WD800AB-22CBA1_WD-WMAA52080296-part3 showopts apm=off noresume nosmp maxcpus=0 edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe vga=0x317
    initrd /boot/initrd-2.6.34-12-default

###Don't change this comment - YaST2 identifier: Original name: windows###
title Windows
    rootnoverify (hd0,0)
    chainloader +1

###Don't change this comment - YaST2 identifier: Original name: floppy###
title Floppy
    rootnoverify (fd0)
    chainloader +1

nomodeset likely forces the loading of the radeonhd driver. Without nomodeset its likely the radeon driver is being loaded.

For my wife’s old PC (with a ATI 9200 PRO (RV280) AGP graphic card) which she subsequently gave away to the made, what gave her PC special desktop effects with the radeon driver, was my edit her /etc/X11/xorg.conf.d/50-device.conf file, so that it read:

Section "Device"
  Identifier "Default Device"

  Driver "radeon"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"

  #oldcpu added following 2 lines
  Option "BusType" "PCI"
  Option "AGPSize" "64"


However that may be specific to her graphic card and NOT your card. And in fact it was not perfect, for while it did give special desktop effects, never the less I also did get artifacts after some time, when using that 50-device.conf file setting.

You might find this link of interest: SDB:Radeon - openSUSE

thanks for the help, but that link you gave has me puzzled since it says tested on 11.2 will it work for 11.3?
and it says the driver for my graphics card is pre-installed on opensuse 11.2 yet when i type in “$ lsmod | grep radeon” in console
it doesnt do anything, and when i typed in “$ glxgears” no gears apperead on screen to test my graphics card i also tried “glxinfo” and said that direct rendering: no.

is there anything in the above text (the one i posted earlier) which indicates why it works in failsafe, instead of normal?
(sidenote, is there a way to install .rpm offline)

UPDATE: info from sysinfo:/
model: rv250 if
2d driver: fbdev
3d driver: swrast (no 3d acceleration) (7.8.2)

more info on my system just in case its helpful: Product name Compaq Presario 6540UK
UK Product number DA394A #ABU
Microprocessor AMD Athlon XP - 2600+ (2.13 GHz)

VIA KM 266 chipset

266 MHz bus speed
Microprocessor cache Total cache 384 KB
Memory 512 MB DDR-SDRAM

2 DIMM sockets
Video graphics ATI Radeon 9000
Video memory 64 MB dedicated video memory
Hard drive 80 GB Ultra DMA hard drive (5400 rpm) including 4 GB partition for system recovery
Diskette drive 3.5 inch, 1.44 MB
Multimedia drive DVD-ROM drive: 16x max.
Fax/Modem V92-ready modem
Network card 10/100BT network interface
IEEE 1394 Interface
Sound Integrated AC '97 sound solution

flat panel 15inch tft monitor (P4825B#ABU)

with some modification it ‘might’.

In 11.2 there were two methods to configure graphics (1) automatically with X with no /etc/X11/xorg.conf file, and (2) the possibility to use an /etc/X11/xorg.conf file which would over rule any automatic X configuration.

In 11.3 there are three methods to configure graphics (1) automatically with X with no /etc/X11/xorg.conf file, and (2) the possibility to configure the various files under /etc/X11/xorg.conf.d/xx-yyyy files which would over rule any automatic X configuration, and (3) the possibility to use an /etc/X11/xorg.conf file which would over rule any settings in the /etc/X11/xorg.conf.d/xx-yyyyy configuration files and also over rule any automatic X configuration.

That says the ‘radeon’ driver is loaded. The radeon driver comes with the xorg-x11-driver-video rpm that comes with your openSUSE-11.3.

You might find this useful to read: openSUSE Graphic Card Practical Theory Guide for Users … in essence some time back, I wrote down the lump sum of my limited knowledge on this subject, in the hope that it might help other users. I concede that needs updating, as does my own knowledge, and I hope as a volunteer to learn more as time goes by.

Well, failsafe likely includes ‘nomodeset’ as a parameter. If you look inside the file /boot/grub/menu.lst (with root permissions) you will see the boot codes that are applied with failsafe. When opening that file be careful NOT TO CHANGE ANYTHING as it could break your PC’s ability to boot. I always keep a backup of that file.

Thats strange. It is saying the very basic fbdev driver is being used, instead of the higher performance radeon or radeonhd driver.

Note fbdev is the most basic of drivers. Then vesa driver has superior performance. Then radeonhd driver (where development work has mostly stopped) followed by the radeon driver (where most open source developement work is centered). Your hardware appears to be legacy hardware and hence I don’t think the fglrx driver will work on this.

You could try forcing a load of the vesa driver (which is superior to the fbdev driver).

Perhaps you could post the content of /var/log/Xorg.0.log to the paste site SUSE Paste and press create on that site, and then post here the URL/website address you are provided that is associated with that files posted contents.

hi, i read the ati section of your thoery post and is very helpful and thanks for that, instead of installing the vesa driver could i install the: mach64, r128 or ati driver im just asking? and here is the link like you asked SUSE Paste, interestingly in the same folder /var/log/ there is a Xorg.0.log.old. like i said at the start of this post
i have never used linux before so i dont know if its normal. again thanks in advance for your help

That clearly indicates your openSUSE is using the VERY basic FVDEV driver with your Video graphics ATI Radeon 9000 (RV250) graphics:

#    32.401] (II) FBDEV(0): Creating default Display subsection in Screen section
#        "fbdev" for depth/fbbpp 16/16
#    32.401] (==) FBDEV(0): Depth 16, (==) framebuffer bpp 16
#    32.401] (==) FBDEV(0): RGB weight 565
#    32.401] (==) FBDEV(0): Default visual is TrueColor
#    32.401] (==) FBDEV(0): Using gamma correction (1.0, 1.0, 1.0)
#    32.401] (II) FBDEV(0): hardware: VESA VGA (video memory: 3072kB)

The RV250 graphics are supposed to be supported by the radeon open source driver. If you type “man radeon” you will note:

       The radeon driver supports PCI, AGP, and PCIE video cards based on the following ATI chips:
       RV250       Radeon 9000PRO/9000, M9+

I recommend you install the application midnight commander (mc) which is a text editor that can be used in a full screen mode.

Then run “yast” (you can run yast in text mode with root permissions if X window not available) and navigate to yast > System > /etc/sysconfig Editor > System > Kernel > NO_KMS_IN_INITRD and change it to “yes”. This takes a minute or two to save once changed is submitted. (see below image examples).

Then boot with nomodeset and see if that works ?

If not, then reboot and apply the edit that I used (it might work with your PC) to the /etc/X11/xorg.conf.d/50-device.conf file, … and if it does not work, just undo the change. By using ‘midnight commander’ (launched by typing ‘mc’ (no quotes)) in a terminal you can easily do edits in a text mode. You could try an edit like this to the 50-device.conf:

Section "Device"
  Identifier "Default Device"

  #uncomment radeon line
  Driver "radeon"

  ## Required magic for radeon/radeonhd drivers; output name
  ## (here: "DVI-0") can be figured out via 'xrandr -q'
  #Option "monitor-DVI-0" "Default Monitor"

  #added following 2 lines
  Option "BusType" "PCI"
  Option "AGPSize" "32"


and maybe with that you can force the load of the radeon driver. After making the change try booting with that in place, without the boot code nomodeset (and if that does not work try with nomodeset boot code).

If it does not work, then simply undo the changes.

hi, before i try that, is it possible that it is using the basic driver since it is in failsafe mode?
i know that in windows when you boot into safe mode it uses the vga drivers not the graphics card drivers.

little side not, but which files should i back up to an external thumb drive?

little side not, but which files should i back up to an external thumb drive?

I typically keep a copy of every file in /etc/X11/xorg.conf.d/ and every file in /etc/modprobe.d, and also of /boot/grub/menu.lst, /boot/grub/device.map, /etc/fstab, and /etc/grub.conf.

Backing up those files goes beyond the issue/problem in this thread, but its my nominal ultra conservative proactive backup practise.

You can always check to see what driver loaded by looking inside /var/log/Xorg.0.log file. Also, sometimes by listing and looking at the loaded kernel modules (with ‘lsmod’) one can also tell what graphic driver is loaded.

thanks for your suggestion and the first one worked :)(the yast kernal config) i selected yes and rebooted my pc first with nomodeset and then without nomodeset both worked. i checked now and it is using the radeon driver whereas in failsafe it was using the basic fbdev driver. i just wanted to know by selecting yes what did it do?

and thanks for your help oldcpu, dont know how i could have done it, opensuse is very helpfull to first time linux users. THANKS;)

To say that I am very far from being knowledgeable on this would be a massive understatement. In truth, I do not know very much.

What I have read about KMS is this and this:

kernel mode-setting (KMS) involves moving the mode-setting code for video adapters from the user-space X server drivers into the Linux kernel. This may seem like an uninteresting topic for end-users, but having the mode-setting done in the kernel allows for a cleaner and richer boot process, improved suspend and resume support, and more reliable VT switching (along with other advantages).

i.e. KMS is supposed to allow the kernel to provide a more clean graphic functionality with X. However for some reason it does not always work well, which is what happened in the case of your openSUSE install/hardware combination. So by setting “NO_KMS” to YES, you in effect switched OFF that functionality.

thnks very much for your help , hopefully now i can fully enjoy my new linux os, and those links were very incite full.
onceagain thanks for your time and help.