Flash no sound

Hi there,
I recently updated to 11.2 - everything is running smoothly, except sound with Flash in Firefox.

I installed the latest plugins (32 bit also) from Adobe’s website and download.openSuse and checked that the volume is cranked up - no sound with Flash videos (youtube and the like).

When I log in, the welcome sound plays.

Any ideas would be very welcome.


I had this problem once, and the solution was that I had to change audio to PulseAudio.

I tried Pulse Audio - still test sound in Yast plays, but still no sound in Flash (youtube).

Some openSUSE-11.2 users with firefox noted that their PCM volume control would dynamically jump to zero volume when they started a flash video. After starting flash, check your PCM volume control in your mixer.

Some openSUSE-11.1 users noted to get sound working in flash they had to remove libflashsupport (but keep flash-player). I do not know if that problem is applicable to openSUSE-11.2.

Note PCM volume control is NOT the same as “master” nor “speaker” volume control labels.

You might have the PCM channel in your mixer muted or 0. If you want to be sure all is open, run ‘alsamixer’ in a terminal, while playing flash in a browser. Fool around with the levels and see what it does.

I have never obtained flash from Adobe’s web site (I’ve always used the SuSE-GmbH packaged version) so that could have introduced complexities I am not familiar with. Time for me to leave this thread (having just joined). :slight_smile:

lol! That’s a good one!
Could be solution I reckon.

I had to chuckle at this - But there’s a deal of sense in it.

Interesting: if I run alsamixer, I can modify the onboard sound card’s volume. The active card is a PCI card, though.

How do I explain alsamixer to use the “real” sound card?

got it - still no sound from the speakers (PCM set to 100)

Make certain you have the card you wish to use (for firefox) set as the primary card. Please read the guidance here in step#9: SDB:AudioTroubleshooting - openSUSE - step#9

Yes, the sound card I want firefox to use is set to primary card (0).

Besides, mp3s are being played by Amarok. It is just Flash which isn’t working with sound.

have you checked that you have the correct version MozillaFirefox-branding-openSUSE installed?

I had identical symptoms and this fixed it for me.

I recommend following the multimedia checks in thread:check your multimedia in ten steps in the multimedia forum

the first one of which is to perform a dependency check. e.g. with

LC_ALL=C zypper ve

I came across this post, because YouTube wasn’t giving any sound in Firefox 3.6 in 11.2.

Running the alsamixer command showed my PCM channel was set to zero! Increasing the PCM to max, then gave sound while watching a YouTube vid.

Thanks for the clear advice:)