Flash content detected as Shockwave?

I am taking an on line class which uses flash content. I can view the content fine on my Ubuntu system (Ubuntu 8.10, Firefox 3.0.8, Shockwave Flash Plugin 10.0.r22)

On Suse 11.1 (Firefox 3.0.10, Shockwave Flash Plugin 10.0.r22) the site presents me with a “you need to install Shockwave” notice.

So the big question is why does this work fine in Ubuntu where I of course have no Shockwave installed, but not in Suse?

(Despite the fact that the web site says you need shockwave, in actual fact the Shockwave Flash plugin plays the content flawlessly in Ubuntu, so I don’t think it is honestly Shockwave, but for some reason Firefox on Suse does not detect it correctly.)

Of course it goes without saying shockwave is not supported in Linux and the only option I know of is IE34Linux and installing Shockwave under Wine, etc. - but I did not have to do this in Ubuntu, so can’t understand why this same site is not working in Suse with the same flash player plugin.

And suggestions would be greatly appreciated as I would really like to use my primary desktop and not just my netbook for this class.


I decided to reinstall Flash player from the .tar.gz download from Adobe. Removed the package I was using, installed the .tar.gz one - works fine, same results however.

Also, I noticed that in Ubuntu Firefox preferences, Applications I have two entries:

Shockwave Flash File (application/futuresplash)
Shockwave Flash File (appliation/x-shockwave-flash)

Both set to Use Shockwave Flash (in Firefox)

In Suse I only have one entry in Application Preferences

Shockwave Flash File

(It does not differentiate between the two types as in Ubuntu. Perhaps this is related.)


Funny, the same thing happens to me as well!

I’d be keen for a fix/workaround if someone has one, too please.


Can you post a url eg of where you have the issue

I think I may have found a workaround of sorts.

Go Install software>search (add description)>Install swfdec-mozilla.

The app description states:

Swfdec is a decoder/renderer for Macromedia Flash animations. The decoding and rendering engine is provided in a library that can be used by other applications.
This package contains a Mozilla plugin that uses the Swfdec library for playing SWF files in a browser capable of loading Netscape-Plugins. It is in an experimental state at the moment, so don’t be surprised if it crashes your browser.

Don’t install anything else.

Restart firefox.

It looks as if suse may need some of the dependencies of the above, where as Ubuntu doesn’t.

Might be a suitable tie over until this prob is resolved…

Thanks for the input guys. Unfortunately I am still having trouble. I can’t really post the exact url as it requires a login to view the on line course contents.

I installed the swf-dec plugin (from Suse repo) and uninstalled swfdec-browser-plugin (from Pacman) - restarted Firefox, but still have the issue.

Callandor:~ # rpm -qa | grep mozilla

Callandor:~ # rpm -qa | grep swfdec

I decided to they try using the Free swfdec plugin - so I installed swfdec-0.8.2-1.24, enabled it in Firefox, and disabled the official Adobe plugin so that about: plugins only showed:

File name: libswfdecmozilla.so
Shockwave Flash 9.0 r999

This also did not work.

Certainly puzzling why this is so difficult and might be worthy of a bug report once we determine the root cause. I feel this should be improved as newer user would have a dreadful time if they ran into this. It works flawlessly in Ubuntu, so there just must be a dependency that is being missed, or perhaps an issue with the implementation of the content detection by swfdec in Suse perhaps?

Thanks again for the help.


Further strangeness . . .

I seem to be able to play the following shockwave page with swfdec fine

Mandrake Linux tips for free

Yet the page I am trying to use still insists that shockwave is not installed. Perhaps it is crappy plugin detection on the part of the page I am visiting. Does anyone know of a plugin that will get around this detection so I can trick the detection of the page I am trying to use? (Similar to say browser version detection one)


OK, so I fixed that prob on my PC.

Here’s what I did…

On my desktop PC running suse 11.1 (KDE 4.1.3) which has no issues with youtube vids, I went install software>search>flash, then I made a note of all the flash files there and compared to those on my laptop which didn’t like youtube vids. I then removed all entries on my laptop that weren’t on my desktop, and applied the ones that were on my desktop to my laptop. Then I applied the changes, and once completed restarted mozilla.

The files you should have ticked under install software>search>flash are:


Nothing else.

I hope that works for you as well as it did for me :wink: