fixing video resolution on PowerBook G4 (openSUSE 11)

I’ve got openSUSE 11 running pretty well on my G4/1.33 !5" al PowerBook except for the video resolution. I can’t seem to get it to give me native resolution, which is 1280x854. Instead I get 1280x800, which is somewhat distorted. Can anyone tell me how to fix this? The video card in the PowerBook is an ATI Radeon mobility 9700.

I looked over all of the monitor resolution settings available in yast2 and there is no option anywhere for my PowerBook native resolution, which is 1280x854. I wouldn’t care about the loss of the 54 vertical pixels, but the text resolution isn’t crisp without the native setting. Could it be as simple as adding 1280x854 to an xorg.conf file?

By the way, I did try compiling the proper ATI video card for my PowerBook, but they only had x86 or x86-64 versions and not one for the PowerPC architecture. It wouldn’t compile.

One other thought - I have Ubuntu also loaded on my PowerBook and it does have the proper resolution. It also assumes a different ATI card (openSUSE has only one ATI card option). Is there any way to import the card from Ubuntu to openSUSE?

No suggestions, anybody? What did you do if you had a video resolution that wasn’t displayed as an option on your openSUSE installation?

I myself fight with a Titanium PowerBook G4, with video issues. One of them seems to be similar. I know this doesn’t help you now, just that you know you are not alone. My situation is even worse, as i get no screen at all when i run Sax2. Only a copy of /etc/X11/xorg.conf.install works which is ridiculous as nothing is configured then.

I would try to work on a copy of the /etc/X11/xorg.conf and change the resolution there.

I haven’t had this problem recently, (for most of us sax2 does a great job), although manual editing of xorg.conf was a common occurrence only a few years ago. A CLI utility called xmode can be used to generate a modeline, which then can be added to your /etc/X11/xorg.conf file. For example:

xmode -x 1280 -y 854

Modeline “1280x854” 230.24 1280 1384 1528 1776 854 855 858 926

You can specify a refresh rate as well, but make sure you know the specs of your display first eg xmode -x 1280 -y 854 -r 60 gives

Modeline “1280x854” 89.96 1280 1352 1488 1696 854 855 858 884

You then add the desired (valid) mode line to the ‘Mode’ section of xorg.conf. A thread along similar lines here. Let us know how you get on.

Deano, i will try with me. As you seem to be a wizard, anything known how to get around the odd behavior of the ATI Radeon LY in the Titanium PowerBook G4? I am totally stuck at the moment. Tonight i will try to merge the xorg.conf that Sax2 had made and the xorg.confg.install form which i will cut out the “Screen” and “Device” sections to past in the one thats messed up by Sax2 and HOPEFULLY locate the problem to the screen or the video card.

Installing more than one Suse’s i never had such “drama” makes me freak out. :smiley:

Deano, i will try with me. As you seem to be a wizard…

:smiley: I wish!!! I’ve never owned a PowerBook, but I do own a ThinkPad with an ATI chipset. However sax2 just works for me, so I haven’t needed to tweak xorg.conf in a long time. I’ll be interested to see how you get on. Don’t forget to make a backup of your existing xorg.conf file first. (You may find sax2 has already created one for you).

For me as well as long as i do not start it :smiley: Anyhow, tonight i will merge the xorg.config’s and see what wrong, MUST be one of this sections. That will keep me up for a while :rolleyes:

I just wonder if ANYONE has Suse PPC running on that Apple PowerBook G4 667 (Gigabit - Ti)

If all would work it would be cool^2, for me at least. I had it up with Gnome and it was working like a charm.

Hi there

It seems Sax2 wont let you use that screen resolution
This is what worked for me in my xorg.conf:

Section "Monitor"
  DisplaySize  321 214
  HorizSync    30-33
  Identifier   "Monitor[0]"
  ModelName    "15 TFT STUDIO-DISPLAY"
  Option       "DPMS"
  Option       "PreferredMode" "1280x854"
  VendorName   "APPLE"
  VertRefresh  50-70
  UseModes     "Modes[0]"

Section "Modes"
  Identifier   "Modes[0]"

Section "Screen"
  DefaultDepth 24
  SubSection "Display"
    Depth      15
    Modes      "1280x854" "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  SubSection "Display"
    Depth      16
    Modes      "1280x854" "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  SubSection "Display"
    Depth      24
    Modes      "1280x854" "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  SubSection "Display"
    Depth      8
    Modes      "1280x854" "1280x800" "1280x768" "1280x720" "1024x768" "1280x600" "1024x600" "800x600" "768x576" "640x480" 
  Device       "Device[0]"
  Identifier   "Screen[0]"
  Monitor      "Monitor[0]"

Basically I used sax2 adding a 15 inches Apple monitor and setting the resolution to 1200x800, then manually modified the “preferred mode” of the monitor section from 1200x800 to 1200x854.

Also added “1200x854” under “mode” to each one of the display sections under “Screen”

Anyway, whatever modification you do to xorg.conf save the original first with another name so that if you have any problems you can rename it back using terminal.

Now I can’t use sax2 anymore because it’ll change it back to 1200x800.

That solves the resolution problem, but if I try to use compiz desktop efects the right side of the screen becomes grey (about 300 pixels or a bit more) and anything that gets there just melts (a black hole, or a grey one!)
And the taskbar where you can access all the programs just becomes a grey bar with nothing on it, only desktop icons are available. So if you’re gonna try that I’d suggest creating a launcher to “control center” or “desktop efects” on your desktop first so that you can disable it, but you’ll need to log off and in to go back to normal.

It looks to me as if the ati driver has some issues, though I think other people had the same issue with Ubuntu using compiz in other systems.

For now it’s good enough, but I’d like to have some desktop effects…

So i finally sorted it out. Letting Sax2 run in to black screen my xorg.config was built. Changing driver “rage” against driver “fbdev” works though i loose all good things about the ATI Rage Driver … it works and for an office laptop, well good enough.

I managed to sort my problem out by adding the resolution to the xorg.conf file. Modline worked as well. Thanks for the suggestions.

Thanks for the feedback. :slight_smile: