Fixing leap installation. (List of official repos)

Hello there, I have a small problem.
I have set up an open suse vm, tried to quickly install everything I need, so I tried to use one click installs.

Big mistake on my side, I sould have learned using the gui will only lead to problems. My installation was full with dead repos and plymoth required a version no longer avalible.

Now I have already weeded out the repos. And deleted and reinstalled plymouth. Now I would just like to understand why it is the way it is and how I should proceed.

“Zypper dup” would downgrade my openSuse-release. Is it possible I have removed a repo I shouldn’t have? Otherwise why could this be the case?

“Zypper up” lists 50 package updates that will not be installed.

I am sorry for this rather long post about something mundane, but I am everything but acustomed of and knowledgable in regards to Linux in general.

Not quite sure what you’re actually asking for, but these are the “essential” Leap 15.4 repositories.

Main OSS           $releasever/repo/oss/
Main Non OSS       $releasever/repo/non-oss/

Main Update OSS    $releasever/oss
Main Update Non OSS$releasever/non-oss/

Update Backports   $releasever/backports/
Update SLE         $releasever/sle/

That’s very helpful to me already :slight_smile:
It means I have not deleted any “essential” Leap 15.4 repositories.

I am still not understanding why there are 50 package updates that will not be installed, nor why “zypper dup” would downgrade my openSUSE-release from 15.4-lp1542.17.1 to 15.4-lp154.166.1

Just show the output of all the commands you are trying (including the initial command). We don’t see what you are seeing and can’t know what you are really doing…

Also show output of “zypper lr -d”

I genuenly can not apparently.

Trying to log in on PC redirects me to the open suse homepage. I just give up for now, main thing is, most things are fixed, and most trash repos are removed.

I got work to do, and altough it is something that annoys me and I’d like to fix, I don’t want to waste my time.

Probably because packages with a higher version/build level where installed from one or more of the repositories added by the use of 1-Click…


  • Version 15.4-lp1542.17.1 is higher than 15.4-lp154.166.1 (when using RPM rules to compare two versions)

  • Version 15.4-lp1542.17.1 is not present in openSUSE repositories and so is replaced by the highest available version

We have no idea where this strange version comes from, you never showed any factual information.

I could not be in any way more confused.
But yeah, if this is true, it does not make sense to me whatsoever, even less than before :smiley:
I will just go trough with zypper dup and call it a day.

It would be better if, you used the YaST Software Management tool and, carefully, selected the appropriate Repositories for the changes to be made to each incorrectly installed package.

  • Using “zypper dist-upgrade” is only relevant if you’re actually performing an upgrade.
    Leap ain’t Tumbleweed …