[FIXED] SUSE 11.2 не работает мышь

После установки OpenSUSE 11.2, при первой загрузке мышь работает… Стоит перезагрузится… и всё, не отвечает не на какие команды >:( Пробовал ставить и KDE и Gnome - всё тоже самое… Помогите плиз!

Нужно читать Xorg.0.log.

Итак попробуем описать детально:
При первой загрузке OpenSUSE мышь определяется правильно и в информации об оборудовании, в подпункте мышь, пишется следующие (примечание: сохранил в текстовом файле всю инфу об оборудовании):

10: udi = ‘/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port_logicaldev_input’
linux.hotplug_type = 2 (0x2)
linux.subsystem = ‘input’
input.device = ‘/dev/input/event1’
input.product = ‘ImExPS/2 Generic Explorer Mouse’
info.callouts.add = { ‘hal-probe-vmmouse’ }
input.x11_driver = ‘evdev’
info.subsystem = ‘input’
info.product = ‘ImExPS/2 Generic Explorer Mouse’
input.originating_device = ‘/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port’
info.udi = ‘/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port_logicaldev_input’
linux.sysfs_path = ‘/sys/devices/platform/i8042/serio1/input/input1/event1’
info.parent = ‘/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port’
info.category = ‘input’
info.capabilities = { ‘input’, ‘input.mouse’ }
linux.device_file = ‘/dev/input/event1’

мышь работает нормально. После перезагрузке мышь определяется, как я понял, как сенсорный экран!!!
и в инфе пишется:

2: udi = ‘/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port_logicaldev_input’
input.x11_options.HorizScrollDelta = ‘0’
info.callouts.add = { ‘hal-probe-vmmouse’ }
linux.hotplug_type = 2 (0x2)
linux.subsystem = ‘input’
input.device = ‘/dev/input/event1’
input.product = ‘elftouchPS2 ElfTouch Touchscreen’
input.x11_driver = ‘synaptics’
info.subsystem = ‘input’
info.product = ‘elftouchPS2 ElfTouch Touchscreen’
input.originating_device = ‘/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port’
info.udi = ‘/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port_logicaldev_input’
linux.sysfs_path = ‘/sys/devices/platform/i8042/serio1/input/input6/event1’
info.parent = ‘/org/freedesktop/Hal/devices/platform_i8042_i8042_AUX_port’
info.category = ‘input’
info.capabilities = { ‘input’, ‘input.mouse’, ‘input.touchpad’ }
linux.device_file = ‘/dev/input/event1’
input.x11_options.SHMConfig = ‘on’

Откуда система берёт такую информацию, и можно ли как нибудь её исправить?

Xorg.0.log - он где находится, и есть ли он у меня вообще?

/var/log/Xorg.0.log

Лог находится в /var/log/

Кажется, читал про что-то подобное. Надо теперь вспомнить где.

Вот мой Xorg.0.log, только интересно чем он может помочь, тут про мышь нет ничего:

X.Org X Server 1.6.5
Release Date: 2009-10-11
X Protocol Version 11, Revision 0
Build Operating System: openSUSE SUSE LINUX
Current Operating System: Linux escomp 2.6.31.5-0.1-desktop #1 SMP PREEMPT 2009-10-26 15:49:03 +0100 i686
Build Date: 02 November 2009 12:05:39PM

Before reporting problems, check X.Org Wiki - Home
to make sure that you have the latest version.
Markers: (–) probed, (**) from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(==) Log file: “/var/log/Xorg.0.log”, Time: Tue Mar 2 21:05:55 2010
(II) Loader magic: 0x3ac0
(II) Module ABI versions:
X.Org ANSI C Emulation: 0.4
X.Org Video Driver: 5.0
X.Org XInput driver : 4.0
X.Org Server Extension : 2.0
(II) Loader running on linux
(++) using VT number 7

(–) PCI:*(0:0:13:0) 10de:03d0:1462:7309 rev 162, Mem @ 0xde000000/16777216, 0xc0000000/268435456, 0xdd000000/16777216, BIOS @ 0x???/131072
(==) Using default built-in configuration (39 lines)
(==) — Start of built-in configuration —
Section “Device”
Identifier “Builtin Default nvidia Device 0”
Driver “nvidia”
EndSection
Section “Screen”
Identifier “Builtin Default nvidia Screen 0”
Device “Builtin Default nvidia Device 0”
EndSection
Section “Device”
Identifier “Builtin Default nouveau Device 0”
Driver “nouveau”
EndSection
Section “Screen”
Identifier “Builtin Default nouveau Screen 0”
Device “Builtin Default nouveau Device 0”
EndSection
Section “Device”
Identifier “Builtin Default fbdev Device 0”
Driver “fbdev”
EndSection
Section “Screen”
Identifier “Builtin Default fbdev Screen 0”
Device “Builtin Default fbdev Device 0”
EndSection
Section “Device”
Identifier “Builtin Default vesa Device 0”
Driver “vesa”
EndSection
Section “Screen”
Identifier “Builtin Default vesa Screen 0”
Device “Builtin Default vesa Device 0”
EndSection
Section “ServerLayout”
Identifier “Builtin Default Layout”
Screen “Builtin Default nvidia Screen 0”
Screen “Builtin Default nouveau Screen 0”
Screen “Builtin Default fbdev Screen 0”
Screen “Builtin Default vesa Screen 0”
EndSection
(==) — End of built-in configuration —
(==) ServerLayout “Builtin Default Layout”
() |–>Screen “Builtin Default nvidia Screen 0” (0)
(
) | |–>Monitor “<default monitor>”
() | |–>Device “Builtin Default nvidia Device 0”
(==) No monitor specified for screen “Builtin Default nvidia Screen 0”.
Using a default monitor configuration.
(
) |–>Screen “Builtin Default nouveau Screen 0” (1)
() | |–>Monitor “<default monitor>”
(
) | |–>Device “Builtin Default nouveau Device 0”
(==) No monitor specified for screen “Builtin Default nouveau Screen 0”.
Using a default monitor configuration.
() |–>Screen “Builtin Default fbdev Screen 0” (2)
(
) | |–>Monitor “<default monitor>”
() | |–>Device “Builtin Default fbdev Device 0”
(==) No monitor specified for screen “Builtin Default fbdev Screen 0”.
Using a default monitor configuration.
(
) |–>Screen “Builtin Default vesa Screen 0” (3)
() | |–>Monitor “<default monitor>”
(
) | |–>Device “Builtin Default vesa Device 0”
(==) No monitor specified for screen “Builtin Default vesa Screen 0”.
Using a default monitor configuration.
(==) Automatically adding devices
(==) Automatically enabling devices
(WW) The directory “/usr/share/fonts/TTF/” does not exist.
Entry deleted from font path.
(WW) The directory “/usr/share/fonts/OTF” does not exist.
Entry deleted from font path.
(==) FontPath set to:
/usr/share/fonts/misc:unscaled,
/usr/share/fonts/truetype/,
/usr/share/fonts/Type1/,
/usr/share/fonts/100dpi:unscaled,
/usr/share/fonts/75dpi:unscaled
(==) ModulePath set to “/usr/lib/xorg/modules/updates,/usr/lib/xorg/modules”
(II) Cannot locate a core pointer device.
(II) Cannot locate a core keyboard device.
(II) The server relies on HAL to provide the list of input devices.
If no devices become available, reconfigure HAL or disable AllowEmptyInput.
(II) Open ACPI successful (/var/run/acpid.socket)
(II) System resource ranges:
[0] -1 0 0xffffffff - 0xffffffff (0x1) MX**
[1] -1 0 0x000f0000 - 0x000fffff (0x10000) MX**
[2] -1 0 0x000c0000 - 0x000effff (0x30000) MX**
[3] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX**
[4] -1 0 0xffffffff - 0xffffffff (0x1) MX**
[5] -1 0 0x000f0000 - 0x000fffff (0x10000) MX**
[6] -1 0 0x000c0000 - 0x000effff (0x30000) MX**
[7] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX**
[8] -1 0 0xffffffff - 0xffffffff (0x1) MX**
[9] -1 0 0x000f0000 - 0x000fffff (0x10000) MX**
[10] -1 0 0x000c0000 - 0x000effff (0x30000) MX**
[11] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX**
[12] -1 0 0xffffffff - 0xffffffff (0x1) MX**
[13] -1 0 0x000f0000 - 0x000fffff (0x10000) MX**
[14] -1 0 0x000c0000 - 0x000effff (0x30000) MX**
[15] -1 0 0x00000000 - 0x0009ffff (0xa0000) MX**
[16] -1 0 0x0000ffff - 0x0000ffff (0x1) IX**
[17] -1 0 0x00000000 - 0x00000000 (0x1) IX**
[18] -1 0 0x0000ffff - 0x0000ffff (0x1) IX**
[19] -1 0 0x00000000 - 0x00000000 (0x1) IX**
[20] -1 0 0x0000ffff - 0x0000ffff (0x1) IX**
[21] -1 0 0x00000000 - 0x00000000 (0x1) IX**
[22] -1 0 0x0000ffff - 0x0000ffff (0x1) IX**
[23] -1 0 0x00000000 - 0x00000000 (0x1) IX**


Помогите плиз… Я первый раз ставлю Linux, и тут нате выньте, вроде проблема то шуточная, а вот решение :-//

Думаю, надо жёстко прописать мышь в xorg.conf и отключить автоопределение.

Если xorg.conf отсутствует (в /etc/X11), нужно загрузиться в консоль, без графики и выполнить в сеансе root

Xorg -configure

Потом скопируйте

cp /root/xorg.conf /etc/X11/xorg.conf

И в этом файле нужно вписать

Section "ServerFlags"
    Option         "AutoAddDevices" "off"
    Option         "AllowEmptyInput" "false"
    Option         "AutoEnableDevices" "false"

Спасибо за помощь!! мышь заработала rotfl!, но работает она бешенно, ей невозможно управлять :X Подскажите плиз где можно прописать настройки скорости передвижения курсора… Стандартный, визуальный, настройщик не помогает…

А как сейчас выглядит секция “InputDevice” с мышью?

Посмотрите man mousedrv. Там есть упоминание про опцию “Sensitivity”.

Таакс вот весь xorg.conf:

Section “ServerLayout”
Identifier “X.org Configured”
Screen “Screen0”
InputDevice “Mouse0” “CorePointer”
InputDevice “Keyboard0” “CoreKeyboard”
EndSection

Section “ServerFlags”
Option “AutoAddDevices” “off”
Option “AllowEmptyInput” “false”
Option “AutoEnableDevices” “false”
EndSection
Section “Files”
ModulePath “/usr/lib/xorg/modules/updates”
ModulePath “/usr/lib/xorg/modules”
FontPath “/usr/share/fonts/misc:unscaled”
FontPath “/usr/share/fonts/truetype/”
FontPath “/usr/share/fonts/TTF/”
FontPath “/usr/share/fonts/OTF”
FontPath “/usr/share/fonts/Type1/”
FontPath “/usr/share/fonts/100dpi:unscaled”
FontPath “/usr/share/fonts/75dpi:unscaled”
EndSection

Section “Module”
Load “dri2”
Load “vnc”
Load “extmod”
Load “dri”
Load “dbe”
Load “glx”
Load “record”
EndSection

Section “InputDevice”
Identifier “Keyboard0”
Driver “kbd”
EndSection

Section “InputDevice”
Identifier “Mouse0”
Driver “mouse”
Option “Protocol” “auto”
Option “Device” “/dev/input/mice”
Option “ZAxisMapping” “4 5 6 7”
EndSection

Section “Monitor”
Identifier “Monitor0”
VendorName “Monitor Vendor”
ModelName “Monitor Model”
EndSection

Section “Device”
### Available Driver options are:-
### Values: <i>: integer, <f>: float, <bool>: “True”/“False”,
### <string>: “String”, <freq>: “<f> Hz/kHz/MHz”
### [arg]: arg optional
#Option “SWcursor” # <bool>]
#Option “HWcursor” # <bool>]
#Option “NoAccel” # <bool>]
#Option “ShadowFB” # <bool>]
#Option “UseFBDev” # <bool>]
#Option “Rotate” # <str>]
#Option “VideoKey” # <i>
#Option “FlatPanel” # <bool>]
#Option “FPDither” # <bool>]
#Option “CrtcNumber” # <i>
#Option “FPScale” # <bool>]
#Option “FPTweak” # <i>
#Option “DualHead” # <bool>]
Identifier “Card0”
Driver “nv”
VendorName “Unknown Vendor”
BoardName “Unknown Board”
BusID “PCI:0:13:0”
EndSection

Section “Screen”
Identifier “Screen0”
Device “Card0”
Monitor “Monitor0”
SubSection “Display”
Viewport 0 0
Depth 1
EndSubSection
SubSection “Display”
Viewport 0 0
Depth 4
EndSubSection
SubSection “Display”
Viewport 0 0
Depth 8
EndSubSection
SubSection “Display”
Viewport 0 0
Depth 15
EndSubSection
SubSection “Display”
Viewport 0 0
Depth 16
EndSubSection
SubSection “Display”
Viewport 0 0
Depth 24
EndSubSection
EndSection

в mousedrv про сенс ничего нет :shame: Кстати, он находитсе в ядре? Его вообще можно редактировать?

Попробуйте в
Driver “mouse”
Option “Protocol” “auto”

auto заменить на explorerps/2

man mousedrv

Option “Sensitivity” “float”
Mouse movements are multiplied by this float before being processed. Use this mechanism to slow down high resolution mice. Because values bigger than 1.0 will result in not all pixels on the screen being accessible, you should better use mouse acceleration (see man xset) for speeding up low resolution mice. Default: 1.0

Эта опция прописывается в этот же xorg.conf, в секцию с мышью.

У мыши два колеса?