Fish:// does not connect


I sometimes use Dolphin and the URI fish:// to work with a SLES15SP4 host. This is a very comfortable way to edit a file or copy a file …

But now the connection is never established. My desktop openSUSE Leap 15.4 is able to connect to several hosts ((open)SUSE and other Distributions) but to a SLES15SP4 a connection is not possible. At the end I get the message ‘Folder is empty’.

I can reach this host via ssh and scp and I can mount a folder from there into my filesystem via mount.sshfs. But fish:// … no change.

BTW: sftp does not work, too.

Any hints? What is necessary to get this protocol running?

Please check the access permissions on the target host –

  • The user credentials you’re using to access that target host may well have been changed to restrict access to that target host.

I try to reach the home-folder of ‘root’ :wink:

So I use fish://root@:/root
and use the root-Pwd. This is successfull via scp at the CLI.

Normally, any attempts to access the home directory of the user “root”, regardless of local access attempts or, access attempts by means of network connections, are by default not allowed.

  • The same, usually, applies to the system directories …
    Except when, and administrator, for whatever reason, adds the system directories to either the NFS exports list or, the exports list of any other server application …

  • I know of systems where, login to the user “root” and other system administration users, was allowed by means of the physical console terminal of the machine, which was physically separated from all the other machines in the computer room by means of a locked cage
    The key to access that console was available only to a hand full of the administrators, despite the restricted access to the computer room plus, the restricted access to the building …

As long as scp with the user ‘root’ is possible it should be possible via fish …
And it is possible to SLES12SP5; RasPI, …
But a fresh SLES15SP4 installation makes trouble.

That it may be a SLES problem and not an openSUSE problem??

This is possible. (Thanks god it is not our problem …)

I thought let’s ask at both sides. Maybe there is someone who knows which packages are neccessary for this feature.

I do not think you told us you also asked somewhere in SLES. Thus I thought it might help you better going there.

Of course when somebody here has a hint that is would be nice.

Meaning that, you can access the user “root” on the target host host by means of SSH and the related “secure file copy” utility …

  • Are you certain that, the target host system has changed the default access permissions for the user “root”?

For everyone, a comparison of SFTP, SCP and FISH → <>

Ok, so forgot all strings ‘fish’ in my postings and set ‘sftp’. It shows the same behavior.

It looks like the sftp add-on for SSHd is enabled.
sshd_config shows:

# override default of no subsystems
Subsystem       sftp    /usr/lib/ssh/sftp-server

But the URL sftp://tester@:/home/tester
in dolphin shows ‘loading’ and after a timeout: ‘Empty folder’
But of course, there are files in it.

And I do not get a question to enter the credentials of the user ‘tester’.

It looks like an issue in KDE / kioslave or somewhat else since month … :roll_eyes:

But as long it is possible to use WinSCP from an M$ all is good … :face_with_symbols_over_mouth:

So I have to use filezilla … an additional program for the same task …

OK, going sleep …

If Dolphin then, KDE Plasma.

  • If KDE Plasma then KWallet.

Please check, the KWallet entries for accessing the target host.

  • There may be something in ‘~/.cache/dolphin/qmlcache/’ – clean out that Cache directory.
    It may be that, the stored Dolphin state is messed up – remove ‘~/.local/share/dolphin/dolphinstaterc’ and try again.

This was helpful!
I think fish is deprecated …
So I should prefer sftp:// in dolphin.

But the issue stay :wink:
Because there are the same symptomes.