First time installation 13.2. Stuck at loading initial ramdisk...

Starting my own troubleshooting thread.

I’m having an issue with Loading Initial Ramdisk… when Grub2 tries to start openSuse. This is my first time trying out the Linux side in general, so i decided to dual boot my HP Pavilion DV4 laptop with Windows 8.1 (no uefi and no secureboot enabled).
I get openSuse installed and everything worked on initial installation. Then i go ahead and perform the System Updates that are recommended (163 of them) and immediately after restarting it gets stuck at grub2 screen with loading initial ramdisk… I’ve tried re-installing the OS 2 times and installed it on a separate harddrive just for sanity… I don’t know where to start on this issue. i’ve read a bunch of different things about possible graphics drivers issue but not sure where to start.

My graphics card is an AMD/ATI RS880 Radeon HD4200. I did notice that there is an update to the radeon graphics driver in the 163 updates and i’m wondering if that has anything to do with it, but unclear how to drop it back to the old driver. Let me know if anyone has any suggestions. I really wanted to try openSuse since my work uses Suse as their enterprise distribution for servers.

Thanks in advance!

First at boot select advanced and select the recovery boot option. see if that works if it does tell use and we will go on from there

Hey Gogal,

it does not, I’ve tried both kernal options that i now have as well and neither work.

Did you do any changes to the standard install?
ie swap,root,home partitions? Did you use at least 40gig for root? What size are your partitions

Did you hibernate?

Are you sure you ran the installer in legacy mode and not in EFI??

On the spare harddrive that i installed on i formatted the entire drive and created the following

20 GiB /
20 GiB /Home

i did not hibernate at all.

and i’m not sure where the option is to run the installer in legacy mode and not EFI mode is. I’ll try to boot up the installer cd again and see if i can find it.

bah sorry no, my laptop doesn’t have EFI mode.

It is the way it is booted in a EFI based machine.

You can tell by the name of the grub file it wants to install normal legacy is grub2… efi is grub2-efi

So what hardware are you trying to install to may be someone has experience

I assume the spare drive install also was ok until updated???

Ok also 20 gig root is too small if you use the default BTRFS files system. I’d recommend you use the ext4 instead. You have to take control of the install and tell the installer what you want

BTRFS includes a snapper program that takes periodic snapshots of the root drive. This eats up disk space.

But you seem to fail before the kernel loads so I don’t know. Somthing about your hardware I’d guess that the newer kernel doe not like.

Note also that the updater may tell you you need to reboot before all the updates are done please what until all are finished before reboot.

It was definitely using Grub2 and not grub2-efi

The spare drive also worked well until updating you are correct.
I also formatted the root as ext4 as i didn’t know much about BTRFS.
And yes, i waited fully for the updates to be completed in Yast2 before rebooting at the end.

the hardware is hp dv4 2145dx

is there any way i can see the steps that it’s trying to take during the (loading initial ramdisk) section to help troubleshoot? are there log files generated during boot that i can look at?

press esc immediately at boot but load ramdisk is pretty much the first step.

That looks like pretty vanilla hardware as far as notebooks go.

Thanks, yeah i was thinking they were too. i guess i’d have to go through the list of 163 updates and try to find ones related to the hardware drivers? like i said radeon was found and updated during the upgrades but i’m not sure if it’s related or not.

I ended up trying to install 13.1 KDE on my spare drive and performed all the updates and it works just fine after updating. not sure if there is any particular way i can troubleshoot this bad boy. Might just have to stick with 13.1.

You can also follow this: