firewire and dvgrab problem

Hi from rushman.

Could some one please explain how I can get
Firewire 1394,and dvgrab to work in user.

Both work fine in root. 1394 dev has permissions enabled.

Both the above have always worked out of the box,
has something changed or is this a bug?

Thank you rushman

If I modprobe raw1394 as root, and do a ‘dvgrab’ as a user, it simply says ‘no camera’. So no problem starting dvgrab.
Once again it might be you need ‘kernel-default’ instead of ‘kernel-desktop’. You can replace one by the other through the software installer.

Hi and thank you.

it still does not function but now comes back with no
permissions,which is a little further on.

Now running kernel default with a restart.


I now use openSUSE 11.2 and had the same problem. Follow the solution that is given at this link:

FAQ - IEEE 1394 FireWire Wiki



thank you very much.

Do you use kino?
up until export all is ok but will not write to
disk,saying file is over 2gig,sometimes it reports dvauthor
has failed.

Kdenlive is similar

openmovieeditor does not load either via 1click or RPM.

Groisofs does not seem to be available for 11.2.

Thanks again

Kino ceased to be able to grab DV video from my camera in 11.2. :frowning: So I searched and found this post, and all is well now! Thanks! :slight_smile:

However, I did not find anything in the openSUSE wiki. Where would be a good place to write something about it?

Also, if this problem is known, why isn’t there a patch meanwhile? Was this reported in Bugzilla?

Not everyone searches the forums for things like this. I would guess many people just give up and might erroneously blame bad hardware support on Linux in general. Not ideal.

I added a warning containing the above link to the Firewire FAQ to Video_editing and dvgrab now. Although I did not find them myself initially, these seem to be the appropriate places in the Wiki.

Hi Guys, would this fix include support for External Firewire Hard-drives too…? Yesterday night, i ran lspci and could not find any entries for IEEE / 1394 / Firewire.

Also modprobe raw1394 fails to load the module, its says its not availabe [FATEL:… blah blah blah] - sorry not at home to get exact message, i shall add some more details when i get back.

Following kim4mich link - i get into a mess and go around in circles. I cannot seem to download the correct module to compile for proper FireWire support. Does this need to be dome via GIT / Fetch…? when i try GIT, it starts to download the whole Repro…? All 160 Megs worths…

I’m using a fresh install of 11.2 - x64, using the 2.6 PREEMPT kernel. I think when installing 11.2, it didn’t detected my on-board FireWire controller. My MoBo is an MSI K8N Diamond plus - i have a smolt profile somewhere, would that help for exact hardware specifics 11.2 has detected. I’v tried to install the ieee package too from Software Management, but this hasn’t worked.

I’m up for doing what ever to get this working - just let us know…

I’m anxiously awaiting for 11.3’s release…

Right numpty me is - Well i was going a bit stir crazy as to why my External Firefire drive was not working under 11.2… I checked if i had the necessary packages installed [following above advice/links…]

It turned out, i had reset my BIOS last week after installing a new component or two. As a result, reverting to defaults disabled my ieee/FireWire controller. I Re-enabled it, booted into 11.2, logged in as myself and all worked a treat - go figure… :shame:

I have not tested this, but i think out the box, Firewire drives should work just fine like any other External drive/USB thumb stick.

Thank again for above posters.