Firewall blocking Transmission

I had swapped out HDDs in my desktop and installed 11.4 x64 Gnome version again. For some reason Transmission was not included and I had manually added it from the repos.

I am unable to connect to the web ui from another pc on my lan. In the firewall I have added TCP ports 51413 (Transmission default) and 9091 (for the web interface). After clicking ok, and exiting the Firewall settings, I go back to Transmission and try testing the port. Its says that it is still closed and I am unable to access the web ui. If I turn off the firewall I can access it ok, but I’d rather not have the firewall disabled.

I rebooted with the previous HDD and install to check what my settings were, and I had not allowed the ports (51413 and 9091) yet Transmission was allowed through. I’m not sure what is causing my issue with the other install.

I had tried searching the forums and have seen the threads about setting up for bittorrent, but have had no luck getting it working. Any guidance would be appreciated.

Please look at the firewall logs on the install this doesn’t work. You need to enable it for example in YaST (logging of dropped packets) and you will see them in /var/log/firewall.

Thanks Greg,

I went to grab my log file and realized I had my SSH X session going. I cleared the log, shut everything down, rebooted, and on boot up I was able to access Transmission.

Im not sure what happened before, but It seems to be working now as it should.

Thank you for pointing me to the log files folder. I’ll be sure to keep my eye on this folder.

Happy to help and good job on making it work again :slight_smile: I’m really not sure why this did not work from the start.

Reopening this thread 'cause I can’t get open port on Transmission. Disabling firewall the port is open. Keeping fw on, how can I open the port?
Adding the port (same TCP and UDP) to “Advanced” in “Allowed services” gave me no results.

Oh, uPnP is enalbed in router and transmission!

where did you get it and how did you install which version of
Transmission?

what version of openSUSE are you running? or, is it Tumbleweed?


dd
openSUSE®, the “German Engineered Automobile” of operating systems!

In general, when failing connecting to a service, typically the service isn’t running or the service is running but blocked, likely by a FW.

You’re suggesting you can connect with the FW down so the service is running.

So,
Have you stop/restart the FW after making changes?
Have you tested connection using telnet?


# telnet <destination> <portnumber>

Depending on what the result is, either the FW is still blocking that port or the service behind the port is not responding.

HTH,
TSU

On Sun, 24 Feb 2013 14:36:01 +0000, susebh wrote:

> Oh, uPnP is enalbed in router and transmission!

I don’t trust UPnP myself - try setting an explicit port forward on the
firewall.

FWIW, I use Transmission myself, and it works just fine here with an
explicit port assignment and port forward set up on the router, and the
port opened in the firewall.

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

@dd

cat /etc/SuSE-release && transmission -v
openSUSE 12.2 (x86_64)
VERSION = 12.2
CODENAME = Mantis
transmission-qt 2.60 (13375)

Transmission is installed from standard oSUSE repos.

@tsu2

# telnet MYLANIP PORT
Trying MYLANIP...
telnet: connect to address MYLANIP: Connection refused

With FW and Transmission stopped.

telnet MYLANIP PORT
Trying MYLANIP...
Connected to MYLANIP.
Escape character is '^]'.

When FW is on and Transmission is started (Transmission says Port is closed)

Have you stop/restart the FW after making changes?
Yes.

@hendersj
I prefer having UPnP enabled:

  1. for the sake of convenience
  2. has always been enabled and so far has always worked :wink:

On 2013-02-25 10:36, susebh wrote:

> Code:
> --------------------
> telnet MYLANIP PORT
> Trying MYLANIP…
> Connected to MYLANIP.
> Escape character is ‘^]’.
> --------------------
> When FW is on and Transmission is started (Transmission says -Port is
> closed-)

Did you actually type that, “PORT” in letters? You have to type the
appropriate number…

No, don’t ask me which number, I would have to read Transmission
documentation myself. You do that :slight_smile:

As has been previously suggested, you have to look at your firewall log
and read there what packets get rejected and on what port and method.

If you did the commands above using the port number, then obviously that
port number is closed in the firewall and the entry will be listed in
the log. Just open it.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

On Mon, 25 Feb 2013 09:36:01 +0000, susebh wrote:

> @hendersj I prefer having UPnP enabled:
> 1. for the sake of convenience 2. has always been enabled and so far has
> always worked :wink:

I used to as well - then I read about the security issues with having UPnP
enabled. There are some potentially nasty issues with using it, from
what I’ve read, and since the port is a fixed port, just setting up the
forwarding and then forgetting about it has worked for me. :slight_smile:

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

In telnet command I used the IP of my PC (not the external IP gave from my ISP) and I wrote the port number I chose for Transmission.
How/where should I check for fw logs?

On 2013-02-26 14:56, susebh wrote:
> How/where should I check for fw logs?

Linux stores all logs in “/var/logs/”. And the firewall log has
“firewall” in the name.


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

On 02/26/2013 04:43 PM, Carlos E. R. wrote:
> Linux stores all logs in “/var/logs/”. And the firewall log has
> “firewall” in the name.

on my system it is /var/log/firewall

note: log, not logs–i know because last week i was astonished to see
something like this:

linux-os114: # tail -n500 /var/logs/messages | grep -i error
tail: cannot open `/var/logs/messages’ for reading: No such file or
directory
linux-os114: #

i may forget next week, again. :frowning:


dd
openSUSE®, the “German Engineered Automobile” of operating systems!
http://goo.gl/PUjnL
http://tinyurl.com/DD-Caveat
http://tinyurl.com/DD-Hardware
http://tinyurl.com/DD-Software

This suggests that unless another application is using the same port, Transmission is listening on that port and the FW is not blocking.

So,
Recommend re-verifying you’re using an unused port (maybe try another?)
Try a different browser, maybe even a text browser like Lynx. The objective is to see the HTML code from Transmission (it doesn’t have to be intelligible, just verify that a web page is actually being served).

What you’re trying to do is narrow down

  • Is the problem with the client (web browser)?
  • Is the problem with the Transmission application configuration?
  • If the problem is not a Transmission configuration, could it be a faulty or incomplete install?

TSU

On 2013-02-26 18:56, tsu2 wrote:
> Code:
> --------------------
> > > telnet MYLANIP PORT
> > Trying MYLANIP…
> > Connected to MYLANIP.
> > Escape character is ‘^]’.
> --------------------
>>> > > When FW is on and Transmission is started (Transmission says -Port is
>> > closed-)
>> >
>> >
> This suggests that unless another application is using the same port,
> Transmission is listening on that port and the FW is not blocking.

Are you sure?

The telnet above shows that the connection succeeds, and I understand it
is happening with the FW down.

Do you think that transmission is also down at that point and it is
something else which is responding?


Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

I;m interpreting the result as

Transmission running
FW on, but with Transmission port allowed
Client is connecting to “something” but but not Transmission.

Just occured to me…
Bit torrent apps want an open port for inbound connections for normal torrent traffic but
A separate port needs to be opened for Web administration.

So,
Are you sure you’ve enabled and tested <both> ports, and the proper port(s)?
So, for example you could be telnet to the torrent port and getting a connection but still have the web admin port closed.

TSU

Solved disabling UPnP in router and Transmission. Firewall is running and I forwarded Transmission TCP port into router.
I’m starting to think that the problem was concerned between FW and the UPnP service…

On Thu, 28 Feb 2013 21:36:02 +0000, susebh wrote:

> Solved disabling UPnP in router and Transmission. Firewall is running
> and I forwarded Transmission TCP port into router.
> I’m starting to think that the problem was concerned between FW and the
> UPnP service…

I didn’t find UPnP to be particularly reliable, either. Lacking security
and reliability, it seemed better to do just what you did. :slight_smile:

Jim


Jim Henderson
openSUSE Forums Administrator
Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C