Firefox Weird Problems

I am running openSuse 11.2, Firefox 3.5.7 and have the following strange problems. Radio buttons on web pages have no response when clicked. From the menu bar - Clicking Edit, Preferences, does nothing. Also from the menu bar - Clicking Help, About Firefox, does nothing. This starting after auto update today. I’ve tried installing FF 3.6, messed around with xulrunner plus a ton of other things. Any ideas? Thanks.

What web site? Or does this happen on all websites with radio buttons? What plugins do you have enabled in Firefox?

Assuming it is a Firefox issue (not sure) :

  • Exit Firefox
  • Rename your ~/.mozilla directory
  • Restart Firefox

You will lose all your extensions and settings (but you backed up your .mozilla directory first). If it works you can investigate further to find out what is causing the problem.

I am using a pristine profile (I had deleted .mozilla) and it does happen on all websites. It sure appears to be a Firefox problem, everything else works and right now I am using Opera as my browser.

I will have to correct myself. Radio buttons work, it is the Java buttons that do not work. By going into about:config I see that Java is enabled. At least I have some direction where to look now - I hope.

Does it make a difference if you disable java? Also GTK is responsible for drawing some buttons on FireFox. Try to change the GTK theme.

Well, thank you for confirming it happens on all sites. This tells me it is something with Firefox. You telling me that it doesn’t occur on Opera is meaningless to me. Why? Because Opera is it’s own program. I need to know what plugins are showing up in Firefox. There are a few ways to do this. Go to Tools>Add-Ons, once in Add-Ons click on plugins. Another way is to type in the address bar


Don’t delete stuff. Instead, rename things. For example.

mv .mozilla .mozilla.old

This way, once you solve it, you can either restore bits of your profile, such as bookmarks, passwords, cookies, cache, and so on, or you can restore the entire thing.

There is a report of Firefox breaking java with the 3.6 release. I don’t know about 3.5.7. What I’d suggest is go with the default Firefox out of the oss repository, or off the CD/DVD. At least then java will work.

If anyone else has a way of solving java and 3.6 I’m all ears. I tried installing java manually and that didn’t help.

Got it. Link this to browser-plugins. is found in /usr/java/jre1.6.0_18/lib/amd64

In my case I can delete .mozilla, it was just a link. And the statement “Opera is it’s own program” make me lose any confidence I had for this place. I am going elsewhere for help.

Something happened to me today - in 11.1 x86_64 I did a YaST update to firefox and it suddenly won’t start (the update to Thunderbird went OK). No errors, nothing - just won’t start. Also Epiphany starts, builds the GUI, then disappears. Tried to switch to SeaMonkey, and it runs, but it failed to import all my settings from Firefox - and it keeps asking for some weird password on startup and whenever I try to save settings. Seems it’s a new-version bug…:’(

Renaming the .mozilla directory worked - is there any way to get my toolbar/links/stored passwords back?

Yes. You can use Dolphin or Konqueror on Konsole for this, but go into the mozilla directory that you renamed and find firefox and go into that directory. Once in there, you will see a directory with a series of letters and numbers.default. Go into that. You’ll see bookmarks, cache, and just tons of stuff. You can copy that into the new .mozilla directory. Just make sure its not just in the .mozilla directory. Make sure to put it in .mozilla/firefox/yabbadabbado.default/
I’d also suggest copying one at a time, and then restarting Firefox. This way if Firefox breaks, you know what it is.

I don’t have this file on my system with java-1_6_0-openjdk installed. The java plugin is in /usr/lib64/browserplugins but Firefox doesn’t recognize it.

If I install the sun-java version, it works fine.

Right. You have to use sun-java.

Oops - I tried something else before seeing these instructions - I simply copied all the files in that multiletter.default directory under .mozilla/firefox (but not any subdirectories) into the new .mozilla/firefox/fooskdhjf.default directory with overwriting. It seems both my links and password stuff came back with no errors.

So, I guess, we know the problem wasn’t a file in that subdir…

Update -

Still problems - now YouTube (and other videos) won’t play on Firefox - I just see a blank area on the web page.

I have some problem too after upgrading to firefox 3.6 close to the op problem. It seems fairly working now after installing the mozilla kde4 integration. As soon as I installed the mozilla kd4 integration this morning, it promted me to delete an old kde4 integration with firefox I deleted it but can’t remember the exact name of the package.

Thanks - I am using KDE3, is that what you’re using? (I suspect you’re using KDE4) :’(

Add flash and other plugins to Firefox. You can do this via YaST Software Manager.

As soon as I installed the mozilla kd4 integration this morning, it promted me to delete an old kde4 integration with firefox I deleted it but can’t remember the exact name of the package.

The packages providing /usr/share/kde4/apps/kmozillahelper is called ‘mozilla-xulrunner191-kde4’ for FF3.5.7 and ‘mozilla-kde4-integration’ for FF3.6.

Those packages are useless for someone using KDE3 though.