Firefox very slow to load

I have had this problem right from Leap 42.1 through to now Leap 15.0. Firefox takes a long time about two minutes to load. I had put up the problem in Install, Boot, Login forum but have not found any solution. However, there was a suggestion that FF was searching for some site or url which was causing the delay. So I turned the internet connection off and then tried to load FF. It came on instantly!

I work mainly in KDE but the same problem exists in Gnome too. I use Network Manager not Wicked. I set the application to open to a blank page. On licking the FF icon the indication that it is loading comes on in the panel which disappears about when one expects the application to come on. The application comes on after nearly 2 minutes. If the icon is clicked again after about 10 seconds a message comes on that FF is already running.

The situation is that to start FF, I first have to disconnect the internet via Network Manager, start FF which comes on in a few seconds and the reconnect. It is not very very inconvenient but something is certainly wrong and needs to be pinned down and corrected.


What initial page did you set when starting firefox?
Access firefox preferences> privacy and security> set like this (sorry but it’s in Italian I hope you understand)](

go in to
Yast > System > Network Settings (ignore the warning about network manager) > Hostname / DNS

and check the box that says *Assign Hostname to loopback IP

*OK out of there and reboot (not sure if the reboot is necessary).

Firefox should now load faster.

I set up FF to come up with a blank page.

THAT WORKED. Thanks a lot. Reboot was not required.


you should notice a few other apps like thunderbird and libreoffice also load up a bit quicker now.

I offered you this solution on May 25, 2018. on the Install / Boot / Login forum :

	 				 				 		 			 				 					Try this... 
  1. Open YaST
  2. Go to System > Network Settings
  3. Select the Hostname/DNS tab
  4. Remove the checkmark (if there is one) on “Change Hostname via DHCP”
  5. Add a checkmark on “Assign Hostname to Loopback IP”
  6. Apply/save the changes

Now try launching Firefox. In theory it’ll pop open much faster… maybe :slight_smile:
Edit: You could also try changing the network.dns option (in about:config) for ipv6 from False to True

Yes, LibreOffice also loads much faster.


That is correct. I am really sorry I did not try it out then! However I sort of remember being put off by the message saying YAST does not handle Network Manager. That additional hint to ignore warning regarding Network Manager put me on the way. But thanks a lot for your help.