Firefox unable to connect

Hi. If I start firefox before I activate the connection to internet the browser can’t connect when the connection is active. Even if I open a new window it can’t connect. The only way is to restart firefox.
Could anyone help me to solve this?.

I’m assuming that this is a wifi connection.

The trick is to set the connection to be available to all users. You failed to tell us which desktop you are using, but it is probably KDE, because the network applet in most other desktops does default to sharing the network among users.

If you are doing this in KDE, you also have to tell the network applet to store the network password in an unencrypted file. Otherwise it is not really available to all users.

The effect of sharing the network, is that the WiFi connection is made earlier, before your desktop is started. So the network connection should be up before “firefox” starts.

sorry for the missing info:


System:    Host: localhost Kernel: 5.16.10-1-default x86_64 bits: 64 Desktop: Xfce 4.16.0
           Distro: openSUSE Tumbleweed 20220221
Network:   Device-1: Intel 82579LM Gigabit Network driver: e1000e v: kernel port: f040 bus-ID: 00:19.0
           chip-ID: 8086:1502 class-ID: 0200

if I forget to lift the connection and open firefox after, it is not able to connect until I restart or start under a different profile. I would like to fix this because is very annoying and even a little nonsense.
the thing is the fully working bluetooth is on KDE.

program running. I connect by networkmanager applet to the wired connection. Firefox unable to connect. You know in windows I can open in any order and if breowser running and connection active, the magic happens.

20XX, the year of the linux desktop :kiss:

I think it is a “firefox” limitation. When started, “firefox” makes some network connections back to the mozilla site. And if that fails, it does not initialize properly.

I would not notice it, because I do not have “firefox” start automatically. Maybe some other browser, such as “falkon” or “opera” will work better for you.

I open the firefox and if it can’t connect to remote… looks like a joke.
The process is: I install tumbleweed (is a good distro, you know) with the option to automatically log in. Then I need to solve this keyring problem?:

but I’m in lightdm and the keyring still locked. This kind of things make users get frustrated (reason why I left arch years ago, f.e.).
If the connection is not active and I open opera or brave, the requesting of unlock the keyring appears, but not when I open firefox. OK it’s not superannoying but mozilla should fix this issue.
I saw some info about this but too unclear. I need to know how to solve it for tumbleweed.
Anyway, thanks for your answers.

That’s a consequence of automatic login. The gnome-keyring is protected by your login password. But since you use automatic login, you do not provide your password. Thus it cannot be unlocked until you do.

If you need gnome-keyring to be automatically unlocked, then best to not use automatic login.

I changed one line in the file /etc/pam.d/common-session-pc

session    optional   auto_start  only_if=gdm,xdm,lightdm

eliminating the conditional part:
session    optional   auto_start

and now I don’t need to restart firefox if I didn’t connect to internet previously.

Thank you.

I updated the info here because it stopped working that way. No i put in /etc/pam.d a ligthdm file with this content:

auth          required envfile=/etc/default/locale
auth          required
account     required
password   required
session      required
session      optional
session      optional    auto_start
#session    optional    auto_start only_if=gdm,gdm-password,lxdm,lightdm,mdm,sddm 

automatic login without password ans in the moment I activate the connection firefox can find the pages. no need to restart it.
I update this because i know how important and helpful is when you have any problem and you find in some forum someone who solved it before or gives to you some idea. Hope people will be this helpful to fix the problem with the bluetooth when trying to send files in the wireless subforum.