Firefox start-page hijacking!

With EVERY Firefox update, my start page gets hijacked to open an (in this case openSUSE branded) google sponsored search page instead of my normal start page which I went out of my way to purposely change.

Not a big deal you might say, but when it happens EVERY SINGLE BLOODY TIME, it gets extremely boring, extremely fast. I’m no longer in support, but if I had to change this on over 200 computers spread over 4 floors of a business, every few weeks, I’d be extremely angry.

I’m not singling out OpenSUSE here, *Buntu, Fedora, and I’m guessing all other distros that use a packaging system also conform. I’ve already complained to them.

/rant.

Regards :).

I have used Firefox Settings > Startpage to set all (startpage, new windows, new tabs) to blank page long ago. I can not remember that ever changed after a Firefox update.

The only time I’ve seen that happen is Firefox + MS Windows + Malware :wink:

How, if it’s not deemed a stupid question, did you change it?

As @hcvv wrote “Settings -> Home -> Homepage and new windows” setting a start page (also using “blank”) there and I’ve never had to reset it again after any update.

And it did it again today :(.

I don’t believe it could be malware as this happens on other distros and also on distros I have installed on USB sticks, and on many machines, a few of which are clean installs.

I could be wrong of course - nothing is impossible!

Actually, you could be right, the first time I used Firefox today, all was normal. After a restart it again reset to https://search.opensuse.org/. Very odd.

Maybe I have openSUSE malware!

https://i.postimg.cc/grb324CX/Screenshot-20221028-115143.png](https://postimg.cc/grb324CX)

I have encountered what you have encountered, but it is not hijacking. My Firefox is set to reopen all tabs open when shut down. I have 11 tabs or so always open. After yesterdays update I had two additional tabs added, one about using Mozilla VPN and the other the openSUSE search page. I closed the two additional tabs and things were back to normal.

The package “MozillaFirefox-branding-openSUSE” installs “/usr/lib64/firefox/distribution/distribution.ini” which is used when a new Firefox user profile is created, that will, amongst other things, set "browser.startup.homepage=“https://search.opensuse.org/” it won’t change an existing profile.

Have you set Firefox to restore previous windows and tabs, what is the current setting of:

Settings -> General - Startup - Open previous windows and tabs

From “about:config” what are these set to:

“browser.startup.homepage”
“startup.homepage_override_url”

And, as asked earlier, how are you resetting the browser start page? (GUI, or about:config)

For future reference we generally prefer images to be hosted at https://paste.opensuse.org/

That one’s courtesy of Mozilla - You can prevent future occurrences of it by (about:config) setting “browser.vpn_promo.enabled” to false.

There are also other “Promotional” Settings/URLs that Mozilla use from time to time. You can disable those by searching about:config for settings that have “promo” in them and either setting to false if they are boolean or setting a null string “” if they are an URL.

Thankyou for your interest and help @tannington, it’s much appreciated.

Q1. Have you set Firefox to restore previous windows and tabs, what is the current setting of:
Settings -> General - Startup - Open previous windows and tabs?
A1. Open previous windows and tabs is unchecked.

Q2. From “about:config” what are these set to: “browser.startup.homepage” “startup.homepage_override_url”?
A2. “browser.startup.homepage”=“about:home”, “startup.homepage_override_url” is empty.

Q3. And, as asked earlier, how are you resetting the browser start page? (GUI, or about:config)?
A3. GUI, by selecting “Firefox home default”.

I1. For future reference we generally prefer images to be hosted at https://paste.opensuse.org/
A4. I tried that, but it refuses my login and the interface is so unbelievably confusing I cannot for the life of me figure out how the hell to use it so I gave up out of disgust and also to alleviate stress before I smash my keyboard again in yet another uncontrolled fit of anger and frustration!

What is interesting, is that when I enter “browser.startup.homepage”, I also see the following items listed -

browser.startup.homepage about:home
browser.startup.homepage.abouthome_cache.enabled false
browser.startup.homepage.abouthome_cache.loglevel Warn
browser.startup.homepage_override.buildID 20221019185550
browser.startup.homepage_override.mstone 106.0.1
services.sync.prefs.sync-seen.browser.startup.homepage true
services.sync.prefs.sync.browser.startup.homepage true

Maybe they have something to do with this?

Regards.

Hmm… :\

Very strange, I see nothing at all wrong with the settings you’ve shown.

Any FF extensions installed?

Are you using Mozilla’s sync service?

Initial things to try to resolve (or at least work out what might be happening), but I’m heading into the realms of ‘hope’…

Create a new test user, login as that user and ensure that user’s FF home page is set to “about:home” and that FF is not set to restore windows tabs; confirm the home page works as expected. Logout the test user and don’t use it again until after the next FF update, then login as the test user and see if the homepage has changed there also.

Meanwhile, on you normal user, change “browser.startup.homepage_override.mstone” from “106.0.1” to “ignore”; and again wait for the next FF update to see what happens then.

Scratches head and tries to think of something else…

Re: https://paste.opensuse.org/ - somewhat counter-intuitive, you don’t need to login. The default is to create a text post, just below “login” at top right you can change that to “image”, then just fill in the appropriate fields.

It happened to me regularly till I go t rid of that package, with every FF update it changed my home page. Since I use the FF upstream branding such a thing never happened again.

@knobody42

Based on @swannema’s comment then try removing the openSUSE-branding and replace with upstream.

@swannema

I have the openSUSE-branding package installed and don’t see the issue, but, I have my homepage as “about:blank” rather than “about:home” so perhaps that why I’ve not seen it.

If the issue is indeed with the openSUSE-branding then that probably warrants a bug report…