Firefox start page hijack

Firefox always opens with the opensuse search page and I cannot find a way of stopping it. I would like it to start with the default Firefox page that shows my recently visited/most popular pages. This is called “Firefox home defaults”, which both start page and new tab are set to, but it is being permanently hijacked. Anyone know how to do this? Thanks.

I set the custom URL for the home page and set all the home content to unchecked, a blank page…

Hi Malcolm, and thanks for the fast reply.

I was playing around in about:config and stumbled on the answer!

I set the start URL to: “about:newtab” and it’s now starting with the New Tab page.

Good guess :D.

…I really need to wait longer before asking a question, seems as soon as I post here I find the answer to my own question!!

That’s the best kind of answer. When you find it yourself, you are more likely to remember what you did.

This behavior comes from the MozillaFirefox-branding-opensuse package setting the browser.startup.homepage pref in distribution.ini.

I filed against it because I don’t think the meaning of “Firefox Home (default)” should be hijacked like this, especially when it’s inconsistent (works fine for new tabs but not new windows) and when there’s no obvious opt-out.