Firefox slow to load

Firefox takes about one minute to start. I had same problem in 42.2 and 42.1 as well. I get a message that Firefox seems to be starting/loading slowly but the suggested remedies, removing add-ons etc, do not work! I use Firefox with window also on the same hardware but there it stars/loads quite fast.


Terminal–> firefox --safe-mode

Or try renaming .mozilla in .mozilla-back between hidden files and then restart Firefox so we see

Does not make any difference. Loads in about 80 secs.

Or try renaming .mozilla in .mozilla-back between hidden files and then restart Firefox so we see

I am not able to make out which file needs to be renamed and where it usually is located. A little more info would help please.


Please mention which Firefox version and which Desktop GUI is being used.
[HR][/HR]With Firefox Quantum ESR 60.0, within the “Help” there’s a new item related to information related to the correction of defects, with a button to “clean up” Firefox.
If that doesn’t help then, export your bookmarks (you’ll have to re-import them later … ), note all the changes you’ve made in “about:config”, note all the add-ons and plugins you’ve installed, quit Firefox and ensure that, all the related processes have disappeared. Then:

  • Remove everything in ‘~/.mozilla/’.
  • Remove everything in ‘~/.cache/mozilla/’.
  • Restart Firefox and, restore your bookmarks and, reinstall, if needed, the add-ons and plugins you previously had.

Does not make any difference. loads in about 80 secs.

Or try renaming .mozilla in .mozilla-back between hidden files and then restart Firefox so we see

I am not able to make out which file needs to be renamed and where it usually is located.

I normally use KDE Plasma, but problem exists in Gnome also. The Firefox version is 52.8.0 (64 bit).
I had once earlier followed the steps suggested (same as Firefox suggests) but it made no difference.
Re version Quantum ESR 60.0 - How do I get it?

I assume, since you looked at the Firefox troubleshooting tips that you have set the homepage to a blank page?

Could be a DNS problem, though. Try change DNS servers in your network config.

You have not indicated what firefox version you are using.

There was a recent update to 60.0 ESR, from the earlier 52.x ESR. For me, the 52.x firefox was slow loading. The 60.0 firefox is loading more quickly. That’s with a blank startup page (in both cases).

One thing that can cause repeated slow FF loading is a user.js file in the profile directory with browser.places.importBookmarksHTML set to true.

Is FF the only thing that is slower than it ought to be? When was this 42.3 installation new? Was it an upgrade rather than fresh? Could something in /var/log/ be bloated due to logrotate not being automatically run periodically?

Is there a shortage of freespace on the /home/ filesystem?

Firefox has a nice profile manager. Modify the command in the program starter to read: firefox -P %u You may add a new profile and compare startup times. Startup time with an old profile is 5 seconds. However my machine has 4 physical cores. It starts immediately.

A number of suggestions have come in and I will try these out.

However, first some clarifications from my end.

:)I have since upgraded to 60.0 This loads in about 30 seconds. That is a big improvement! I have yet to try the “clean up” process.

Yes FF is the only thing that is/was very slow to load up. Yes, I start FF with a blank page.
42.3 was a clean installation and is updated regularly.
I do not think DNS is source of problem since FF will look up for DNS only after loading.
I do not have any add-ons at present. I had removed Ad-blocker as suggested by FF help but it made no difference.
I have Intel Core I3 2105 @ 3.10 GHz with 4 GB RAM on Gigabyte H61 M S2P. That is a bit old but cannot be the reason for FF to load so slowly.

Well about 30 secs is much better than 80 secs, but let me try out the various suggestions and revert.

Thanks everyone.

With your Hardware you should start Firefox in 5 - 10 seconds maximum

Actually, it does a lot of connecting before it will pop up. If it cannot get to certain ones, it will never come up, just hang. To see this for yourself, just disconnect your machine from the network and try to start Firefox.

Be prepared to wait a long time, or perhaps to kill the process, because it refuses to come up.

Bad DNS (I had that happen when my preferred DNS Servers turned “bad”) will give the same results.

Testing DNS Servers, then selecting Good ones that were Working, solved the problem.

You can test with DNSBenchmark (runs under Wine):

If you want to do some serious DNS benchmarks I recommend this:

Try this…

  1. Open YaST
  2. Go to System > Network Settings
  3. Select the Hostname/DNS tab
  4. Remove the checkmark (if there is one) on “Change Hostname via DHCP”
  5. Add a checkmark on “Assign Hostname to Loopback IP”
  6. Apply/save the changes

Now try launching Firefox. In theory it’ll pop open much faster… maybe :slight_smile:
Edit: You could also try changing the network.dns option (in about:config) for ipv6 from False to True

It looks like this to me:](

Yes, possibly a DNS issue:
Is ‘nscd’ activated and running?«systemctl status nscd.service»

Allowing the Hostname to be changed via DHCP is, IMHO, a **** GOOD **** thing – visitor responsibility and good manners to networks you visit …

Additionally, assuming that, your ISP uses IPv6 by default (IPv4 tunnel via IPv6 for the IPv4 traffic) and, your DSL Router prefers to use IPv6, you could change a setting in ‘/etc/sysconfig/network/config’:

## Type:        string
## Default:     ""
# Allows to specify options to use when writing the /etc/resolv.conf,
# for example:
#       "debug attempts:1 timeout:10"
# See resolv.conf(5) manual page for details.
NETCONFIG_DNS_RESOLVER_OPTIONS="inet6 edns0 single-request single-request-reopen"

In the Firefox Quantum ESR 60.0.1 browser I’m using to write this, the “disable IPv6” option has by default the value “false”:


Well first let me apologise for an error in my last post. The 60.0 did not load in 30 sec. I must have dozed or let my attention wander. Subsequent tests all hit between 80 to 90 secs.

I have tried most of suggestions except of the DNS and none worked.

Now comes the surprising part. As suggested in above quote I turned off the network/internet connection and started FF. IT CAME ON IMMEDIATELY! Excuse the shout in excitement. I now will try the other DNS of my service provider by changing the order of priority. But the enigma remains, what could cause this problem?

I’d recommend using wireshark to see what the issue is.