Firefox: Server not found

On attempting to access any web page Firefox brings “Server not found”. Other browsers (Chromium, Opera) have no problems. I tried deleting my .cache/mozilla and .mozilla/firefox directories but the problem persists.

How can I find out the cause of the problem?

openSUSE 13.2, xfce

TIA for any suggestions.

Firefox proxy settings?
(It’sin Preferences>Advanced> Connection > Settings)

Thanks for the suggestion, Ray. I tried all possible proxy settings, none of them solves the problem.

As suggested on the Mozilla support page, I also tried disabling DNS Prefetching and IPV6, but to no avail.


Extensions – “safe” mode ?

I tried safe mode but it made no difference. I even set up a test user and called Firefox from there, with a completely new (empty - no extensions, etc.) environment but it also made no difference.

At about the time the problem started, thunderbird stopped accessing my mail server, so it seems to be a problem with the way the Mozilla environment handles DNS access. I suspect that a system-software update changed something which Mozilla didn’t like, but I’ve no idea what it could be.

Oh well, if I don’t find a solution I’ll just have to keep using chromium, but firefox has some nice features which aren’t available in chromium …


Does starting firefox from Konsole telling more?

Have you tried another non-Google browser, e.g. Midori, Qupzilla or Konqueror?

Flushed the resolver cache?

sudo systemctl restart nscd

Checked the resolver?

> ping -c1 ; ping -c1

> cat /etc/resolv.conf ; ls -lh /etc/resolv*

Thanks for the suggestion, but this doesn’t bring any relevant messages.

Opera and the internal browser of liferea don’t have this problem.

Makes no difference.

No problems with ping. /etc/resolv.conf contains the following non-commented lines:

search Speedport_W_724V_Typ_A_05011603_00_002
nameserver fe80::1%enp0s10

The problem only occurs with firefox (version 40) and thunderbird (version 38)