Firefox profile gone

Hi after updating to version 20200716 suddenly firefox is not working any more. when I click on the icon a window opens with the following text: “<toolbarbutton id=“UITourTooltipClose” class=“close-icon”--------------^”. Otherwise everything seems to be working fine. I uninstalled firefox and reinstalled it (version 78.0.2). The result is the same. However I can open firefox from command line and firefox opens with the following response:

QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'
QStandardPaths: XDG_RUNTIME_DIR not set, defaulting to '/tmp/runtime-root'

With the new firefox all my Add-ons are gone and my profile has disappeared. What happened? How can I go bakc to open firefox from the icon and is it possible to get my profile back?

Are you running “firefox” as the root user or as yourself?

That output you showed is suggesting that you were running it as root.

Yes, nrickert you are right - I was root when I typed firefox. I tried typing it as user and I get the same strange window with the text. What is going on?

That you were running as root and didn’t know it suggests you may have corrupted permissions in your user’s /home/ directory. As root you could most likely fix them thus (assuming you have only one ordinary user):

chown -R 1000.100 /home/<username>

First you should peruse your homedir observing whether permissions are correct, no need to fix what isn’t broken.

No, mrmazda, I was root in the console after I removed and re-installed firefox. since firefox at that time didn’t open when I clicked the icon I thought I try now whether I get any response from the command line and typed it there without entering ctrl and d first to log off as root. Strangely enough firefox worked yesterday after I rebooted after zypper dup. Today I had a busy day and wanted to quickly check emails and suddenly firefox didn’t work.


Thanks for the link, Wolffi.