firefox lost everything on upgrade

So I just installed 15.2 on my main system (was 15.1) and after boot, firefox duly notified me that my old profile was useless - I must create a new, empty profile - so passwords, etc., are all gone. I just barely clawed my way back to this forum to ask if anyone has a fix for this? Firefox remembered my “master password” - but all other passwords and usernames are gone. (including for this forum - it was tricky to reset uname and password) I tried about:profiles but it simply replied that old profiles can’t be used.

Has this been solved for firefox? Internet searching wasn’t much help.

Recover user data missing after Firefox update: https://support.mozilla.org/en-US/kb/recover-user-data-missing-after-firefox-updateRecovering important data from an old profile: https://support.mozilla.org/en-US/kb/recovering-important-data-from-an-old-profile#w_your-important-data-and-their-filesYou can start firefox and override the warning if you use an “old profile”:
Firefox

MOZ_ALLOW_DOWNGRADE=1 firefox -P

Firefox ESR

MOZ_ALLOW_DOWNGRADE=1 firefox-esr -P

Thanks, Kieltux - your first suggestion at support.mozilla is what I tried when I mentioned working about-profiles in the input line for firefox (it’s actually a colon separating those two words, but I can’t use them because colon-p comes out as a smiley on this forum). Firefox doesn’t like my old profile so those options don’t work.

I’m not sure what you’re saying to do with the second suggestion - this is a vanilla Leap 15.2 install - so how would i use your second suggestion? (the code for overriding the “warning” - actually a blocking, not a warning - and what’s “ESR”)

I tried…

~> firefox MOZ_ALLOW_DOWNGRADE=1 firefox -P

…and ff did give me a dialog box for choosing other profiles. But it
still threw the blocking dialog box (new profile or quit) when I selected an old profile.
So it’s the same result as the about:profiles approach.

I guess I’ll either have to downgrade ff or else LEAP to get back online.

You may try to manually copy your preferences into the new profile. The profiles should be there:

/home/kasi/.mozilla/firefox/

Most settings should be here

[FONT=Courier new]chromeappsstore.sqlite [/FONT]
[FONT=Courier new]handlers.json[/FONT]

 [FONT=Courier new]xulstore.json
[/FONT]

User setting

 
[FONT=Courier new]prefs.js[/FONT]

 [FONT=Courier new]user.js[/FONT]

 

bookmarks, downlaods, history:



 [FONT=Courier new]places.sqlite[/FONT]

 [FONT=Courier new]favicons.sqlite[/FONT]

 bookmarkbackups    

 

most important, pass words:



 [FONT=Courier new]key4.db[/FONT]

 logins.json

 

others



  [FONT=Courier new]permissions.sqlite [/FONT]

 [FONT=Courier new]content-prefs.sqlite[/FONT]

[FONT=Courier new]search.json.mozlz4 [/FONT]
[FONT=Courier new]formhistory.sqlite[/FONT]

[FONT=Courier new]extensions [/FONT]

Find the relevant files in your old profile anc put copy into the new one. I’d make sure to backup before messing about. :slight_smile:

Thanks for the directory listings - mozilla/ff/tb used to be ez on linux - just copy a directory to backup. Now I see bits of ff all over my ~ filesystem, for instance in .cache

Anyway, this is a very serious problem and I had previously avoided 15.1 -> 15.2 because I let ff take over a lot of passwords. I could recover everything in principle, but it would take a very long time, and many things I’d just not have the energy to pursue. Thankfully, I backed up my homedir, so I can roll back as much as possible.

The cache only relates to history though, so not essential to keep.

You could use firefox sync to manage the passwords and bookmarks in a portable manner (even if you later decide to inhibit it)…
https://support.mozilla.org/en-US/kb/how-do-i-set-sync-my-computer

I haven’t encountered the issue you describe, but I do use firefox sync across multiple devices (Linux and Windows environments).

I think it still basically is. Of course, I wouldn’t bother about .cache. I have just transferred my profile from the laptop to my new desktop. “just copied the directory”. :wink:
Then I put that in first place of the profiles.ini:

[Profile0]
Name=default
IsRelative=1
Path=jmfutgaw.default
Default=1

[General]
StartWithLastProfile=1
Version=2

[Install11457493C5A56847]
Default=jmfutgaw.default
Locked=1

(This is actually the laptop.) Third step in ff: about:_profiles and set that profile as default. Everything is there. OK, I don’t store password in ff, can’t check that.

Forgot something:
The name of the folder in my case

~/.mozilla/firefox/jmfutgaw.default

is the actual name of the profile. “Everything” is in there. I haven’t mentioned that. But you probably know anyway.

No, I didn’t know that, so thank you! I sort of thought maybe cookies were also in ~/.cache/firefox… and I think sometimes cookies have to do with how ff respondes to revisiting a web site - but, of course, I don’t know. I think I had never seen this problem, either, until Leap 15.2 (with its corresponding ff). I saw it on a couple of my intel/leap laptops. (I have about 4 regularly used.) I’ve kept the ~/.mozilla folder from back pre-Leap, I think. So there may be a long-time bug they never quite fixed that breaks things now. I’ve also kept ~/.thunderbird.

Hi Deano: Thanks - but - I’ve been following Krebsonsecurity.com and Schneier.com for, maybe, 10 years (?) - so I never keep anything on the cloud. (That’s a big flaw with Android backuping… ) Back then it was sort of academic. It’s pretty out of control, now, and only getting worse.

But this time it was ff that did me in… :wink: I’m guessing they’re trying to participate in cloud monetization (maybe to support complex dev?) - but also maybe it’s time to switch to Brave, although I don’t think it imports the data contained in a long-time ff user’s records. Dunno. It would be SUPER easy for ff to write that same password/bookmarks/etc. file from ff to an on-disk portable file… but Nnnoooooooooooo! (What’s up ff devs?)

Good to know about .cache, too. I should really move away from ff. I’ve seen online that maybe brave is the best replacement. Ff is going to increasingly suffer from bad/evil “add-ons.” I think also major codebases will be infiltrated, like LEAP and PM repos.

I get that. :wink:

But this time it was ff that did me in… :wink: I’m guessing they’re trying to participate in cloud monetization (maybe to support complex dev?) - but also maybe it’s time to switch to Brave, although I don’t think it imports the data contained in a long-time ff user’s records.

Regarding Brave, I know it can import browsing history, bookmarks, and saved password from FF. I did that with no issue.

It would be SUPER easy for ff to write that same password/bookmarks/etc. file from ff to an on-disk portable file… but Nnnoooooooooooo! (What’s up ff devs?)

A deliberate FF design decision unfortunately. However, “FF Password Exporter” might be of interest to you…
https://support.nordpass.com/hc/en-us/articles/360002451778-How-to-export-passwords-from-Firefox-
https://github.com/kspearrin/ff-password-exporter

I always learn the best things here!

IIRC, Brave isn’t in any of the ‘standard-ish’ YaST repos.

sudo zypper install curl
sudo rpm --import https://brave-browser-rpm-release.s3.brave.com/brave-core.asc
sudo zypper addrepo https://brave-browser-rpm-release.s3.brave.com/x86_64/ brave-browser
sudo zypper install brave-browser

I think I had seen some errors reported by the auto-updater about the Brave browser several days b4 I installed 15.2. I was getting several repo errors, but I had several nonstandard repos (like Brave’s repo).

Try Firefox ESR.

Well, I heard someone mention ESR - but I don’t know what that means. (Well, I mean, I know it means some version or build of ff…)

This is actually a pretty serious problem for me. It doesn’t appear just to be a “tabs and passwords” problem. So far there’s a lot I haven’t been able to access from that approach - my hashers, my router (tomato), facebk says my profile has disappeared…

So I took a laptop that had a dead drive, put in a new HD, installed 15.1 bare-metal. I copied my .mozilla/firefox backup to that machine - but it looks like there are at least 10 different versions of ff in the 15.1 repo. Now that I think about it, I was forbidding autoupdater updates on ff b/c the YaST autoupdater claimed some version conflict.

Here’s my profiles.ini and installs.ini from the old 15.1 ff. Does this mean anything to anyone? There are a couple of profiles listed, but there is syntax present which makes it unclear to a noob like me what’s the primary profile. Also, is there a ff version stored (ff version or repo version?) somewhere in ~/.mozilla/firefox? (or even in ~ somewhere?) It’s probably very important to install the exact version I had installed on my main system b4 upgrading to 15.1.
(the esr68 profile has the latest “modified” timestamp in Dolphin)

[Profile1]
Name=default-esr68
IsRelative=1
Path=eouuteOs.default-esr68-3309458575833

[Profile0]
Name=default
IsRelative=1
Path=3rb5ff0ds.default
Default=1

[General]
StartWithLastProfile=1
Version=2

[Install130033B5B53442]
Default=eouuteOs.default-esr68-3309458575833
Locked=1

------------

[130033B5B53442]
Default=eouuteOs.default-esr68-3309458575833
Locked=1

Sorry, for sure I am not a Firefox expert. I don’t know why your profile names do not all have the same names in “path”. So probably you have a different folder name than just the profile name. It seems your profile with the name “default-esr68” is located in ~/.mozilla/firefox/eouuteOs.default-esr68-3309458575833/.

Here is what I’d do:
(As long as you keep a backup of your original /.mozilla/firefox/ folder it should be safe.)
In 15.1 Firefox “about: profiles” you’ll find all profiles listed. Set one by one as default and restart ff. Check in which one everything is as expected. Then take a note of the correct profile name and folder.

Sorry, my initial explanation may have been too short. Some time ago I have done some research on user profiles and found the German page:

https://support.mozilla.org/de/kb/benutzerprofile-mit-ihren-persoenlichen-daten

There must be the original English version somewhere. :wink:

All the files I have listed in #5 are containing your user settings. I’d now create a new profile in the 15.2 Firefox. You now know how to identify and locate it. Shutdown Firefox. Now copy /all/ these files from your old profile folder on 15.1 into the new one on 15.2. You may have to overwrite some files in the new “empty” profile. Then restart FF in 15.2. I’d say it should all be there. You may double-check on the Mozilla website if I left out anything. For example, I never use cookies. So I might have dismissed that one.
Yes, I did. It’s

cookies.sqlite

Just an update here - I’ve been slowly working through online links to restore passwords. I still can’t access my router or other local hardware. (I have no idea why this should be a problem.) Despite all the difficulties, I suppose I should take comfort to be up-to-date on my distro. But it’s a big shame that ff causes such problems!! (And this isn’t the first time.) That should probably be a concern for future distro design.

So the best alternative? Chrome (I avoid the cloud, SolarWind, and google, so probably not), Seamonkey (unknown), Chromium (unknown), or maybe Brave?

Apparently Brave is about the best, most-secure browser code currently running for standard linux. As our online world falls apart (read: is subverted by hacking) increasingly rapidly, security should be rapidly ascending in importance: and this might be a consideration for the Opensuse gods - although I’m not sure they’ve really regarded how badly things are trending. (see, of course, Krebs’ and Schneier’s always-increasingly-dire reports) There are just so many, diverse things demanding attention.

Best,
PattiM:)

Hi pattyM,

I have got some new findings which might be useful. I’m not sure. It might be too late to help you but I’m still putting it here in case someone runs into the same issue.
As I said, I have transferred my profile from the laptop to the desktop. I have gone further to sync the profiles between both machine (actually the full folder /home/user/mozilla) via my homeserver using unison and nfs. It runs perfectly. I shutdown the laptop yesterday night, now opened ff on the desktop and it’s just the same I have left. So, I am still sure it’s all inside there, only.

Then it happened, I got that box, maybe the same as you, telling me to create a new profile or quit. But it said that my Firefox is too old, not the profile. Using old an old version of ff might corrupt the profile. Maybe you mistook that message?
I checked: ff was updated on the desktop but I haven’t run the update on the laptop, yet. I just updated to the newer version and it was fine.

Now, it’s quite possible that you have seen the same issue after your system upgrade 15.1 - 15.2. Depending on what version from which repository you have been using on 15.1 the same or a newer version may not have been installed with the upgrade. As we have learned from @Sauerland:

You get only the ESR Version in the OSS or Update Repo.

It might be worth a try, in case you still haven’t recovered eveything, yet. You could upgrade to the latest ff version and try running it with your old profile as you did before. Just be careful, you probably can’t use ESR if you need a newer version. If you have installed ESR it in the meantime, you should make sure the new version doesn’t change your current profile - in case it doesn’t work. In that case you might opt for a (first?) snapper rollback to the old ff version.:wink: