FireFox go slow on 11.1

Hello ,

I have just installed 11.1 on a few machines , all upgrades from 11.0 , it may just be something stupid I have done but I find firefox tediously slow on 11.1. There seems to be a delay when opening web pages, like its taking ages to resolve DNS. I have set all DNS manually. When I do a back to back with a 11.0 machine or even a Windowz machine the 11.1 is endless compared. This is not confined to one machine it seems to follow 11.1 around.
Anyone have any Ideas ?


Ohh ,

sorry I have put this in the wrong group.



Could this be that you need to disable IPv6 in the network settings via yast?

Hi Mat,

try to disable ipv6 in Firefox, and see- usually this works and is my first step while configuring web access.

  1. in firefox URL bar, type ‘about:config’
  2. accept warning
  3. in URL bar, type ‘ipv6’
  4. network.dns.disableIPv6 entry appears.
  5. Double click this entry to set the value to true.

Now FF will try the more prevalent ipv4 protocol for name resolution.


I find Firefox 3 slower that Firefox 2. I do not see that the Operating System openSUSE-11.1 Linux has anything to do with it, but rather it is the application itself (unless it is ipv6 as pointed out by caf4926 and a59). Here are some tweaks to firefox 3 you could consider (basically the 3 note below are just the same thing over and over):

Further to the above:
About:Config Tweaks For Firefox 3 | Tips
note this recommendation:

  1. Disable Prefetch (Helpful for frequent Google searcher, low-speed internet connection or low RAM)

    network.prefetch-next = False
    I find the google searcher check is a big slow down.

Hello ,

Thanks for the tips , changing those setting has made a difference, I have even done it to all the machines here now. BUT !!!

Yes the pages load quicker now but the initial DNS request is still slow , I would blame the router set-up or Packet-shaper but other non 11.1 machines are no problem.
I have a new machine to do a clean install on in a day or so , I am wandering if it is a ‘Update’ rather than fresh install issue so the clean install will be a good test.

Of course I could be talking total rubbish! :\

Thanks for all the help, I’ll let you know how my experiment goes.


Note: step three is done in the Filter bar, not the URL bar.

phewwwwww…that gave a kick to my firefox on 11.0
thanks a lot guys…

I was having the same issues with firefox…it seemed hopelessly slow, but disabling ipv6 worked like a charm.


The Fasterfox and FasterFox Lite add-ons are worth a look (the main distinction being the former uses prefetch and the latter disables it).

Odd, I’ve found just the opposite.

FF2 was annoying, and FF3 has been a huge speed up! I have run it on machines 4, 1, 0.5 & 0.25 GiB RAM. I have had to disable IPv6 to get DNS resolution to work, but did it anyway with 10.3 just to keep things simple.

Went through this howto and speeded up FF for me
How To Speed Up Firefox
There’s another one here but bit harder
Speeding up Firefox the right way - Darrell Norton’s Blog [MVP]


Thank you very much. It worked like a charm.