Firefox and Sun java 1.6

I have just uninstalled and reinstalled Sun Java rpms from the repos, the Sun Java works well, but the plug in for Firefox doesn’t even show up in the applications part of preferences in Firefox. I tried testing to see if i had Java installed at and the install missing plugin window shows. Any help would be appreciated.

there is an update for java & plugin for FF,try updating your setup


I was having trouble with some Java applets in Firefox. I searched plugins under add-ons in Firefox for Java, added Java Console 6.0.02 and JavaScript Options 1.2.6… restarted and all works now…

Scratch that… another reboot and it is gone again!

I had the same problem but found out, that I also had a openjdk plugin.

So go to Software management. Search for java and plugin under installed software.

I uninstalled both java plugins and then installed the sun java plugin again.

Here’s a link to a thread I had about installing Java. It also has how to get it to work with firefox

help installing jre-6u12-linux-i586-rpm.bin. - openSUSE Forums

Hope this helps!

There was a problem with Sun’s 64bit Linux version of Java in Firefox, I installed OpenJDK to get around it.
I installed it, rebooted and Java on Firefox worked straight away.