Firefox 52.0.1 https error?


since a few days i get the following error whenever i try to open a webpage in Firefox 52.0.1 that uses https: “Fehler: Gesicherte Verbindung fehlgeschlagen” (“error: sucure connetcion failure” or so) and further down on the page “An error occurred during a connection to security library: memory allocation failure. Error code: SEC_ERROR_NO_MEMORY”

I am not quite sure but i guess this error occurred first when i had firefox updated from 51.x. Getting back to this version however did not solve the problem. I deinstalled all extensions in firefox but that did not help either.

I am not sure if this really has to do only with firefox. Chromium as well prevents connection to some https resources but not to as many as firefox.

When thte problem first showed up I had played arround with gpg and KGpg, so that might have caused the problem. So now I deactivated all keys I had on my system and the problem still persists.

I know, firefox as of version 52 handels invalid https certificates in a stricter way, but it cant be that strict. There must be some other issus. Most of the webpages using https ar unusable for me. And a firefox 52.0.1 running on an other computer i have works okay.

Does anybody have an idea what might cause this strange behavior.


Based on a quick Google search, this problem was resolved a long time ago,
So, I’d guess that maybe you haven’t updated your openssl libraries.

Recommend you update your system by running the following in a root (or otherwise elevated permissions) console

zypper update


Hey TSU,

my System seems to be up to date. zypper -lu says so. I run updates almost daily.

According to my google search there were similar errors solved. the “insecure connection…” stuff associated with an SEC_ERROR_NO_MEMORY seems to be unsolved - and somehow bizar.