Finding root password

I did a clean install of OS 11.4. I do not recall being asked to specify a root password during installation. Did the install ask me to setup a root password ?

Now when I try to use Yast it asks me for the root password. I tried a root password I had used with an install of a previous release of OS, just in case that was the root password I entered if/when OS 1.4 install asked me for one, but it is not valid. Is there any way to find out the root password, or set the root password, when logged in normally under my own password so I can use Yast ?

By default unless you tell it otherwise the installer uses your password for the toot password. You can change the password in Yast to something a bit safer the the first users password.

Have you tried your user password?
Else, to set a different root password;

sudo -i

Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 3.0.31-0.9-default
up 1 day 0:25, 2 users, load average: 1.25, 1.03, 0.98
GPU GeForce 8600 GTS Silent - Driver Version: 302.11

On 06/21/2012 04:26 AM, eldiener wrote:
> Did the install ask me to setup a root password ?

yes and no: that is you were offered the option to setup a root
password, but didn’t accept that option…

see the image just above paragraph 8 in this quick start guide

there you will see that during your interaction with that install step
you left the check mark in the box next to “Use this password for system
administrator” (and, therefore both you and root have the same password)

reading paragraph 8, i see that had you removed that check mark you
would have then seen the image below paragraph 8, and could have had a
different password for you and root by following the info in paragraph 9…

[now you (and, all those who google in) know for next install…]