FileZilla failed to issue SSH connect after the latest update of Tumbleweed

Hello everyone,

I am using Tumbleweed with the latest snapshot 20160503. After this update yesterday morning, I cannot use FileZilla on my system.

The problem is FileZilla starts up normally at first but crashed after I tried to connect to my VPS using SFTP protocol. And it refuses to start up again after this crash.

But if I delete the configuration folder from ~/.config/filezilla, It starts. And the same nightmare comes again.

I cannot figure out more on this. Could anyone give me some clues?


Best regards,

Hi everyone,

For the above problem, I found following log from YaST2 -> Journal entries. There are 3 lines every time FileZilla quits unexpectedly.

May 04 18:12:06  filezilla[2619]                  ANOM_ABEND auid=1000 uid=1000 gid=100 ses=2 pid=2619 comm="filezilla" exe="/usr/bin/filezilla" sig=7

May 04 18:12:06  kernel                             traps: filezilla[2619] trap stack segment ip:7f43473eedd2 sp:7ffe7600bbe0 error:0 in[7f4346f35000+583000]

May 04 18:12:06  systemd-coredum[2632]  Process 2619 (filezilla) of user 1000 dumped core.

I wish this could be helpful.

Thanks in advance.

Maybe similar to this thread and bug;

Many thanks for your help.

My knowledge cannot tell whether this is the problem or not. And I do not know how to use the debug tools. I can use SSH to connect to my VPS. The problem only happens when I use FileZilla to connect using SFTP.

I tried the suggested solution of fallbacking OpenSSH to 6.6p1-11.1 (hopefully I got this right), but it seems no effect.

Best regards,

Hello everyone,

This problem still exists.

But I found a workaround to get a usable FileZilla in the system. Details are as follows.

I tried to downgrade the package of FileZilla from repositories, but it was not easy. So I download the install package of FileZilla v3.14.1 for Linux from sourceforge, uncompress the tar ball, and use the 3 files in the bin subdirectory to replace the ones in the /usr/bin directory. Now the FileZilla in my system works in a lower version state.

And I found that v3.16.1 and v3.16.0 were also not working in my current openSUSE Tumbleweed installation (snapshot 20160505).

Thanks for your concerns.