files destroyed after copying from NTFS to EXT3 ??

hi folks
i am a newbie and i have a really '~##+ problem
i just installed opensuse 11.1 on some old hardware (FJS E600) to use it as an home server
bevor this, i evaluated the MS home server which was not that what i needed.
so i make a clean installation on an free HD.
after that, i put the old HD with the inst of win home server and my files (NTFS) into the suse box and copied all the files (~170 GB mp3,videos and photos to the “linux hd”.
after all the files were moved, i deleted the NTFS partitions and reformated it to ext3, to move all the files back to the “old” hd and share it via samba.
while the files are moving from one disk to the other i tested the shares and i recognized that all files are damaged. i could not open any file on my win pc over the network.
so i tried it directly on the linux box as root with the same result. i checked all the permissions over and over again but nothing
i cant open any file which were copied from the ntfs disk to the ext3.
allthough everything looks ok. filesize is ok, i can copy the files to win systems (but still cant open it)everything looks normal.
now i have 170 GB of data junk on my disk and no backup anywhere
i hope someone can help me please ?

i just opened some files with a hex editor
only 0 , zeros
all files are empty>:(

I never had this myself, but it sounds like it might be a fragmentation issue originating on the ntfs side. Doesn’t sound good though

Testdisk can be used to recover lost partitions.

I’d be surprised if you can recover data once you’ve put another partition on top of it…

But it might be worth a shot.