file associations in firefox dont work

Hi …when using firefox to open a file attachment in web mail the update configuration runs but next time the same box appears to select which program to use , in firefox preferences / applications there is no way to add a new file association for a new filetype eg .doc or .xls …!
I tried switching off suse integration with firefox but it made no difference .if anyone has a fix for for this i can save myself a lot of time …thanks

Firefox version 3.5.9
open suse 11.2
AMD Athlon™ II X2 240 Processor
Speed: 2,800.00 MHz1.8 GiB
Free memory: 788.6 MiB (+ 605.2 MiB Caches)
Free swap: 2.0 GiB

File associations can be set in Configure Desktop > Advanced > File Associations in KDE. I assume Gnome has something similar. Don’t think there are file associations per se in firefox.

It may help if you would post, if you use GNOME (2.8.2?) or KDE (4.3.5?)

Have you tried the search for your filetype/extension there?
In GNOME I have (by default) there a association with open office but I have chosen “ask always”.