Faulty HDD: link online but device misclassified

Hi, I have a faulty HDD (there were a lot of bad blocks found), I have a replacement but unfortunately there is a small portion of data that I don’t have a backup of. I would like to see if that specific part would still be readable from the disk but I can’t mount it anymore. It doesn’t even show up in fdisk -l. When I hot plug the disk in I can see this in dmesg:

 3081.973991] ata8: SATA link up 6.0 Gbps (SStatus 133 SControl 300) 3087.145990] ata8.00: qc timeout (cmd 0xec)
 3087.146002] ata8.00: failed to IDENTIFY (I/O error, err_mask=0x4)
 3097.146390] ata8: softreset failed (1st FIS failed)
 3107.146817] ata8: softreset failed (1st FIS failed)
 3142.146860] ata8: softreset failed (1st FIS failed)
 3142.146869] ata8: limiting SATA link speed to 3.0 Gbps
 3147.325937] ata8: SATA link up 3.0 Gbps (SStatus 123 SControl 320)
 3147.325943] ata8.00: link online but device misclassified
 3147.325944] ata8: link online but 1 devices misclassified, device detection might fail

Is there any chance I still can get the data from the disk? Please advise.

I don’t think it matters in this case but I’m using Tumbleweed.

Sure it’s not the SATA controller, cable or power issue, is there another SATA port on the board to try? Do you have a HDD to USB enclosure you could use for the drive?

Yes, I’m pretty sure. I don’t have USB frame but I tried a different SATA port and cable.

Can you disable unused SATA ports in the system BIOS? What controller is it (lspci output should how).

Can disabling the unused ports help? I currently can’t reboot but may try later. BTW the disk worked normally in this PC until it started behaving weird like a week ago (e.g. suddenly remounted as read-only). Then I ran badblocks which showed quite a lot of them and I ordered replacement disk. Yesterday I was still able to mount it but not today.

# lspci | grep SATA
03:00.1 SATA controller: Advanced Micro Devices, Inc. [AMD] 400 Series Chipset SATA Controller (rev 01)
30:00.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 51)
31:00.0 SATA controller: Advanced Micro Devices, Inc. [AMD] FCH SATA Controller [AHCI mode] (rev 51)

Yes it may help, or can you test them with another drive?

Not sure what you mean now. What is the goal here? To test that all SATA ports work with another drive?

Yes, could be the controller…

Try using ddrescue to clone the old HDD to the new. If it can’t make the un-backed up data readable on the new HDD, then the old is probably too toasted for any but a very expensive recovery service to recover.

For that I would have to be able to see the drive though, right? It’s not detected and doesn’t have its /dev/sdX.

Thank you. I tried all the ports and all work with a different disk.

A stuck head can sometimes be unstuck rapping the disk against something, or tapping disk lightly with something, rotating it in the platter plane while giving it the shock. Another possibility is a chill, putting it in a sealed plastic bag in the freezer until good and cold, then trying again. A separate power supply that can be turned on and off at will might assist with the shocking process, keeping it spinning once started.

I guess I can try that as the last resort if nothing else helps.