Failed to use external monitor with nouveau driver


I’m trying to use my Dell Inspiron 17R SE 7720 Laptop with an external monitor.
This works fine with openSUSE 12.3 and the nouveau driver.
With openSUSE Leap42.1 the second monitor is no longer found. The same applies to openSUSE 13.2.

The graphics adapter is GeForce GT 650M. It’s not the optimus technology!

I tried using the NVIDIA driver:
This does not work in any constellation (also not with 12.3). I tried every driver release in the last year. Both the one supplied by opensue using yast to install and also from NVIDIA and manuall install.
After installation it boots into a fast flashing screen, like a stroboscope.

So I stick with the nouveau driver which works with 12.3.
When booting opensuse 12.3 (Kernel 3.7.10.-1.45-default), I see this:

lspci -nnk | grep -i vga -A2

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK107 [GeForce GT 650M] [10de:0fd1] (rev a1)
Subsystem: Dell Device [1028:0566]
Kernel driver in use: nouveau

the external monitor is recognized on VGA-0.

Wenn booting opensuse leap42 (Kernel 4.1.15-8-default), I see this:

A) black screen

B) with “nomodeset” set on the grub2 commandline:

lspci -nnk | grep VGA -A2

01:00.0 VGA compatible controller [0300]: NVIDIA Corporation GK107M [GeForce GT 650M] [10de:0fd1] (rev a1)
Subsystem: Dell Device [1028:0566]
Kernel modules: nouveau

Everything works with nomodeset except no external monitor is recognized. The laptop screen works.

Any idea what I can try?

I have 2 harddisks, one has opensuse12.3 on it, the other leap42. So I can experiment with the leap42.