Failed to rotate log files

Hi guys.

Using LEAP 15.0 i am getting this message at boot saying

[FAILED] Failed to start Rotate log files.

 See 'systemctl status logrotate.service' for details.

and if i open

systemctl status logrotate.service

i get this

logrotate.service - Rotate log files
   Loaded: loaded (/usr/lib/systemd/system/logrotate.service; static; vendor preset: disabled)
   Active: inactive (dead)
     Docs: man:logrotate(8)

And also getting Failed unmounting /var at shutdown.

I sometimes see that. I have not tried to investigate. It doesn’t happen on every boot. So I don’t worry about it, on the assumption that it won’t hurt too much if log rotation is delayed.

And also getting Failed unmounting /var at shutdown.

That could be more serious. Or maybe not. Hard to tell.

I don’t have a separate “/var” so I am not seeing that issue.

If I did see that happen, I would boot from rescue media, and run “fsck” on that file system. If it shows the file system as clean, then it was probably unmounted later during the shutdown. There’s a final “unmount all file systems” check near the end of shutdown which usually catches ones that failed earler in the shutdown.

I ran an fsck on my btrfs partition and it said to run btrfs check. So i did that and it said that no errors were found so i guess everything is fine.

Thanks for the reply.