Failed to open \EFI\BOOT\MokManager.efi - Not Found

Hi Communities

I have a problem to boot from the usb live x86_64 KDE opensuse-Leap 15.3 download from “”.

Because I would like to first check that can Leap 15.3 run on my laptop with NVIDA graphic card,
I booted from this live version and installed the official NVIDIA driver using the “easy way” mentioned here “”.

After the first reboot, the NVIDIA driver was not load. I though there probably be the issue caused related to the secureboot.
So I ran

# mokutil --import /var/lib/nvidia-pubkeys/MOK-nvidia-gfxG0<X>-<driver_version>-<kernel_flavor>.der --root-pw

and reboot.

And then it came something broken with the boot loader!!

Failed to open \EFI\BOOT\MokManager.efi - Not Found 
Failed to load image \EFI\BOOT\MokManager.efi: Not Found 
Failed to start MokManager: Not Found 
Something has gone seriously wrong: import_mok_state() failed : Not found

Because it was just boot from live-usb.
So I cleaned up and rebuilt the live usb for Leap15.3.
After reboot, it still persists the same boot error.

I have checked this thread “update killed bootloader”, and learned that a workaround is to copy MokManager.efi to \EFI\Boot.
But I can not find where the MokManager.efi it is…

Any suggestions/ideals ?

By the way, win 10 is the only operation system on this laptop and is running well with no problem.

Thank you for reading this~~

I’m not clear on what the issue is. However, on an installed Leap 15.3 system, you can usually find “MokManager.efi” at “/usr/share/efi/x86_64/MokManager.efi”, assuming that the “shim” package is installed.

Thank you for the information.
With copying MokManager.efi to \EFI\Boot, the boot problem has been solved.