fail install Radeon lastest driver on Dell Latitude E6540

Hi guys,

I’ve just tried to install AMD Radeon lastest driver, amd-catalyst-13.11-beta6, on my new laptop Dell Latitude E6540 which has graphic card is AMD Radeon HD 8790M, but it failed.
I installed all required libs and kernels also. Then run the script of AMD Radeon lastest driver which I downloaded from: http://www2.ati.com/drivers/beta/amd-catalyst-13.11-beta6-linux-x86.x86_64.zip (the lastest stable version is 13.4 does not support Radeon HD 8xxx series)

After running the script successfully, I ran “aticonfig --initial”. But then I restart X server, it stuck at step of “[OK] Reached target Graphical Interface.” I restart computer and it still stuck at that step.

So please if someone installed driver for AMD Radeon HD 8xxx series, give me some advices.
Thanks for all your helps!

PS: I need to install the driver to enable OpenGL and can use Desktop Effects, right?
And I’m using OpenSuSE 12.3, KDE 4.10

On Wed 30 Oct 2013 05:06:03 PM CDT, n00bvn wrote:

Hi guys,

I’ve just tried to install AMD Radeon lastest driver,
amd-catalyst-13.11-beta6, on my new laptop Dell Latitude E6540 which has
graphic card is AMD Radeon HD 8790M, but it failed.
I installed all required libs and kernels also. Then run the script of
AMD Radeon lastest driver which I downloaded from:
http://tinyurl.com/myz28sl (the lastest stable version is 13.4 does not
myz28sl ->
http://www2.ati.com/drivers/beta/amd-catalyst-13.11-beta6-linux-x86.x86_64.zip
support Radeon HD 8xxx series)

After running the script successfully, I ran “aticonfig --initial”. But
then I restart X server, it stuck at step of “[OK] Reached target
Graphical Interface.” I restart computer and it still stuck at that
step.

So please if someone installed driver for AMD Radeon HD 8xxx series,
give me some advices.
Thanks for all your helps!

PS: I need to install the driver to enable OpenGL and can use Desktop
Effects, right?
And I’m using OpenSuSE 12.3, KDE 4.10

Hi
Follow the instructions here, for building as an rpm (it installs
automagically), just grab the later makerpm scripts (13.11v1 is
there);

http://en.opensuse.org/SDB:AMD_fglrx
http://www.sebastian-siebert.de/downloads/


Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLED 11 SP3 (x86_64) GNOME 2.28.0 Kernel 3.0.93-0.8-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

I followed the instruction for building rpm, then install the generated rpm. But when I restart computer, it still stuck at “Reached target Graphical Interface.” step.

Do I have to config anything after installing the driver? What packages I have to install before installing the driver?

And now how can I boot and log in back to OpenSUSE to uninstall the driver and try another solution.

Thanks!
Regards,
n00bvn

On Thu 31 Oct 2013 08:16:02 AM CDT, n00bvn wrote:

malcolmlewis;2594523 Wrote:
> Hi
> Follow the instructions here, for building as an rpm (it installs
> automagically), just grab the later makerpm scripts (13.11v1 is
> there);
>
> ‘SDB:AMD fglrx - openSUSE’ (http://en.opensuse.org/SDB:AMD_fglrx)
> ‘Index of /downloads’ (http://www.sebastian-siebert.de/downloads/)
>
> –
> Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
> SLED 11 SP3 (x86_64) GNOME 2.28.0 Kernel 3.0.93-0.8-default
> If you find this post helpful and are logged into the web interface,
> please show your appreciation and click on the star below… Thanks!

I followed the instruction for building rpm, then install the generated
rpm. But when I restart computer, it still stuck at “Reached target
Graphical Interface.” step.

Do I have to config anything after installing the driver? What packages
I have to install before installing the driver?

And now how can I boot and log in back to OpenSUSE to uninstall the
driver and try another solution.

Thanks!
Regards,
n00bvn

Hi
No the script does everything for you, to uninstall use the -u option
as indicated in the SDB article.


../makerpm-... -u

Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
SLED 11 SP3 (x86_64) GNOME 2.28.0 Kernel 3.0.93-0.8-default
If you find this post helpful and are logged into the web interface,
please show your appreciation and click on the star below… Thanks!

Hi,

I tried to boot OpenSUSE with nomodeset, logged in as root then I tried “aticonfig --initial” and then “startx”, I got error message like below:

88.841] 

X.Org X Server 1.13.2
Release Date: 2013-01-24
88.841] X Protocol Version 11, Revision 0
88.841] Build Operating System: openSUSE SUSE LINUX
88.841] Current Operating System: Linux linux-gzq5.site 3.7.10-1.16-default #1 SMP Fri May 31 20:21:23 UTC 2013 (97c14ba) x86_64
88.841] Kernel command line: BOOT_IMAGE=/boot/vmlinuz-3.7.10-1.16-default root=UUID=875379d7-3e3c-475f-89ea-fb7694c6d695 resume=/dev/disk/by-id/ata-ST500LM000-1EJ162_W370EW4D-part8 splash=silent quiet showopts 3
88.841] Build Date: 21 February 2013 10:01:18AM
88.841]
88.841] Current version of pixman: 0.28.2
88.841] Before reporting problems, check xorg
to make sure that you have the latest version.
88.841] Markers: (–) probed, () from config file, (==) default setting,
(++) from command line, (!!) notice, (II) informational,
(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
88.841] (==) Log file: “/var/log/Xorg.0.log”, Time: Thu Oct 31 22:34:34 2013
88.848] (==) Using config file: “/etc/X11/xorg.conf”
88.848] (==) Using config directory: “/etc/X11/xorg.conf.d”
88.848] (==) Using system config directory “/usr/share/X11/xorg.conf.d”
88.852] (==) ServerLayout “aticonfig Layout”
88.852] (
) |–>Screen “aticonfig-Screen[0]-0” (0)
88.852] () | |–>Monitor “aticonfig-Monitor[0]-0”
88.852] (
) | |–>Device “aticonfig-Device[0]-0”
88.852] (==) Automatically adding devices
88.852] (==) Automatically enabling devices
88.852] (==) Automatically adding GPU devices
88.867] (WW) The directory “/usr/share/fonts/Type1/” does not exist.
88.867] Entry deleted from font path.
88.867] (WW) The directory “/usr/share/fonts/100dpi” does not exist.
88.867] Entry deleted from font path.
88.868] (WW) The directory “/usr/share/fonts/cyrillic” does not exist.
88.868] Entry deleted from font path.
88.868] (WW) The directory “/usr/share/fonts/misc/sgi” does not exist.
88.868] Entry deleted from font path.
88.868] (==) FontPath set to:
/usr/share/fonts/misc:unscaled,
/usr/share/fonts/75dpi:unscaled,
/usr/share/fonts/ghostscript/,
/usr/share/fonts/truetype/,
built-ins
88.868] (==) ModulePath set to “/usr/lib64/xorg/modules/updates,/usr/lib64/xorg/modules”
88.868] (II) The server relies on udev to provide the list of input devices.
If no devices become available, reconfigure udev or disable AutoAddDevices.
88.868] (II) Loader magic: 0x801c20
88.868] (II) Module ABI versions:
88.868] X.Org ANSI C Emulation: 0.4
88.868] X.Org Video Driver: 13.1
88.868] X.Org XInput driver : 18.0
88.868] X.Org Server Extension : 7.0
88.869] (–) PCI:*(0:0:2:0) 8086:0416:1028:05be rev 6, Mem @ 0xf5800000/4194304, 0xd0000000/268435456, I/O @ 0x0000f000/64
88.869] (–) PCI: (0:1:0:0) 1002:6606:1028:05be rev 0, Mem @ 0xe0000000/268435456, 0xf7c00000/262144, I/O @ 0x0000e000/256, BIOS @ 0x???/131072
88.869] (WW) Open ACPI failed (/var/run/acpid.socket) (No such file or directory)
88.869] Initializing built-in extension Generic Event Extension
88.869] Initializing built-in extension SHAPE
88.869] Initializing built-in extension MIT-SHM
88.869] Initializing built-in extension XInputExtension
88.869] Initializing built-in extension XTEST
88.869] Initializing built-in extension BIG-REQUESTS
88.869] Initializing built-in extension SYNC
88.869] Initializing built-in extension XKEYBOARD
88.869] Initializing built-in extension XC-MISC
88.869] Initializing built-in extension SECURITY
88.869] Initializing built-in extension XINERAMA
88.869] Initializing built-in extension XFIXES
88.869] Initializing built-in extension RENDER
88.869] Initializing built-in extension RANDR
88.869] Initializing built-in extension COMPOSITE
88.869] Initializing built-in extension DAMAGE
88.869] Initializing built-in extension MIT-SCREEN-SAVER
88.869] Initializing built-in extension DOUBLE-BUFFER
88.869] Initializing built-in extension RECORD
88.869] Initializing built-in extension DPMS
88.869] Initializing built-in extension X-Resource
88.869] Initializing built-in extension XVideo
88.869] Initializing built-in extension XVideo-MotionCompensation
88.869] Initializing built-in extension XFree86-VidModeExtension
88.869] Initializing built-in extension XFree86-DGA
88.869] Initializing built-in extension XFree86-DRI
88.869] Initializing built-in extension DRI2
88.869] (II) “glx” will be loaded by default.
88.869] (II) LoadModule: “glx”
88.871] (II) Loading /usr/lib64/xorg/modules/updates/extensions/libglx.so
88.874] (II) Module glx: vendor=“Advanced Micro Devices, Inc.”
88.874] compiled for 6.9.0, module version = 1.0.0
88.874] Loading extension GLX
88.874] (II) LoadModule: “fglrx”
88.883] (II) Loading /usr/lib64/xorg/modules/drivers/fglrx_drv.so
88.928] (II) Module fglrx: vendor=“FireGL - AMD Technologies Inc.”
88.928] compiled for 1.4.99.906, module version = 13.20.6
88.928] Module class: X.Org Video Driver
88.928] (II) Loading sub module “fglrxdrm”
88.928] (II) LoadModule: “fglrxdrm”
88.928] (II) Loading /usr/lib64/xorg/modules/linux/libfglrxdrm.so
88.930] (II) Module fglrxdrm: vendor=“FireGL - AMD Technologies Inc.”
88.930] compiled for 1.4.99.906, module version = 13.20.6
88.930] (II) AMD Proprietary Linux Driver Version Identifier:13.20.6
88.930] (II) AMD Proprietary Linux Driver Release Identifier: UNSUPPORTED-13.20.16
88.930] (II) AMD Proprietary Linux Driver Build Date: Sep 26 2013 16:09:41
88.930] (–) using VT number 2

89.346] (WW) Falling back to old probe method for fglrx
89.356] (II) Loading PCS database from /etc/ati/amdpcsdb /etc/ati/amdpcsdb.default
89.357] ukiDynamicMajor: found major device number 250
89.357] ukiDynamicMajor: found major device number 250
89.357] ukiOpenByBusid: Searching for BusID PCI:1:0:0
89.357] ukiOpenDevice: node name is /dev/ati/card0
89.357] ukiOpenDevice: open result is 9, (OK)
91.329] ukiOpenByBusid: ukiOpenMinor returns 9
91.330] ukiOpenByBusid: ukiGetBusid reports PCI:1:0:0
91.367] (--) Chipset Supported AMD Graphics Processor (0x6606) found
91.367] (II) fglrx: intel VGA device detected, load intel driver.
91.367] (II) LoadModule: "intel"
91.368] (II) Loading /usr/lib64/xorg/modules/drivers/intel_drv.so
91.464] (II) Module intel: vendor="X.Org Foundation"
91.464]     compiled for 1.13.1, module version = 2.20.19
91.464]     Module class: X.Org Video Driver
91.464]     ABI class: X.Org Video Driver, version 13.1
91.464] (II) fglrx(0): pEnt->device->identifier=0x1fc2e90
91.466] 

Fatal server error:
91.466] atiddxProbe: fail to probe intel VGA device
91.466] (EE)
Please consult the The X.Org Foundation support
at xorg
for help.
91.466] (EE) Please also check the log file at “/var/log/Xorg.0.log” for additional information.
91.466] (EE)

Then I removed ATI by “./make-rpm… -u”, then I restart and can log in to OS normally.

After re-login to OS normally, I checked KInfocenter -> OpenGL, it said:

3D Accelerator: unknown
Driver:
Vendor: VMware

By the way, this is result of lspci:

lspci -nnk | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell Integrated Graphics Controller [8086:0416] (rev 06)
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Mars [Radeon HD 8790M] [1002:6606]

It seem that X still use onboard graphic card which is Intel VGA, right?
And why driver for OpenGL is VMware?

Please help me.
Thanks!

Hi,

After running makerpm-amd-13.11-betav1.sh, I got below error message:


  •                                                                          *
    
  • Kernel: 3.7.10-1.1-desktop *
  • Source: /lib/modules/3.7.10-1.1-desktop/build *
  • Include: /lib/modules/3.7.10-1.1-desktop/source/include *
  •                                                                          *
    

Warning:
kernel includes at /lib/modules/3.7.10-1.1-desktop/source/include not found or incomplete
file: /lib/modules/3.7.10-1.1-desktop/source/include/asm-x86_64/compat.h

/usr/src/kernel-modules/fglrx/2.6.x /
rm -rf *.c *.h *.o *.ko .a .?? *.symvers
make: *** /lib/modules/3.7.10-1.1-desktop/build: No such file or directory. Stop.


Build of kernel module failed!


rm -rf *.c *.h *.o *.ko .a .?? *.symvers
/
Calling ‘depmod -a 3.7.10-1.1-desktop’ this may take a while…

Summary report:

Kernel => 3.7.10-1.1-desktop
Detected => RPM package
Build => FAILURE ]
Install => FAILURE ]


Building/installation of fglrx kernel module failed! Try again
by calling “/usr/bin/fglrx-kernel-build.sh” manually.



Please read “/usr/share/doc/packages/fglrx/README.SuSE” for
configuration details when using SaX2.


Disable KMS to prevent driver issue:

Kernel image: /boot/vmlinuz-3.7.10-1.1-desktop
Initrd image: /boot/initrd-3.7.10-1.1-desktop
Root device: /dev/disk/by-id/ata-ST500LM000-1EJ162_W370EW4D-part6 (/dev/sda6) (mounted on / as ext4)
Resume device: /dev/disk/by-id/ata-ST500LM000-1EJ162_W370EW4D-part8 (/dev/sda8)
Kernel Modules: thermal_sys thermal processor fan scsi_dh scsi_dh_emc scsi_dh_hp_sw scsi_dh_alua scsi_dh_rdac xhci-hcd hid-logitech-dj
Features: acpi plymouth block usb resume.userspace resume.kernel
Check: No fglrx section.
Uninitialised file found, configuring.
PowerXpress info: Diagnostic output from /usr/lib64/fglrx/switchlibglx:
Switch to AMD

Switch to AMD

committingCommitResult (total 13, done 13, error 0, skipped 0, updateMessages 0)
OK ]
Check for activated fglrx rebuild init script …
Note: This output shows SysV services only and does not include native
systemd services. SysV configuration data might be overridden by native
systemd configuration.

                                                                                OK ]

Finish! Please restart your computer and have a lot of fun! :wink:

Please help me how to fix this.
Thanks a lot!

Install kernel-desktop-devel-3.7.10-1.1.

installed, status is OK now

Kernel => 3.7.10-1.1-desktop
Detected => RPM package
Build => OK ]
Install => OK ]

but still not work. OS still stuck at “Reached target Graphical Interface” step :frowning:

Are you booting kernel 3.7.10-1.1?

Can you post the file /var/log/Xorg.0.log? (upload to SUSE Paste and post a link)

Does “recovery mode” work? (in “Advanced Options” at the boot menu)
If yes, boot that and post /var/log/Xorg.0.log.old if you don’t know how to get at the file in text mode.

Maybe the beta driver just doesn’t work for you?

The log file is here: SUSE Paste

Thanks for helps!

This is the error:

Fatal server error:
    10.115] atiddxProbe: fail to probe intel VGA device

So you have a hybrid system? Sorry I have no experience with that.

Googling for the error message does bring up a lot of hits though.

You could try to switch off the intel graphics in your BIOS settings, but not all systems allow this.

Maybe the intel kernel module is not loaded for some reason?
Could you show the output of “lspci -nnk”, please?

Yes, exactly, my laptop has hybrid system. Below is output of lspci:

lspci -nnk | grep VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell Integrated Graphics Controller [8086:0416] (rev 06)
01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Mars [Radeon HD 8790M] [1002:6606]

Unfortunately, there’s no BIOS setting for switch off intel graphics. In Windows, there’s option for switchable graphics.

Thanks!
Regards.

Please post the full output. With your grep you filter out the additional output of the “-nnk” option.
Or use “grep -A2 VGA”. :wink:

below is output of lspci:

lspci -nnk | grep -A2 VGA
00:02.0 VGA compatible controller [0300]: Intel Corporation Haswell Integrated Graphics Controller [8086:0416] (rev 06)
Subsystem: Dell Device [1028:05be]
00:03.0 Audio device [0403]: Intel Corporation Haswell HD Audio Controller [8086:0c0c] (rev 06)

01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI Mars [Radeon HD 8790M] [1002:6606]
Subsystem: Dell Device [1028:05be]
03:00.0 Network controller [0280]: Intel Corporation Centrino Advanced-N 6235 [8086:088e] (rev 24)

Thanks for your helps!

So apparently there’s no kernel driver loaded for the intel card, that’s why the intel gfx driver cannot be loaded.

AFAIK your intel chip should be supported by the i915 module.
Could you try to load it manually? And post a possible error message?

sudo /sbin/modprobe i915
dmesg|tail

Maybe it would help to upgrade the kernel. The latest stable one is available in this repo:
Index of /repositories/Kernel:/stable/standard
You would have to re-install the fglrx driver afterwards in that case, of course.

I don’t think there’s no kernel driver loaded for the intel card, because without AMD driver, OS loaded normally with intel card.
By the way, below is i915 module, there’s no message:

linux-mkrd:~ # /sbin/modprobe i915
linux-mkrd:~ # dmesg|tail
25.316227] ll header: 00000000: ff ff ff ff ff ff d4 3d 7e 4c 4b 66 08 00 …=~LKf…
26.075258] EXT4-fs (sda6): re-mounted. Opts: acl,user_xattr,commit=0
26.106554] EXT4-fs (sda7): re-mounted. Opts: commit=0
27.316424] IPv4: martian source 255.255.255.255 from 192.168.100.6, on dev eth0
27.316429] ll header: 00000000: ff ff ff ff ff ff d4 3d 7e 4c 4b 66 08 00 …=~LKf…
27.873930] IPv4: martian source 255.255.255.255 from 192.168.100.7, on dev eth0
27.873934] ll header: 00000000: ff ff ff ff ff ff d4 3d 7e 54 e5 12 08 00 …=~T…
41.481525] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC= SRC=fe80:0000:0000:0000:f21f:afff:fe3a:b132 DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=84 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=44
57.476646] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC= SRC=fe80:0000:0000:0000:f21f:afff:fe3a:b132 DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=84 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=44
89.495395] SFW2-INext-DROP-DEFLT IN=eth0 OUT= MAC= SRC=fe80:0000:0000:0000:f21f:afff:fe3a:b132 DST=ff02:0000:0000:0000:0000:0000:0000:00fb LEN=84 TC=0 HOPLIMIT=255 FLOWLBL=0 PROTO=UDP SPT=5353 DPT=5353 LEN=44

I’ll try newest kernel and feedback later.
Thanks for your helps!

After installing the newest stable kernel, I can use OpenGL with intel driver successfully (before that I couldn’t)

Then I re-install AMD driver, it failed when building fglrx kernel. So I tried to install manually and got these error mesage: SUSE Paste

By the way, I re-checked and kernel-desktop is installed:

zypper install kernel-desktop=3.12.0-1.ge8fa6b4
Loading repository data…
Reading installed packages…
‘kernel-desktop=3.12.0-1.ge8fa6b4’ not found in package names. Trying capabilities.
‘kernel-desktop = 3.12.0-1.ge8fa6b4’ is already installed.
Resolving package dependencies…

Nothing to do.

Thanks for your helps!

By the way, after uninstall AMD driver, log-in back to OS, I got this X.org.0.log.old: SUSE Paste

Apparently you didn’t uninstall the fglrx driver completely, since X still loads it (but it fails then).

Specifically /usr/lib64/xorg/modules/linux/libfglrxdrm.so /usr/lib64/xorg/modules/drivers/fglrx_drv.so are still present.

And removing /etc/X11/xorg.conf could help, too… :wink:

Did you also install the kernel headers for 3.12? (kernel-desktop-devel)

But your paste would rather indicate that your fglrx driver is incompatible with kernel 3.12…

Which fglrx driver version did you try to install?

The latest 13.11 Beta should support kernel 3.12:
[Phoronix] AMD Catalyst Beats NVIDIA To Linux 3.12 Support](http://www.phoronix.com/scan.php?page=news_item&px=MTQ4NzM)