Extremely slow connection between a Tp-Link Archer MR600 3G/4G router and an HP notebook

Probably, this has nothing to do with Linux (or openSUSE). I am just curious.
Recently I bought a Tp-Link Archer MR600 3G/4G router; it works like a charm with whatever device (PCs, smartphones, Smart TVs, etc) and whatever operating system. There is only one exception: an HP Pavilion DV7 notebook with a Broadcom BCM43225 wireless card; speed tests report max. download speed = 1 Mbps!
Obviously, I have tested this notebook with other 4G routers (for example, a ZTE and a smartphone wifi hot spot) and it works perfectly.
I have tried to change everything in the Tp-Link configuration panel, but nothing seems to solve this weird problem.
What can it be?

Install broadcom-wl and broadcom-wl-kmp-xxxx related to your kernel-version from the Packman Repository.

Yes. It works!
How is it possible?
As far as I know, the open source driver brcmsmac is a complete replacement of broadcom-wl.
Anyway, thanks a lot Sauerland.

No, Broadcom is producing many subversions of its chips, and some of them requires closed-source Broadcom drivers.

I just had this problem solved in another thread. I downloaded only the broadcom-wl file. I went from sub 1MB to 17MB instantly. I did not go for the second file recommended since the first gave an instant boost… There are two kmp files: one designated default and the other designated pae. Which did you use? What was your final performance?

I use broadcom and have installed the driver (kmp-package) and the conf to blacklist the broadcom-drivers (broadcom-wl) shipped by the Kernel.

zypper se -si broadcom
Loading repository data...
Reading installed packages...

S  | Name                    | Type    | Version                                 | Arch   | Repository
i+ | broadcom-wl             | package |                     | x86_64 | Sauerland-kernel
i+ | broadcom-wl-kmp-default | package |  | x86_64 | (System Packages)
i+ | broadcom-wl-kmp-default | package |  | x86_64 | (System Packages)
i+ | broadcom-wl-kmp-default | package |  | x86_64 | (System Packages)
i+ | broadcom-wl-kmp-default | package | | x86_64 | Sauerland-kernel

I use kernel:stable and have 4 kernel installed so there are 4 kmps.

kernel-pae is 32 bit and only in Tumbleweed…

The kernel default should be used wherever your CPU is 64bit.
PAE(physical address extension) would be used on 32bit systems, it’s a way of extending the 32bit memory space by reserving some memory space to artificially extend beyond the real address space.