External usb camera in endoscope

I have an endoscope with camera and usb c connector. I see its image in my mobile phone using Usee app for Android.
No way to see anything connecting it to my notebook.
I installed: Guvcview, Cheese, Webcamoid.
All softwares shows image captured by notebook (internal) camera, endoscope (external) camera is not even included in available device.
Endoscope camera seems recognized by system, lsusb give this row for it:
Bus 001 Device 006: ID 2ce3:3828 Geek szitman supercamera

Unfortunately I have the same problem. If you run dimes -f you see that the camera is not recognized as UVC device Webcam …
I even tried to create a udev role (and you see the camera has the same name in my slush description but different vendor and attribute ids):
SUBSYSTEM==“video4linux”, BUS==“usb”, ATTR{idVendor}==“0329”, ATTR{idProduct}==“2022”, NAME=“video3”
but without success.
So if you got any further please let me know.

Not clear which command you run, “dimes” is not a command.

Dmesg -f

You mean “dmesg” probably.
Anyway this is what I get:

~> dmesg -f
dmesg: option requires an argument -- 'f'
Try 'dmesg --help' for more information.

Hello running „dmesg“ without options works as well.
What I meant was the option „—follow“. So you can watch the dmesg output directly when plugging in the camera. Can you post your output regarding the usb camera?

Using
~> dmesg --follow

I get this

[ 1988.697544] [    T8] usb 1-1: new high-speed USB device number 8 using xhci_hcd
[ 1988.844573] [    T8] usb 1-1: New USB device found, idVendor=2ce3, idProduct=3828, bcdDevice= 1.00
[ 1988.844586] [    T8] usb 1-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1988.844590] [    T8] usb 1-1: Product: supercamera
[ 1988.844594] [    T8] usb 1-1: Manufacturer: Geek szitman
[ 1988.844596] [    T8] usb 1-1: SerialNumber: 022018050100030

just after connecting camera.

Did anyone figure out how to get these to work with a Linux machine? I just bought two off of amazon that both have a product name of Geek szitman supercamera. I am doing some digging to figure out if it’s possible to get these to work with Linux, multiple android OTG Webcam apps work with these cameras so it’s nothing brand specific. I have de-compiled a couple of the apps that work with them. Most of them use this android library to access the camera so that seems like a good place to start, hopefully someone a little smarter than me can figure out how to port that library for use in Linux.

Hello, a linux Mint user: USB camera endoscope {solved}
https://forums.linuxmint.com/viewtopic.php?t=309829&sid=4b983142ee9037182a838888b3bcc184&start=20
post 25
guvcview can by download by openSUSE downloads

I wrote in first message I tried Guvcview (and Cheese and Webcamoid). None of them even recognize external webcam.
This solution doesn’t works for me, unfortunately.